locked
GMT off by 1 hour RRS feed

  • Question

  • We have one site on our farm that has it's regional settings set to GMT and the majority of the reset are set to U.S Central Time Zone.  What we have found strange is that times seem to be +1 hour off when uploaded to the site that is set to GMT (i.e file uploaded at 8:00AM displays 2:00PM in the site when it should be 1:00PM).  It only affects this one site and has only show up since the move to DST last month.

    We are running MOSS 12.0.0.6545.  I have verified that the servers are all set to the correct time zone and have enable DST.

    • Moved by Mike Walsh FIN Monday, April 25, 2011 3:25 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Monday, April 25, 2011 3:18 PM

All replies

  • Hi,

    Please try with following command to resolve the issue.

    stsadm -o updatealerttemplates -url <URL name>


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Tuesday, April 26, 2011 11:20 AM
  • Hi,

     

    According to your description, when the DST change occurs SharePoint is completely clueless of what happened. In generally, we had a few content deployment jobs scheduled to run every minutes. These jobs took an average of about 5 minutes to run. After this weekend these jobs started taking an average of about 1 hour and 5 minutes to run. It was too much of a coincidence for all jobs to start taking an extra hour just after the DST change. In my opinion, I suggest that you should restart the Windows SharePoint Timer Service.  For more information, please refer to this KB link:

    http://support.microsoft.com/kb/938663

     

    Best Regards
    David Hu

     

    Wednesday, April 27, 2011 1:54 AM
  • updatealerttemplates didn't work, nor did restarting the timer service.  Doesn't seem to affect our timer jobs, not that we have many custom ones.

    What seems to be affected is the createdate of the item on a site where regional settings are set to GMT.  Createdate gets stamped with a time that is 1 hour ahead of the actual GMT time.

    Monday, May 2, 2011 3:49 PM
  • I have noticed that GMT in the Windows Time Settings (Vista & 7) has three different settings, and the only one which reports the correct time, for my purposes anyway, is the Casablanca setting.  The other two report the time as one hour ahead of Zulu time.  The military uses this reference for UTC, because it's the "Z" time zone.

    You might try setting the time to the Casablanca setting, and see if that fixes the problem.

    Tuesday, September 13, 2011 11:42 AM