locked
November 2014 CU RRS feed

  • Question

  • Once I installed KB2889944 and KB2889845, my incoming email stopped working. The emails are sitting in the Drop folder but are not being picked up. Everything was working fine until I installed these updates.

    Has anyone else had this issue?

    Monday, December 1, 2014 11:38 PM

Answers

  • I have worked with Microsoft to resolve the issue. This is a temporary fix until they come out with a permanent fix.

    Set a quota for the Site Collection.  (which I had tried previously)

    The key is that you have to set both:

    • Sandboxed Solutions Resource Quota
    • Send warning e-mail when site storage reaches

    I set them both to 10 points

    After this, email starting working on that Site Collection.



    • Marked as answer by LabRat8 Tuesday, December 23, 2014 5:51 PM
    • Edited by LabRat8 Tuesday, December 23, 2014 5:54 PM
    Tuesday, December 23, 2014 5:51 PM
  • Hello,

    issue seems to be fixed in April 2015 CU:

    When you send an email message to a library in a SharePoint Server 2013 site collection, the message is not processed, and it is not picked up from the email drop folder. This issue occurs if the Sandboxed Solutions Resource Quota value for the site collection is set to 0.

    Regards!

    Thursday, April 16, 2015 9:37 AM

All replies

  • Hi LabRat,

    According to your description,  my understanding is that the imcoming email stopped working after you installing November 2014 CU.

    For troubleshooting this issue, please check the log file to find whether there are some errors about this issue. The path of the log file is: C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\LOGS.

    In addition, please go to the SharePoint Central Administration > Application Management > Configure quotas and locks > on the Site Quota Information section >  set a limit (i.e: 5000 MB) on this setting:  “Limit site storage to a maximum of:”  > and then press “OK”.

    Best Regards,

    Wendy

    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wendy Li
    TechNet Community Support

    Wednesday, December 3, 2014 3:11 AM
  • Thanks Wendy but I am using SharePoint Server 2013. I have had the quota set since the issue was discovered with the SP 2010. I thought this was fixed with the April 2012 CU.

    Anyway, I have discovered that my Root site collection is still receiving incoming email but none of the other site collections are. The only message in the log files is:

    The Incoming E-Mail service has completed a batch. The elapsed time was 00:00:00. The service processed 3 message(s) in total. Errors occurred processing 3 message(s): Message ID: Message ID: Message ID:

    There is no other detail. This is the same message as in the Event Viewer.

    I have had incoming email working on my 2013 environment for over a year. Suddenly stopped working right after installing the November CU.

    • Edited by LabRat8 Thursday, December 4, 2014 12:27 AM
    Thursday, December 4, 2014 12:25 AM
  • Hi,

    Please restart Microsoft SharePoint Foundation Incoming E-Mail service on manage services on server and restart SharePoint Timer Service on Service.msc, compare the result.

    In addition, please try to re-configure incoming email settings in Central Administration, and set the mode is Advanced.

    And re-enable incoming email in libraries.

    Best Regards,

    Wendy

    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wendy Li
    TechNet Community Support

    Thursday, December 4, 2014 2:22 AM
  • I have tried all of these things.

    Email files are still sitting in Drop folder.

    Thursday, December 4, 2014 4:07 PM
  • Thursday, December 4, 2014 4:21 PM
  • We have installed November CU this wekkend and we are having exactly the same problem. Have you manage to come up with anything?

    Thanks!

    Monday, December 15, 2014 2:50 PM
  • No I have not. I have tried all of the things that Wendy has mentioned but nothing works. Email is still stuck in the drop folder.

    Monday, December 15, 2014 4:36 PM
  • Guys,

    Have below links for your reference. It may help you.

    SharePoint 2013 Incoming Email Stuck in Drop Folder

    Solving SharePoint 2013 incoming mails stuck in Drop folder

    Thanks. Please mark it as an answer if it helps.

    Tuesday, December 16, 2014 9:19 AM
  • I have tried all of these suggestions. I only have incoming email running on one of my WFE's. This is the way it has been setup for two years.

    Everything worked fine for two years until the November CU.

    The LockType is None, I am not sure what it was before the CU.

    ********************************************************************************

    Description                 : Process incoming email.
    DisplayName                 : Microsoft SharePoint Foundation Incoming E-Mail
    Service                     : SPIncomingEmailService
    WebApplication              :
    Server                      :
    LockType                    : None
    Schedule                    : every 1 minutes between 0 and 59
    Title                       : Microsoft SharePoint Foundation Incoming E-Mail
    LastRunTime                 : 12/16/2014 2:09:26 PM
    Retry                       : False
    IsDisabled                  : False
    VerboseTracingEnabled       : False
    HistoryEntries              : {, , , ...}
    EnableBackup                : False
    DiskSizeRequired            : 0
    CanSelectForBackup          : False
    CanRenameOnRestore          : False
    CanSelectForRestore         : False
    Name                        : job-email-delivery
    TypeName                    : Microsoft.SharePoint.Administration.SPIncomingEmailJobDefinition
    Id                          : 4cc460ba-1cd6-4072-8257-bddc0bfa2007
    Status                      : Online
    Parent                      : SPIncomingEmailService
    Version                     : 668408
    Properties                  : {}
    Farm                        : SPFarm Name=SharePoint_Config
    UpgradedPersistedProperties : {}

    ********************************************************************************

    TypeName                                        Status   Id                                 

    --------                                        ------   --                                 

    Microsoft SharePoint Foundation Incoming E-Mail Disabled 537df064-c3f6-43a7-bde4-8383bbedbf81

    Microsoft SharePoint Foundation Incoming E-Mail Online   113cfd77-a676-4c13-b7fe-a7d442c5e450

    Microsoft SharePoint Foundation Incoming E-Mail Disabled 987570ae-df8b-4c06-aece-028c28e90758

    Microsoft SharePoint Foundation Incoming E-Mail Disabled 3abaa6b7-d951-4872-a8ad-d5fd1b06ff46

    Tuesday, December 16, 2014 11:17 PM
  • I've just applied the December 2014 CUs and now my incoming email is broken as well. The Config database is populated with all off the incoming email names as I would expect. I've tried playing around with setting and removing quotas and it's still broken for me.
    Friday, December 19, 2014 5:50 PM
  • I have worked with Microsoft to resolve the issue. This is a temporary fix until they come out with a permanent fix.

    Set a quota for the Site Collection.  (which I had tried previously)

    The key is that you have to set both:

    • Sandboxed Solutions Resource Quota
    • Send warning e-mail when site storage reaches

    I set them both to 10 points

    After this, email starting working on that Site Collection.



    • Marked as answer by LabRat8 Tuesday, December 23, 2014 5:51 PM
    • Edited by LabRat8 Tuesday, December 23, 2014 5:54 PM
    Tuesday, December 23, 2014 5:51 PM
  • This also worked for me. I thought I tried the sandboxed quota configuration for a site but I guess I missed the option for sending the email warming. Once that was ticked all the email stuck in my Drop folder was processed successfully.
    Saturday, December 27, 2014 11:01 PM
  • At first, it did not work when we modified our quota templates. After some testing we discovered tha refresh/reassign (to switch from quota template to individual quota and back) is needed. It has started to work again after this.
    • Edited by Chahoosa Wednesday, January 14, 2015 2:09 PM Exact solution
    Monday, December 29, 2014 3:13 PM
  • There are fixes within the Feb 2015 Public Update for Incoming Email. I'd be curious if anyone can validate that it fixes this particular issue.

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, February 10, 2015 11:41 PM
  • No, the February CU did not fix the issue. The Sandboxed quotas still need to be set.

    Thursday, February 26, 2015 7:17 PM
  • Hello,

    issue seems to be fixed in April 2015 CU:

    When you send an email message to a library in a SharePoint Server 2013 site collection, the message is not processed, and it is not picked up from the email drop folder. This issue occurs if the Sandboxed Solutions Resource Quota value for the site collection is set to 0.

    Regards!

    Thursday, April 16, 2015 9:37 AM