Error applying virtual network properties changes


  • Hello,

    I have a strange issue with virtual network. My server is System x3650 M4 and i have Hyper-V 2012 Core edition installed on it. I have 4 NIC's in it. I use one for management and one for VM's. Everything is working well until I want to enable VLAN identification for management operating system. Strange is that is greyed out if i don't have allow management.... checked. When I do that i get error message: Error applying virtual network properties changes. The operation on computer x.x.x.x failed. I can create virtual networks but can't enable vLAN.

    Can someone help with this problem. I run updates for network cards but still getting this error.

    Thursday, May 02, 2013 2:05 PM

All replies

  • When you have created a virtual switch on a NIC, and you have not allowed host access, it makes total sense that the option to set the VLAN tag would be greyed out within Hyper-V.  It's not available for use by the host, so you can't make changes that would apply to the host.  For any VM that is using that switch, you would be able to set the VLAN tag.

    As for why you get an error message when you try to switch it so that the host can have access, do you have any VMs running that are using that virtual switch at the time you are trying to change its characteristics?  Make sure all machines that are using the switch are off before trying to make such a significant change to the switch.

    .:|:.:|:. tim

    Thursday, May 02, 2013 11:31 PM
  • hi Tim,

    No, i have only one VM on it for now. That VM is off and I was created new Virtual network but get same error. Even after updating server i still get it. I really dont know what to do. This is the first time I see this error and I have successfully installed and configured many of them.

    Thing is that i cant enable vLAN when I applying virtual network to VM in VM setting not in Virtual network manager.

    • Edited by Nedim Mehic Wednesday, May 08, 2013 7:16 AM
    Wednesday, May 08, 2013 7:05 AM
  • Is there anyone who can help with this.

    When I create new virtual network and when I apply that to my VM I am not able to enable vLAN identifier i VM settings. I get that error Error applying virtual network properties changes. The operation on computer x.x.x.x failed.

    Wednesday, May 15, 2013 12:57 PM
  • Hi,

    We had the same error on our Hyper-V 2012 core server that I've been trying to troubleshoot for the last few days.

    Our problem was that we were trying to manage the Hyper-V 2012 instance using the management tools on a Vista or Windows 7 PC.  While most of the functions work OK on Vista and 7, we get the "The operation on computer x.x.x.x failed." message when trying to set the VLAN for a NIC in a VM.

    The solution has been to install a Windows 8 PC and use the management tools on this to manage the Hyper-V 2012 core server.  We're then able to set the VLAN as required.

    If a Windows 8 machine isn't available, then a workaround is to use PowerShell on the server itself.


    PS C:\> Set-VMNetworkAdapterVlan –VMName Redmond –Access –VlanId 121

    The powershell command was able to set the VLAN fine, so this is what gave me the clue that it was the management tools in Vista and 7 that were not compatible.

    Hope this helps someone else who has this same problem.

    Tuesday, October 08, 2013 9:12 PM