locked
RDP Single Sign on with Smart Cards? RRS feed

  • Question

  • Hello,

     I've got two vista machines connected to a domain. I've set up the group policy to allow credential delgation for RDP.

     If I log into machine one with a username/password, RDP correctly uses those credentials to do Single Sign On to the second machine.

     If, on the other hand, I log on with a smart card to machine 1, RDP tries to do the remote login, but comes back with an error - "No Credentials are Available in the Security Package" (0x8009030e)

    Can anyone tell me what I need to do to get SSO to work properly with smart cards?

    Thanks!
    Tuesday, June 9, 2009 6:07 PM

Answers

  • Thanks Sean.
    I got an answer from another source - apparently SSO is only supported for Username/password not Smartcards.
    Thursday, June 11, 2009 3:39 PM

All replies

  • Hi StevenTS, thanks for the post. This error seems to be the Kerberos issue, have you tried NTLM authentication method? Meanwhile, you can first try the following workaround:

     

    Shut down and then restart the computer. 

    Log off and then log on to your user account on the computer. 

     

    Also, as the issue can be related to Windows server and terminal service, you can post the issue to the following forum:

     

    http://social.technet.microsoft.com/Forums/en-US/winserverTS/threads

     

    Hope this helps!


    Sean Zhu - MSFT
    Thursday, June 11, 2009 6:51 AM
    Moderator
  • Thanks Sean.
    I got an answer from another source - apparently SSO is only supported for Username/password not Smartcards.
    Thursday, June 11, 2009 3:39 PM