locked
UAG 2010 Update Fails error 1603 RRS feed

  • Question

  • I have Forefront Unified Access Gateway Installed ver. 4.0.1101.0 on a Windows Server 2008 R2 Enterprise Edition Server with 2 Network cards and all seems to be running ok, however no matter what I try I can not get the Update 'ForefrontUAG_KB981323_ENU.msp' to run, it seems to go through the whole process and then roles back.

    I have copied the file to the C drive, running as a full administrator, tried stopping services, multiple re-boots, re-downloaded the update and nothing seems to work.

     

    Please see below for the bit of the logfile that looks to be relevant, any help would be gratefully recieved.

     

    Thanks Alan.

    UAG CA: Info: RulesetConverter.ConvertData <- Exit.
    UAG CA: Debug: SchemaConversionRuntime.CreateDataConvertersChain <- Exit.
    UAG CA: Info: Completing transaction.
    UAG CA: Info: Firing ProgressChanged event: Step: 90%, Description: 'Completing transaction.'.
    UAG CA: Info: Calling Prepare() manually.
    UAG CA: Info: Calling Commit() manually.
    UAG CA: Info: PersistanceGateway.Commit -> Enter.
    UAG CA: Info: PersistanceGateway.SaveConfigurationIntoStorage -> Enter.
    UAG CA: Debug: Calling StampSupportedSchemaAsEffective
    UAG CA: Debug: StampSupportedSchemaAsEffective return code: 0.
    UAG CA: Info: Manually saving configuration.
    UAG CA: Debug: Saving temporary registry key.
    UAG CA: Debug: Running 'Reg.exe' with the following commandLine: 'save HKLM\Software\WhaleCom\e-Gap_Conversion "C:\Users\ash\AppData\Local\Temp\gi1dgguz.lyx\Cab\Backup\WhlReg.reg" /y'.
    UAG CA: Debug: Process created, waiting for it to exit.
    UAG CA: Debug: Exit code returned from 'Reg.exe': 0.
    UAG CA: Debug: Std Output: The operation completed successfully.

    .
    UAG CA: Debug: Std Error: .
    UAG CA: Debug: Making cab: 'C:\Users\ash\AppData\Local\Temp\gi1dgguz.lyx\qbeqn5yh.0o0'.
    UAG CA: Info: Firing ProgressChanged event: Step: 0%, Description: 'Packing configuration files in a cabinet.'.
    UAG CA: Debug: Exit code returned from MakeCab.exe: 1.
    UAG CA: Debug: Setting commited event.
    UAG CA: Error: Caught error (will rethrow after rollback): Microsoft.UAG.Transformer.Util.CabinetException: Failed to create cabinet.
       at Microsoft.UAG.Transformer.Util.CabUtil.MakeCab(String sourcePath, String searchPath, String cabinetPath)
       at Microsoft.UAG.Transformer.Core.PersistanceGateway.SaveConfigurationIntoStorage()
       at Microsoft.UAG.Transformer.Core.PersistanceGateway.Commit()
       at Microsoft.UAG.Transformer.Core.SchemaConversionRuntime.Run()
    UAG CA: Info: Firing ProgressChanged event: Step: 0%, Description: 'Conversion aborted due to error, Rolling back.'.
    UAG CA: Info: Rolling-back manually.
    UAG CA: Info: PersistanceGateway.Rollback -> Enter.
    UAG CA: Info: PersistanceGateway.DeleteTempFiles -> Enter.
    UAG CA: Debug: Deleting temporary file path.
    UAG CA: Debug: Deleting temporary registry path.
    UAG CA: Info: PersistanceGateway.DeleteTempFiles <- Exit.
    UAG CA: Debug: Setting commited event.
    UAG CA: Info: PersistanceGateway.Rollback <- Exit.
    UAG CA: Info: Transaction rolled-back manually.
    UAG CA: Info: Rethrowing exception.
    UAG CA: Microsoft.UAG.Transformer.Util.CabinetException: Failed to create cabinet.
       at Microsoft.UAG.Transformer.Util.CabUtil.MakeCab(String sourcePath, String searchPath, String cabinetPath)
       at Microsoft.UAG.Transformer.Core.PersistanceGateway.SaveConfigurationIntoStorage()
       at Microsoft.UAG.Transformer.Core.PersistanceGateway.Commit()
       at Microsoft.UAG.Transformer.Core.SchemaConversionRuntime.Run()
       at UAG.CustomActions.ConfigurationSchemaConvert.InstallTask()
    UAG CA: Exiting UAG.CustomActions.ConfigurationSchemaConvert(Install)
    UAG CA: Starting UAG.CustomActions.FilterDLLsUpdate(Rollback)
    UAG CA: Opening registry subkey: 'SOFTWARE\WhaleCom\e-Gap\common\conf'
    UAG CA: Setting registry value 'UnderUpgrade = 0'
    UAG CA: Exiting UAG.CustomActions.FilterDLLsUpdate(Rollback)
    UAG CA: Exiting UAG.CustomActions.Updates(Install)
    CustomAction Update.Install returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 13:28:06: InstallFinalize. Return value 3.
    Action 13:28:06: Rollback. Rolling back action:

    Tuesday, June 8, 2010 2:19 PM

Answers

  • Hi Alan,

    Have you noticed these limitations in the Update 1 installation KB (http://support.microsoft.com/kb/981323)?

    Before you install Update 1, make sure the following conditions are true on Forefront UAG RTM servers:

    • Custom Update files are not set as read-only.
    • Spaces are not included in the names of custom update files or in the names of folders that contain custom update files.
    • Forefront UAG rules do not contain excluded rule parameter sets.

    Thanks,

            Meir :->


    Meir Mendelovich, Sr. Program Manager, Microsoft Forefront - IAG/UAG Product Group
    Team Blog: http://blogs.technet.com/edgeaccessblog/
    Anything you can do, I can do anywhere!
    • Marked as answer by Erez Benari Wednesday, June 16, 2010 11:37 PM
    Tuesday, June 15, 2010 12:42 PM
  • Hello all,

     

    Thank you for your kind replies, in the end I wiped the computer and started it again as I could not get it to work.

    After rebuilding the computer the only thing I did differently was to not customise anything, which I think was the issue even after checking all the files to make sure they weren't read only.

     

    Thanks again

     

    Alan.

     

    Wednesday, June 23, 2010 10:50 AM

All replies

  • Alan,

    I've currently researching this issue and its interesting that someone else experienced this problem as well.

    How much RAM and CPU do you have on your server?  I noticed this commonality with various test scenerios

    Also, when you see your installation bar stop moving around 90%.  Do me a favor, click the logoff button in windows.   You will get a prompt saying your doing something and cancel the logofff.  Do you see the installation continue after you did that?    If it does, you still wont be able to use UAG because of another error.  Schema Mismatch of some sort.

    Please post your findings so I can match your error being the same as the one I'm investigating

    Thank you.

     

    Tuesday, June 8, 2010 7:10 PM
  • Hi Alan,

    Have you noticed these limitations in the Update 1 installation KB (http://support.microsoft.com/kb/981323)?

    Before you install Update 1, make sure the following conditions are true on Forefront UAG RTM servers:

    • Custom Update files are not set as read-only.
    • Spaces are not included in the names of custom update files or in the names of folders that contain custom update files.
    • Forefront UAG rules do not contain excluded rule parameter sets.

    Thanks,

            Meir :->


    Meir Mendelovich, Sr. Program Manager, Microsoft Forefront - IAG/UAG Product Group
    Team Blog: http://blogs.technet.com/edgeaccessblog/
    Anything you can do, I can do anywhere!
    • Marked as answer by Erez Benari Wednesday, June 16, 2010 11:37 PM
    Tuesday, June 15, 2010 12:42 PM
  • Hello all,

     

    Thank you for your kind replies, in the end I wiped the computer and started it again as I could not get it to work.

    After rebuilding the computer the only thing I did differently was to not customise anything, which I think was the issue even after checking all the files to make sure they weren't read only.

     

    Thanks again

     

    Alan.

     

    Wednesday, June 23, 2010 10:50 AM
  • Dennis,

     

    I wasn't getting an error message, but my installation was hanging at around 90% as well.  I clicked log off, and just as you said it picked right up.  I did get the schema mismatch error.  Did you ever find a solution to that problem?

     

    Thanks!

    -Victoria

    Wednesday, June 23, 2010 5:06 PM
  • Victoria,

    I did the following to three different UAG boxes and it seemed to have fixed the error.

    Run "CMD" as administrator

    cd to the directory and call the .msp from there.

    For unknown reasons, double-clicking the .msp even while logged in as a domain administrator did not help.  But yeah, it sounds like you go the same error as myself.

    Thanks,
    Dennis

     

     

    Wednesday, June 23, 2010 7:08 PM
  • Same issue as all of you.

    1603

    No customupdates
    Did not work when I ran from an elevated CMD.

    Tried the logof but then ended up with the schema problem.

    Not solved yet. Any suggestions?

    Wednesday, July 14, 2010 11:00 PM
  • Hi There,

    We had the same issue, finally it seemed to be caused by some old trunks we had been testing with and deleted sometime ago, they indeed contained a custom update file with a space in the name. So when the trunk was deleted not everything was removed from the filesystem, we manually had to remove some remaining files from the trunks.

    Thursday, July 15, 2010 7:13 AM
  • I struggled with this for months, even opened a ticket with MS.  After months of work and not just a little frustration, it was resolved in 2 seperate steps.

     

    1) Download Update2

    2) Stop ALL UAG services and IIS. 

     

    As many know, Whale/IAG/UAG is good out the door, but spent alot of time researching and customizing the interface and language files and to be told that it's the updates that are killing the install, well, <shrug> not acceptible is about as nice as it gets.

    Tuesday, December 7, 2010 10:27 PM
  • I still had the same iss on a few appliances.

    Had to run the following a VB script:

    set fpc = CreateObject("FPC.ROOT")
    set arr = fpc.GetContainingArray
     
    For Each srv in arr.Servers
      WScript.Echo "Removing SP1-specific filters from server " & srv.Name
      srv.InstalledWebFilters.RemoveSpecified "{9599218C-CCE6-4C39-B0DB-A0F2DFF0C486}"
    Next
     
    WScript.Echo "Saving..."
    arr.Save

    Then run the SP install.  During the install, sometimes I would be told it could not complete, and to reboot, and I would that and then rerun the install.  On one occasion, I had to do this 4 times before the install would complete, but I just had to be persistant.

    • Proposed as answer by JGBoake Monday, February 13, 2012 3:37 PM
    Monday, February 13, 2012 3:37 PM
  • ...and now I have the same issue with SP2...MS involved...will update when resolved.
    Friday, August 24, 2012 2:23 PM
  • I have the same issue on two UAG. Both fail to upgrade to SP2 however my error is a Timeout Exception.

    Do you have the cabinet creation error on SP2 or a different one?

    UAG CA (Info): Info: PersistanceGateway.Commit <- Exit.
    UAG CA (Info): Info: Transaction completed manually.
    UAG CA (Info): Error: Transaction aborted. Throwing innner-exception: System.TimeoutException: Transaction Timeout
    UAG CA (Info): Info: Firing ProgressChanged event: Step: 0%, Description: 'Conversion aborted due to error, Rolling back.'.
    UAG CA (Info): Info: Rolling-back manually.
    UAG CA (Info): Info: PersistanceGateway.Rollback -> Enter.
    UAG CA (Info): Info: PersistanceGateway.DeleteTempFiles -> Enter.
    UAG CA (Info): Debug: Deleting temporary file path.
    UAG CA (Info): Warning: Caught directoryNotFoundException (ignored): Could not find a part of the path 'C:\Users\administrator\AppData\Local\Temp\13p3402x.0n4'.
    UAG CA (Info): Info: PersistanceGateway.DeleteTempFiles <- Exit.
    UAG CA (Info): Debug: Setting commited event.
    UAG CA (Info): Info: PersistanceGateway.Rollback <- Exit.
    UAG CA (Info): Info: Transaction rolled-back manually.
    UAG CA (Info): System.TimeoutException: Transaction Timeout
       at Microsoft.UAG.Transformer.Core.SchemaConversionRuntime.Run()
       at UAG.CustomActions.ConfigurationSchemaConvert.InstallTask()
    UAG CA (Info): Exiting UAG.CustomActions.ConfigurationSchemaConvert(Install)
    UAG CA (Info): Starting UAG.CustomActions.FilterDLLsUpdate(Rollback)
    UAG CA (Info): Opening registry subkey: 'SOFTWARE\WhaleCom\e-Gap\common\conf'
    UAG CA (Info): Setting registry value 'UnderUpgrade = 0'
    UAG CA (Info): Exiting UAG.CustomActions.FilterDLLsUpdate(Rollback)
    UAG CA (Info): Exiting UAG.CustomActions.Updates(Install)
    CustomAction Update.Install returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 10:58:32: InstallFinalize. Return value 3.
    Action 10:58:32: Rollback. Rolling back action:

    Sunday, August 26, 2012 10:27 AM
  • Looks simular to me:

    UAG CA (Info): Info: PersistanceGateway.Commit <- Exit.
    UAG CA (Info): Info: Transaction completed manually.
    UAG CA (Info): Error: Transaction aborted. Throwing innner-exception: System.TimeoutException: Transaction Timeout
    UAG CA (Info): Info: Firing ProgressChanged event: Step: 0%, Description: 'Conversion aborted due to error, Rolling back.'.
    UAG CA (Info): Info: Rolling-back manually.
    UAG CA (Info): Info: PersistanceGateway.Rollback -> Enter.
    UAG CA (Info): Info: PersistanceGateway.DeleteTempFiles -> Enter.
    UAG CA (Info): Debug: Deleting temporary file path.
    UAG CA (Info): Warning: Caught directoryNotFoundException (ignored): Could not find a part of the path 'C:\Users\JEGSVCUAG\AppData\Local\Temp\g5g1vews.iwf'.
    UAG CA (Info): Info: PersistanceGateway.DeleteTempFiles <- Exit.
    UAG CA (Info): Debug: Setting commited event.
    UAG CA (Info): Info: PersistanceGateway.Rollback <- Exit.
    UAG CA (Info): Info: Transaction rolled-back manually.
    UAG CA (Info): System.TimeoutException: Transaction Timeout
       at Microsoft.UAG.Transformer.Core.SchemaConversionRuntime.Run()
       at UAG.CustomActions.ConfigurationSchemaConvert.InstallTask()
    UAG CA (Info): Exiting UAG.CustomActions.ConfigurationSchemaConvert(Install)
    UAG CA (Info): Starting UAG.CustomActions.FilterDLLsUpdate(Rollback)
    UAG CA (Info): Opening registry subkey: 'SOFTWARE\WhaleCom\e-Gap\common\conf'
    UAG CA (Info): Setting registry value 'UnderUpgrade = 0'
    UAG CA (Info): Exiting UAG.CustomActions.FilterDLLsUpdate(Rollback)
    UAG CA (Info): Exiting UAG.CustomActions.Updates(Install)
    CustomAction Update.Install returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 10:12:34: InstallFinalize. Return value 3.
    MSI (s) (28:2C) [10:12:34:364]: User policy value 'DisableRollback' is 0

    Tuesday, August 28, 2012 2:41 PM
  • I have sent the verbose logfile to MS to investigate, but this is the same issue I have had running SP1.  We will see.
    Tuesday, August 28, 2012 2:55 PM
  • I'm getting a 1603 as well

    UAG CA (Info): Info: PersistanceGateway.DeleteTempFiles <- Exit.
    UAG CA (Info): Debug: Setting commited event.
    UAG CA (Info): Info: PersistanceGateway.Commit <- Exit.
    UAG CA (Info): Info: Transaction completed manually.
    UAG CA (Info): Error: Transaction aborted. Throwing innner-exception: System.TimeoutException: Transaction Timeout
    UAG CA (Info): Info: Firing ProgressChanged event: Step: 0%, Description: 'Conversion aborted due to error, Rolling back.'.
    UAG CA (Info): Info: Rolling-back manually.
    UAG CA (Info): Info: PersistanceGateway.Rollback -> Enter.
    UAG CA (Info): Info: PersistanceGateway.DeleteTempFiles -> Enter.
    UAG CA (Info): Debug: Deleting temporary file path.
    UAG CA (Info): Warning: Caught directoryNotFoundException (ignored): Could not find a part of the path 'C:\Users\administrator.SCMA\AppData\Local\Temp\m0h1h5mk.ptz'.
    UAG CA (Info): Info: PersistanceGateway.DeleteTempFiles <- Exit.
    UAG CA (Info): Debug: Setting commited event.
    UAG CA (Info): Info: PersistanceGateway.Rollback <- Exit.
    UAG CA (Info): Info: Transaction rolled-back manually.
    UAG CA (Info): System.TimeoutException: Transaction Timeout
       at Microsoft.UAG.Transformer.Core.SchemaConversionRuntime.Run()
       at UAG.CustomActions.ConfigurationSchemaConvert.InstallTask()
    UAG CA (Info): Exiting UAG.CustomActions.ConfigurationSchemaConvert(Install)
    UAG CA (Info): Starting UAG.CustomActions.FilterDLLsUpdate(Rollback)
    UAG CA (Info): Opening registry subkey: 'SOFTWARE\WhaleCom\e-Gap\common\conf' 
    UAG CA (Info): Setting registry value 'UnderUpgrade = 0'
    UAG CA (Info): Exiting UAG.CustomActions.FilterDLLsUpdate(Rollback)
    UAG CA (Info): Exiting UAG.CustomActions.Updates(Install)
    CustomAction Update.Install returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    Action ended 10:53:48: InstallFinalize. Return value 3.


    Brandt Smith


    • Edited by bsmith9 Friday, September 7, 2012 5:12 PM
    Friday, September 7, 2012 5:08 PM
  • Hello,

    I had similar issue today and it seems there is a solution. Please see KB2811066 for more details.

    Ophir.

    ---

    Ophir Polotsky - Aman Group

    Sunday, April 7, 2013 12:56 PM
  • Had the same issue with the latest SP. After 4 tries it suddenly installed for the full 100% and didnt rolled back.
    Sunday, April 7, 2013 6:19 PM
  • Saturday, November 30, 2013 1:25 PM