locked
Internal and External Domain names+Exchange RRS feed

  • Question

  • Hello,

    I am setting up an exchange server for the first time for testing and Ihave the following :

    I have an extrernal domain "external.com" and an internal domain "mailtest.prs"

    I have created mx records on our isp to point to my external firewall.

    Nslookup -type=mx external.com gives the correct answers.

    If I send a mail to my google account it arrives from "mail1@mailtest.prs" if I reply I get dns errors (Obviously as no mx record exists for mailtest)

    Is it possible to make exchange use the @external.com domain when sending rather than then mailtest.prs domain
    Wednesday, May 30, 2012 9:04 AM

Answers

  • No, you don't need an edge server.  Just add the accepted domain and create an email address policy.  This can be done in Exchange Management Console, Organisation Tree -> Hub Tansport
    Wednesday, May 30, 2012 10:34 AM

All replies

  • Hi

    You need to add external.com as an accepted domain and then create an email address policy that includes this domain.

    http://technet.microsoft.com/en-us/library/bb124423.aspx

    Cheers, Steve

    Wednesday, May 30, 2012 9:09 AM
  • From reading the article I assume I need an Edge server setup, which I dont have! is there another way to do this?

    Thanks for your time eith this!

    REgards

    WG

    Wednesday, May 30, 2012 10:02 AM
  • No, you don't need an edge server.  Just add the accepted domain and create an email address policy.  This can be done in Exchange Management Console, Organisation Tree -> Hub Tansport
    Wednesday, May 30, 2012 10:34 AM
  • Excellent thanks a lot, another question, if i want to use OWA what domain would i set in external host name , external.com or mailtest.com? When setting up OAB and virtual directories would I use the same hostname as the above?

    Thanks

    WG

    Wednesday, May 30, 2012 11:53 AM
  • No worries.

    You should use the external.com domain for all external URLs, perhaps as mail.external.com.  You will need a DNS record for autodiscover.external.com too and a certificate that contains both of these names at least.


    Wednesday, May 30, 2012 12:04 PM
  • Ok how do i go about doing the below please, sorry first time setting up an exchange box!

    You will need a DNS record for autodiscover.external.com too and a certificate that contains both of these names at least.

    WG

    Wednesday, May 30, 2012 12:14 PM
  • It's no problem.  There is an excellent guide from Microsoft which could help with a first time set-up: http://technet.microsoft.com/en-us/exdeploy2010/default.aspx#Index

    More information on certificates here: http://technet.microsoft.com/en-us/library/dd351044.aspx

    Wednesday, May 30, 2012 12:31 PM
  • Hello Again, Thankyou all for your help I now have exchange up and running and am able to send and recieve mail, internally and externally. I have another slight problem, i am trying to get owa working, it works  when using the following url https://<server name> or <ip address>/owa but if i try to access it using the externalurl which is https://mail.princerupertschool.com/owa i get "internet explorer cant display the webpage".

    My external domain is princeupertschool.com, and when setting up the cas and owa stuff I used the mail.princerupertschool.com as the external fqdn, im assuming that this is wrong, any shoves in teh right direction greatly appreciated.

    Cheers

    Wayne Gillard

    Tuesday, June 26, 2012 8:40 AM