locked
Response Group Forward to Telephone Number RRS feed

  • Question

  • I am trying to configre an RG to overflow to external cell numbers, but i get the "user does not exist" but i need this to obviously go out the gateway,

    Here are the logs

    TL_INFO(TF_PROTOCOL) [3]0AB0.1FBC::02/09/2012-19:06:33.815.001cc161 (SIPStack,SIPAdminLog::TraceProtocolRecord:SIPAdminLog.cpp(125))$$begin_record

    Trace-Correlation-Id

    Instance-Id

    Direction

    Peer

    Message-Type

    Start-Line

    From

    To

    CSeq

    Call-ID

    Via

    ms-diagnostics

    Server

    Content-Length

    Message-Body

    :
    : 0
    : RTC/4.0
    : 1003;reason="User does not exist";TargetUri="+12895555555@domain.ca";source="csse.domain.local"
    : SIP/2.0/TLS 192.168.111.30:54057;branch=z9hG4bK26ae66d4;ms-received-port=54057;ms-received-cid=28D6900
    : 500a365571bb4799acaa53b598f60ad9
    : 143132 SERVICE
    : <sip:+12895555555@domain.ca;user=phone>;tag=A6BFFA9EE5D38A64EAB35DB70BC9E6A4
    : SIP/2.0 404 Not Found: <sip:+12895555555@domain.ca;user=phone>;epid=D33D80EF67;tag=fd5bc138b5
    : response
    : csse.domain.local:54057
    : outgoing;source="local"
    : 0046D493
    : 1423529859

    $$end_record

    TL_INFO(TF_PROTOCOL) [1]292C.2878::02/09/2012-19:06:33.810.001cc122 (S4,SipMessage.DataLoggingHelper:sipmessage.cs(613))[3301002505]

    >>>>>>>>>>>>Outgoing SipMessage c=[<SipTlsConnection_530BBC>], 192.168.111.30:54057->192.168.111.30:5061

    SERVICE sip:+12895555555@domains.ca;user=phone SIP/2.0

    FROM

    TO

    CSEQ

    CALL-ID

    MAX-FORWARDS

    VIA

    CONTACT

    CONTENT-LENGTH

    SUPPORTED

    USER-AGENT

    CONTENT-TYPE

    <?xml version="1.0" encoding="us-ascii"?><reportError xmlns="http://schemas.microsoft.com/2006/09/sip/error-reporting"><error callId="eeb0dd5c-8116-4fb9-9895-241f24254be5" fromUri="sip:9055222222;phone-context=SITE@domain.ca;user=phone" toUri="sip:+12895555555@domain.ca;user=phone" fromTag="a05154ad2d" toTag="A6BFFA9EE5D38A64EAB35DB70BC9E6A4" requestType="INVITE" contentType="application/sdp;call-type=audio" responseCode="400"><diagHeader>1;reason="Service Unavailable";AppUri="http%3A%2F%2Fwww.microsoft.com%2FLCS%2FOutboundRouting";reason="Failed when constructing the outgoing request";source="csse.domain.local"</diagHeader><progressReports /></error></reportError>------------EndOfOutgoing SipMessage

    : application/msrtc-reporterror+xml
    : RTCC/4.0.0.0 MediationServer
    : gruu-10
    : 723
    : <sip:csse.domain.local@domain.ca;gruu;opaque=srvr:MediationServer:1TGI9_v-pVqK8KGtZSLOKgAA>;isGateway
    : SIP/2.0/TLS 192.168.111.30:54057;branch=z9hG4bK26ae66d4
    : 70
    : 500a365571bb4799acaa53b598f60ad9
    : 143132 SERVICE
    : <sip:+128955555556@domain.ca;user=phone>
    : <sip:+12895555555@domains.ca;user=phone>;epid=D33D80EF67;tag=fd5bc138b5
    AND this

    If this post answered your question, Mark As Answer If this post was helpful, Vote as Helpful

    • Moved by Noya Lau Thursday, February 16, 2012 5:46 AM (From:Lync Clients and Devices)
    Thursday, February 9, 2012 7:13 PM

Answers

  • Try adding ";user=phone" to the end of the SIP URI without the quotes. I.E. sip:+12895555555@domain.ca;user=phone

    Also, make sure that you apply a Voice Policy to the RGS Workflow contact object that is permitted to call this external number.

    • Marked as answer by Tim_MCP Sunday, February 19, 2012 3:44 PM
    Thursday, February 9, 2012 9:38 PM
  • Hi Tim,

    In this cmdlet, the PolicyName parameter is the name of the voice policy to be assigned to the user.

    Please note, this includes only the name portion of the Identity. Per-user policy identities include a prefix of tag and that should not be included with the PolicyName.

    You can refer to this document, hope helps.


    Noya Liu

    TechNet Community Support

    • Proposed as answer by Noya Lau Sunday, February 19, 2012 8:52 AM
    • Marked as answer by Tim_MCP Sunday, February 19, 2012 3:44 PM
    Thursday, February 16, 2012 5:42 AM

All replies

  • Try adding ";user=phone" to the end of the SIP URI without the quotes. I.E. sip:+12895555555@domain.ca;user=phone

    Also, make sure that you apply a Voice Policy to the RGS Workflow contact object that is permitted to call this external number.

    • Marked as answer by Tim_MCP Sunday, February 19, 2012 3:44 PM
    Thursday, February 9, 2012 9:38 PM
  • Thanks for the reply Jamie,

    When i try to assign my voice policy to the RG i get this error

    Grant-CsVoicePolicy : Policy "Site:Policy Name" is not a user policy. You can assign only a user policy to a specific user.
    At line:1 char:85
    + Get-CsApplicationEndpoint -Identity "Main Menu - Inbound Call" | Grant-CsVoic
    ePolicy <<<<  -PolicyName "Site:Voice Policy"
        + CategoryInfo          : InvalidOperation: (CN={5b8f2a9d-d4...onstra,DC=l
       ocal:OCSADUserOrAppContact) [Grant-CsVoicePolicy], ManagementException
        + FullyQualifiedErrorId : GrantPolicy,Microsoft.Rtc.Management.AD.Cmdlets.
       AssignOcsVoicePolicyCmdlet


    If this post answered your question, Mark As Answer If this post was helpful, Vote as Helpful

    Monday, February 13, 2012 9:07 PM
  • Hi Tim,

    In this cmdlet, the PolicyName parameter is the name of the voice policy to be assigned to the user.

    Please note, this includes only the name portion of the Identity. Per-user policy identities include a prefix of tag and that should not be included with the PolicyName.

    You can refer to this document, hope helps.


    Noya Liu

    TechNet Community Support

    • Proposed as answer by Noya Lau Sunday, February 19, 2012 8:52 AM
    • Marked as answer by Tim_MCP Sunday, February 19, 2012 3:44 PM
    Thursday, February 16, 2012 5:42 AM
  • Thanks for the reply, worked. I did not focus on what types of policies where there. Only Site Policies :)

    I created a new "User" Voice policy. added normalization for the numbers i wanted the RGS to dial out. Then PowerShell

    Get-CsApplicationEndpoint -Identity "Response Group Name" | Grant-CsVoicePolicy -PolicyName "Response Group Voice Policy"

    Works Great!


    If this post answered your question, Mark As Answer If this post was helpful, Vote as Helpful http://lyncme.blogspot.com

    Sunday, February 19, 2012 3:43 PM
  • Why this is not a selection in the workflow config perplexes me. This fixed my issue too. Thanks for the post.

    btw, just doing the "Grant-CsVoicePolicy" with the name of the RG as the identity did complete in Powershell but did not fix the issue. Only when I added the Get-CsApplicationEndpoint prior to the Grant-CsVoicePolicy did it start working.

    Rick Phillips

    University of Kentucky

    Thursday, April 5, 2012 6:41 PM