none
MDT image deployment fails after adding applications RRS feed

  • Question

  • I've been trying to use MDT (ie deployment workbench 6.2.5019.0) to build and deploy images for quite some time now, and I am having a lot of difficulty deploying images to target computers.  I've successfully built a reference image in a VM with all the Win7 updates.  I can deploy that image to HP z820 workstations while injecting drivers.  Then I've tried two ways of adding applications, capturing that image and then re-deploying it to other target machines.

    First, I run a standard client task sequence that will deploy and capture an image to a target machine.  I put in a suspend command in the task sequence.  I can then add applications and then restart the task sequence.  If I don't add applications, and I just let the task sequence do it's magic, inject drivers, add any remaining Windows updates, and then just resume, MDT will capture the image.  I can then add it to my deployment share and then deploy it back to my target machine that it came from or any other similar target.  On the other hand, if I add all my applications during the suspend, MDT will capture the image, but subsequent deployments of the image will always fail on the target machine during Windows setup.

    Second, I can deploy the reference image to a target, let the sequence finish, add the apps, then run a sysprep and capture task sequence.  I finally got that to work.  I have an image with apps that I can deploy.  However, I go to a target machine that image was deployed to, I added for example Office and Winzip.  Then I run the same sysprep and capture sequence, capture the image, and when I deploy that image back, it hangs while setup is installing devices.

    Why am I having so much trouble just adding applications to an image that deployed perfectly fine before, but once I add apps, I can no longer use the same task sequences to capture and deploy?  These same task sequences will capture and deploy the image without the apps, but not with the apps.  I don't get it.

    So, what's so special about adding applications, and also can anyone give me a good reference for troubleshooting deployment issues where sysprep and setup fail for whatever reason?

    Friday, December 20, 2013 3:28 PM

Answers

  • Hmmm... Applications should not cause hangs when installing drivers. In fact NOTHING should cause a hang like that... except for a bad driver. Go back and go through you driver manifest with a fine tooth comb and find the bad driver. That may include removing all of your 3rd party drivers.

    Keith Garner - keithga.wordpress.com

    Monday, December 30, 2013 4:51 AM
    Moderator