Windows Server 2012 Backup stops working on Virtual Machine with SharePoint 2013 after SQL Server 2012 is installed.


  • I have a virtual machine running Windows Server 2012 and installed Windows Server Backup.  My daily backups were working without any problems for several days.

    I then installed SharePoint 2013 and my backups continued to work without any problems for several more days.

    I then installed SQL Server 2012 and my backups immediately started failing with the error message saying:

    Detailed error: The system writer is not found in the backup.

    I then uninstalled SQL Server 2012, but I continue to get the same error.

    Any help on how I can get my backups to work again would be greatly appreciated ... Especially if this help includes figuring out a way for Windows Server 2012, SharePoint 2013 and SQL Server 2012 to work together.

    Thanks, Dean

    Thursday, September 26, 2013 10:30 PM

All replies

  • I believe that there is no problem with SQL SERVER. Please see this link:

    System State backup using Windows Server Backup fails with error: System writer is not found in the backup


    Saeid Hasani,

    Download Books Online for SQL Server 2012

    Thursday, September 26, 2013 11:03 PM
  • Hello,

    You need to run the following command to be able to backup SharePoint:

    stsadm -o registerwsswriter

    If you are using SharePoint, the best way to get a backup of SharePoint without losing data is to perform the following procedure:

    Although Windows Backup can be used on SharePoint single server environments.

    Hope this helps.


    Alberto Morillo

    Friday, September 27, 2013 12:54 AM
  • Hi Saeid,

    Thank you for your reply.

    I followed the instructions from the link you provided, but I am still getting the original error I described in my initial post and my Event Log does not contain the entry the link says to look for when the system writer is not in the list returned from the 'vssadmin list writers' command.

    The reason why I posted to the 'SQL Server Setup & Upgrade' forum is because this error started immediately after I installed SQL Server 2012 on one of my Virtual Machines configured with Windows Server 2012 and SharePoint 2013.

    SQL Server 2012, by itself, is probably not the sole reason for this error ...

    So, I thought is was important in my initial post to mention I am running Windows Server 2012 and that SharePoint 2013 is also installed on this Virtual Machine.  The Windows Server Backup was running daily without any errors on this VM before specifically installing SQL Server 2012.

    Therefore, it appears there is something caused by the combination of at least 2 specific products ... 1) SharePoint 2013 and 2) SQL Server 2012 ... The combination of these 2 products seem to be causing the error.

    Friday, September 27, 2013 3:29 AM
  • Hi Alberto,

    Thanks for your suggestion.

    I ran the 'stsadm -o registerwsswriter' command and unfortunately, I am still getting the same error.

    Friday, September 27, 2013 4:53 AM
  • I would check the logs as shown here

    and then go on to fix VSS using one of these strategies:

    It's possible that the VM is vetoing the backup. Have a look at all Event Viewer logs (App & Sys) on host as well as VMs.


    Octavio, Tech Support for


    Friday, September 27, 2013 3:43 PM