none
Problems with Office 365 - Mailrouting?!

    Question

  • Hello,

    well as u can see here: https://community.office365.com/en-us/f/158/t/415263?pi14985=2

    I got a problem with the mailflow.

    UserA@domainA.com was moved vom on premise to exchange online.

    UserB@domainA.com is still on premise.

    UserA can send mails. And can get mails. From external or on premise.

    UserB can send mails. Gets mails from on premise users. Not from external. They get an error. Also can't get an email from UserA.

    Ok, now we did some configurations in office 365 and the local exchange.

    Now I'm getting this error:

    Diagnostic information for administrators:

    Generating server: AM2PR09MB0003.eurprd09.prod.outlook.com
    Receiving server: AM2PR09MB0003.eurprd09.prod.outlook.com 

    mouse@roschmann.us
    11/5/2015 4:57:11 PM - Server at AM2PR09MB0003.eurprd09.prod.outlook.com returned '550 4.4.7 QUEUE.Expired; message expired'
    11/5/2015 4:49:00 PM - Server at emea01-internal.map.protection.outlook.com (10.47.216.27) returned '441 4.4.1 Error encountered while communicating with primary target IP address: "Failed to connect. Winsock error code: 10061, Win32 error code: 10061." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts. The last endpoint attempted was xxx.xxx.xxx.xxx:1701'

    Original message headers:

    So I think its a problem with our local config. Well: The exchange server is behind a firewall. Are there any port forwardings needed? I thought exchange online and on premise are talking over SMTP?

    Thanks!

    Monday, November 16, 2015 11:36 AM

All replies

  • Winsock error 10061 means connection refused, so definitely take a look at your firewall and make sure external systems (or only EO) can reach you on-prem server. Port 25 namely.
    Monday, November 16, 2015 4:53 PM
  • Hi,

    Please check your NIC settings and make sure it is correct. Additionally, please open port 25 and add Exchange Online ip address and URL to firewall exceptions.

    https://technet.microsoft.com/en-us/library/dn751020(v=exchg.150).aspx

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    Tuesday, November 17, 2015 7:12 AM
    Moderator
  • Hi,

    please check account that is moved to Exchange online if it has correct remote routing address.

    Since you successfully migrated user to Exchange online, then I guess Hybrid config has been setup successfully?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Tuesday, November 17, 2015 7:27 AM
  • Hi,

    well I think the problem is that the error shown IP Address is not the IP Address our exchange is reachable with SMTP. We got it like this:

    mail.domain.com -> Public static IP 1 -> SMTP Port to Exchange

    activesync.domain.com -> Public static IP 2 -> ActiveSync Port to Exchange

    oa.domain.com -> Public static IP 2 -> Outlook Anywhere Port to Exchange

    owa.domain.com -> Public static IP 2 -> Outlook Web Apps Port to Exchange

    And Exchange Online tries to route through the static IP 2 instead of 1.

    Tuesday, November 17, 2015 7:47 AM
  • Romote Routing Address? You mean the SMTP Address? Yes its correct.

    Hybrid config setup was successfull.

    So now I made a Rule in TMG (Which is reachable under IP Address 2) also with SMTP to our exchange. Mail didnt come. But it needs days before I get the error message.

    Also wondering that the error message tells something about port 1701?

    Tuesday, November 17, 2015 7:57 AM
  • Remote routing address is additional SMTP alias. This is the one that route message to office365 mailbox.It should be in format username@domain.mail.onmicrosoft.com

    This can be found on same page as email addresses in ECP.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Tuesday, November 17, 2015 8:45 AM
  • Hi,

    I Added this mailadress. But... didnt fix the problem. Also the problem is not that the mail is not routed to office 365 mailbox. It can't be routet to the on premise server.

    Still wondering about the port 1701!


    • Edited by r33n Monday, November 30, 2015 4:22 PM
    Monday, November 30, 2015 4:19 PM