locked
Task Scheduler won't talk to XP RRS feed

  • Question

  • Hi,

    When I use the Windows 7 task scheduler to try and access tasks on any remote XP PC, I get:

    "You do not have permission to access this computer."

    I have full admin rights to such PCs and can perform other remote admin functions successfully.

    Why doesn't this work in Windows 7?

    Thanks,

    Rob

    P.S. Naturally, this works ok to another Windows 7 PC and if I log onto an XP PC with the same user it works to the same XP machine.





    • Edited by Rob.Ford Sunday, November 29, 2009 11:40 PM Added P.S.
    Sunday, November 29, 2009 11:38 PM

All replies

  • If it helps, there's hope:

    I tried connecting from Windows 7 (Ultimate retail) to my XP Pro 32 bit SP3 laptop and it actually connected okay.  However it wouldn't show me anything for about 30 seconds, then finally filled in the data.  I had just awakened it from sleep mode, so maybe all of the network stack wasn't quite up right away.

    I tried connecting from Windows 7 to Vista x64, and was successful, though I had to temporarily disable the Windows firewall on the Vista x64 system to do it.  I'm sure there's an exception for that.

    I assume you have no firewall issues, because you're able to connect from another XP system.

    FYI, no domain here, just simple Windows workgroup networking.  Same username and password as the logged-in user on my Windows 7 system exists on all systems.  As I recall I tweaked the XP system years ago to use advanced networking (e.g., so the full sharing capability shows up in the Properties dialog).  I don't recall the specifics of that, but it did take some research.

    Only other thing I've done that could possibly remotely bear on this is that I have disabled the Homegroup services on my Windows 7 machine.

    -Noel


    P.S., while attempting to connect to my Vista system, before the firewall was off, I once got a message along the lines of "Can't connect to a system older than Vista with a different username / password".

    Monday, November 30, 2009 1:51 AM
  • Noel, just in case, I disabled Windows Firewall at both ends (I have pretty much all admin exceptions set-up but you never know) and it still fails.

    I also thought it might be to do with the file and printer sharing options, as XP tasks are "shared" as "Scheduled Tasks" but no luck there, either.

    Nice to know it works for you, so at least the mechanism should be ok (although, yes, domain setup here).

    If I work it out, I'll update this post.
    Monday, November 30, 2009 3:26 AM
  • The domain setup has me worried in this case.  I can almost envision how an errant programmer at Microsoft might think that a domain user is "a different user" and the limitations of that last message I mentioned above apply.  Let's hope not.

    A possible (though not well-integrated) workaround might be to run the task manager in a virtual XP session.

    -Noel

    Monday, November 30, 2009 4:16 AM
  • run gpedit.msc and configure Computer Configuration\Security Settings\Local Policies\Security Options
    to use the DES-CBC-MD5 or DES-CBC-CRC cipher suites
    run gpupdate /force and try with ur schedule task again
    http://technet.microsoft.com/en-us/library/dd560670%28WS.10%29.aspx

    hope that helps!
    Tuesday, December 1, 2009 1:44 PM
  • Hi Is01c, I have no setting called "Configure encryption types allowed for Kerberos" as that article describes in that location or any other location in Windows 7 local policy, 2008 R2 local policy or Group Policy (when viewed from the Windows 7 RSAT gpmc.msc).

    Our AD is still 2003 based, is this setting only available via group policy and only after adprep32 has been run?
    Tuesday, December 1, 2009 8:18 PM
  • can you first try to configure the local policy of your win7 machine and retry the task again?
    Wednesday, December 2, 2009 2:17 AM
  • Wednesday, December 2, 2009 5:00 AM
  • can you first try to configure the local policy of your win7 machine and retry the task again?
    As I mentioned, the specified setting simply does not exist in local or group policy, but I'll take a look at those 2 articles, thanks.
    Thursday, December 3, 2009 6:18 AM
  • hi, you can configure it on your win7 machine. which win7 version you are using? home/ultimate/pro ?
    in your win7 local machine, run gpedit.msc
    go to
    Computer Configuration\ Windows Settings\ Security Settings\ Local Policies\ Security Options
    select the Network security: Configure encryption types allowed for Kerberos option.
    select the first 3 DES and RC4

    please try that out. thanks.

    btw, can you elaborate a bit of the task you wish to do between win7 and XP?
    so that i can do a test here.
    Thursday, December 3, 2009 6:26 AM
  • <slaps head>

    Sorry, I mis-read the article and was looking for a setting called "Configure encryption types allowed for Kerberos" and not "Network security: Configure encryption types allowed for Kerberos".

    OK, I've set these and done a gpupdate /force and even a reboot and still no luck.

    This is using Windows 7 Pro or Enterprise 32-bit.

    All I am trying to do is remotely look at tasks from Windows 7 on XP.

    For example, open "Scheduled Tasks", right-click "Task Scheduler (Local)", Connect to another computer, enter an XP system get "You do not have permission to access this computer.".

    However, I can find no other remote administration tasks that don't work from Windows 7 to the same PC...
    Wednesday, December 9, 2009 1:11 AM
  • I am having exactly the same problem viewing scheduled tasks on XP machines from my Win7 Enterprise (x86) box.  I am also in a domain environment.  I have full administrative access to the remote machines in all other conceivable ways.  What's going on?
    Thursday, January 28, 2010 3:34 PM
  •   What's going on?

    Microsoft never tested it on XP!
    Thursday, January 28, 2010 8:32 PM
  • Did you spot this thread already Rob?
    http://social.technet.microsoft.com/forums/en-US/itprovistaapps/thread/bd49657a-628e-4f7d-abc0-3300f1e480c5/

    The problem has existed since Vista.  Words just fail me.
    Friday, January 29, 2010 8:29 AM
  • I did everything suggested here, enabling the Kerberos in the Win7 machine, restarting the machine and I have still no luck.

    Is there a way to fix this?

    Does MS read this forum?

    Tuesday, August 17, 2010 5:46 PM
  • Hi IanB - I solved the problem by rolling out Windows 7 to all of our PCs :P

     

    Tuesday, August 17, 2010 10:18 PM
  • is there a real fix for this yet? One of my users is going crazy because he can no longer manager xp machines scheduled tasks remotely... I dont want to have to downgrade him back to xp just for this one feature. Any 3rd party apps that can do this if MS no longer supports this?
    Wednesday, January 26, 2011 9:37 PM
  • You could try setting your user up with Virtual XP.  I can only guess it might be able to control another XP.

    -Noel

    Thursday, January 27, 2011 9:00 PM
  • Or use a Windows 2003 server
    Thursday, January 27, 2011 10:32 PM