locked
Web object for steaming video RRS feed

  • Question

  • I have the following web code...

    <object id="mediaPlayer" classid="CLSID:6BF52A52-394A-11D3-B153-00C04F79FAA6" codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" standby="Loading Microsoft Windows Media Player components..." type="application/x-oleobject" height="360" width="1024">
    <param name="fileName" value="http://atc.server1.lovethosetrains.com:20103">
    <param name="animationatStart" value="true">
    <param name="transparentatStart" value="true">
    <param name="autoStart" value="true">
    <param name="showControls" value="false">
    <param name="ShowStatusBar" value="true">
    <param name="loop" value="0">
    </object>

    Why does this not work any more?


    Friday, January 1, 2021 4:26 PM

All replies

  • https://medium.com/canal-tech/how-video-streaming-works-on-the-web-an-introduction-7919739f7e1

    hassansayedissa

    Friday, January 1, 2021 7:25 PM
  • Your web server is returning a 400 bad request. Should the file name be something like http://atc.server1.lovethosetrains.com:20103/Trains.wmv? 

    C:\>curl -v http://atc.server1.lovethosetrains.com:20103
    * Rebuilt URL to: http://atc.server1.lovethosetrains.com:20103/
    *   Trying 198.2.67.5...
    * TCP_NODELAY set
    * Connected to atc.server1.lovethosetrains.com (198.2.67.5) port 20103 (#0)
    > GET / HTTP/1.1
    > Host: atc.server1.lovethosetrains.com:20103
    > User-Agent: curl/7.55.1
    > Accept: */*
    >
    * HTTP 1.0, assume close after body
    < HTTP/1.0 400 Bad Request
    < Server: Rex/9.0.0.4509
    < Cache-Control: no-cache
    < Pragma: no-cache
    < Pragma: client-id=2862716320
    <
    * Closing connection 0

    Maybe consider switching to the HTML5 <video> tag also.

    https://dzone.com/articles/how-to-video-stream-from-html

    • Edited by MotoX80 Saturday, January 2, 2021 5:26 PM
    Saturday, January 2, 2021 4:57 PM