New MacBook Air (June 2013) Deployment Issue RRS feed

  • General discussion

  • I've worked out how to use MDT 2012 to deploy Windows 7 (and now Windows 8) to MacBook Pro laptops, and it works very well. The only concession I've had to make due the to mac hardware is not booting from Windows Deployment Services using PXE - I simply have to use the LiteTouchPEx64.iso to create a boot CD or USB to kick off the process.  But it all works!

    Today I'm having a new issue - one I've never seen - with my brand new June 2013 MacBook Air. When I boot into my WinPE LTI environment I have no keyboard or mouse support.  Yes, I downloaded the MacBook Air BootCamp drivers, imported them into MDT, and generated new boot images. I thought I could workaround by attaching an external USB keyboard and/or mouse, but even those fail to operate at all in the LTI WinPE environment. 

    I decided to work around the issue by removing the need for interacting with the wizard entirely. It didn't take long to customize my CustomSettings.ini file with the MAC address of my MacBookAir, making use of the SkipTaskSequence, SkipComputerName,SkipApplications (etc, etc) options and manually defining the computername, task sequence ID, Mandatory Applications, etc to fully automate the deployment. And it all worked. On my last test, no wizard screens popped up asking me for input.

    *Unfortunately*, the deployment fails with errors. I believe the errors are related to my custom diskpart script, but it's difficult to troubleshoot without any way to interact with the deployment at the WinPE console. 

    I then created and booted from a Win8 installation USB stick, to learn whether the keyboard and mouse would work, and also to use diskpart to try a bit of manual partition configuration. The keyboard and mouse DO work normally. I created a partition layout that should be compatible with the custom diskpart script in my task sequence, but the deployment still failed (although with a different number of errors and warning, so at least that's "progress"). 

    Any thoughts on why my keyboard and mouse won't work within WinPE? If I can get those working again I'm happy to do my own troubleshooting, but it's a bit hard to figure out with both hands tied behind my back! 

    Thanks in advance for all replies!


    • Edited by Bryan-L Tuesday, June 18, 2013 10:17 PM
    • Changed type Bryan-L Friday, June 21, 2013 2:25 PM No solution currently available.
    Tuesday, June 18, 2013 5:55 PM

All replies

  • If a Windows 8 boot disk worked, my first thought is that maybe you are still using WAIK (WinPE 3)?  If so, you may want to update to ADK (WinPE 4), specially if you are imaging Windows 8 onto your machines.  WinPE 4 has a lot more support for hardware, including touch, and often doesn't need nearly (if any) additional drivers to work for deployment.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Wednesday, June 19, 2013 3:24 AM
  • David,

    You may be onto something.  Right now two machines are involved - MDT is installed on my machine, and Windows Deployment Services is installed on a Server (I'll call it Onsite) that's also host to my deployment share. I first checked \\Onsite and found that ADK is installed and WAIK is not. I then checked my own machine and found that WAIK is installed, and ADK is not. I presume that means that MDT (running on my machine) is generating boot images based on WAIK/WinPE3 (installed on my machine)? 

    Will there be any downsides, broken functionality, things to watch out for, or tweaking required if I remove WAIK from my machine and install ADK? Will I need to reinstall or reconfigure MDT in any way?  Or can I simply make the switch and then update my deployment share to generate new boot images?

    Thanks for the reply - if that turns out to fix my problem I'll be a happy camper indeed!


    Wednesday, June 19, 2013 3:48 PM
  • If you open the Workbench on your machine when you generate the boot images, then it will use what you have installed locally (WAIK or ADK).  There have been some reports of replacing ADK with WAIK causing issues, but for the most part it's seamless.  Just make sure to uninstall WAIK, reboot, then install ADK to ensure it is as clean as possible.  You won't need to re-install or reconfigure MDT other than to regenerate your boot images (now using ADK), then put the new boot images on WDS.  If you don't want to replace WDS right off, you can always manually test the boot images from USB stick or whatever on the MacBook to see if the new WinPE does indeed solve the problem, THEN move it to your WDS.  Keep copies of the old WinPE 3 boot images to put back in the event you find an issue later on.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Wednesday, June 19, 2013 4:08 PM
  • David,

    It worked. Beautifully. I uninstalled WAIK, rebooted, and installed ADK (selected to install only Deployment Tools and WinPE features).  Keyboard and mouse are now functioning in WinPE on my MacBook Air. 

    Additionally it solved another problem. I'd managed to work thru the problems with partition setup and my custom diskpart script, to the point that last night my fully-automated, no-interaction-required workaround progressed as far as the OS image actually beginning to install. However, it only reached 4%, at which point it hung and never progressed further. After booting with the newly-generated WinPE4 image, installation proceeded all the way thru the OS installation phase.  Very happy here.

    (Minutes later...)

    Apparently I celebrated too soon. The deployment booted into the Local Admin desktop as usual, where it typically begins to install applications. However, upon reaching the Win8 Desktop (or more accurately, the Windows 8 Start screen), it became completely unresponsive. Once again, no response to keyboard, touchpad, or external mouse (and the mouse laser doesn't even light up when plugged in.)

    Damn! Any more ideas? I realize I'm in fairly uncharted waters with Win8 on this just-out MacBook Air, but I've never had driver issues with Win8 on any other recent Mac hardware before now. 

    Thanks for all your help! I've made progress thanks to you and think I'm *almost* there...


    Wednesday, June 19, 2013 8:30 PM
  • Are you injecting the latest MacBook BootCamp drivers during the Deploy Task Sequence?  It sounds like ADK fixed all your boot image issues with the new hardware, but now we need to get Windows 8 itself running on that hardware.  How recently patched is your reference image?

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Wednesday, June 19, 2013 8:39 PM
  • David,

    I'm not using a custom reference image; I'm deploying Windows 8 Enterprise Gold, unmodified. I have created a selection profile called MacBook, and I've confirmed that it is selected in the Preinstall>Inject Drivers step of the Task Sequence I'm using.

    Two notes:

    1. I'm using the option "Install only matching drivers from the selection profile" in the Deploy Task Sequence.
    2. I have imported my Out-of-Box Drivers into folders organized by computer model or function (like printer drivers). The drivers included in the MacBook Selection Profile are: Printer Drivers, MacBook Pro Late 2012, MacBook Air June 2013, Thunderbolt Ethernet.

    Do you think I'll get different results if I choose to install all drivers from the selection profile, or if I de-select drivers that don't apply within the selection profile (i.e. MacBook Pro Late 2012)? Could that be causing driver confusion when Windows setup enumerates devices?

    Thanks for sticking with me on this!


    Wednesday, June 19, 2013 10:14 PM
  • Do you also have a Inject Drivers in the Postinstall?  That's the one that will affect the installed Windows that you image the machine with.  You can try choosing to install all drivers, all that does is add drivers to the store the device may not need.  If you take MDT out of the picture and install Windows 8, does it have the same issue upon completion?

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, June 20, 2013 1:34 AM
  • The default Inject Drivers step is enabled under Postinstall also, but the Task Sequence Editor does not provide a dropdown to choose a selection profile for that step as it does for the Inject Drivers step under Preinstall. I assume that means it will (re)inject the same drivers defined/used earlier in the setup process? However, I see that if I select Add > General > Inject Drivers, I can manually add an Inject Drivers step under Postinstall that DOES provide a selection profile dropdown. Do you think that will help?  With other computer models (I've deployed many models of Dell Optiplex and Latitude machines), I've noticed that when I've imported and injected drivers for a particular computer model, all devices are found to be properly recognized once the OS deployment to that model is complete. This is using a default, otherwise unmodified deployment task sequence (provided the imported drivers are selected to be applied during the task sequence). Typically, no hardware devices under Device Manager are shown as unrecognized after such a deployment.

    My next step was going to be what you suggest - a standard, manual install of Windows 8. I'll do that and report back. If it succeeds, I may next try to manually add an Inject Drivers step to the task sequence under Postinstall, configure it with the appropriate selection profile, and see what happens.

    Thanks David.


    Thursday, June 20, 2013 2:49 PM
  • Update: Windows 8 will not completely install. I used a USB stick created from the Windows 8 Enterprise ISO and Microsoft's "Windows 7 USB DVD Download Tool".  Keyboard and mouse work properly in the WinPE portion of setup. Once Windows boots into the "Personalize" screen asking for the user to select a color scheme and computer name, installation cannot continue, as the keyboard and mouse fail to function. I'm supposing it's due to the lack of driver support for the Haswell chipset.

    I'm going to experiment with driver injection via MDT in the Postinstall phase as mentioned above and report back.

    Thursday, June 20, 2013 3:58 PM
  • Update 2: I manually added an Inject Drivers step to the task sequence in the Postinstall section, to replace the built-in Inject Drivers step, which I disabled. Still no keyboard and mouse support. What I find interesting about this is that at this point, my task sequence normally begins to install software without user interaction. It begins by enabling/installing .NET Framework 3.5 via a Install Roles and Features step, then installing selected Applications, the first of which should be BootCamp. As far as I can see, none of this ever occurs, but because the Start screen obscures the desktop on login, I doubt I'd be able to see it installing anyway.  All I can say definitively is that at this point, LTI appears to hang. The computer does not respond and there's no evidence of any activity, even waiting for over 20 minutes for a reboot (or anything else) to happen. 

    I strongly believe now that the problem is tied to lack of drivers for the Haswell chipset. My thoughts on how to proceed at this point are this:

    1. Under Postinstall, I will move the Inject Drivers task sequence step I manually added ahead of the built-in Inject Drivers step.
    2. I will reenable the built-in Inject Drivers step above, so the Task Sequence first injects the drivers I've specified, then processes the built-in Inject Drivers script (ZTIdrivers.wsf).
    3. Under State Restore, I will add a new Install Application step BEFORE the Install .NET Framework 3.5 step, which until now has been the first feature/program installed by LTI. That step will attempt to install BootCamp, then restart the computer.

    I'll report back.  If this doesn't do it, I'm a bit stumped. I can try to find/import/inject Haswell drivers for Windows 8 provided by someone other than Apple. Any thoughts on any of this are welcome.


    Thursday, June 20, 2013 4:36 PM
  • I posted a blog article about how to hide the Start Screen during a deployment, you could try including that PowerShell in your Task Sequence to see if anything else is happening and it just appears to be hung: http://dcthegeek.blogspot.com/2013/04/programmatically-hiding-windows-8-start.html

    I agree with you though, its mostly likely a driver issue with the new chipset.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, June 20, 2013 4:44 PM
  • Thanks David. I'm continuing to post so others searching for help with this might also find this post and perhaps learn (or contribute) something. 

    I added the powershell script exactly as indicated in your excellent blog post, and was then able to see that my scripted install of BootCamp begins, but ultimately displays the following error message: "The program can't start because msvcr100.dll is missing from your computer."

    I was about to conclude that Windows 8 simply cannot run on the new MacBook Air until Apple releases an update to BootCamp. Then I found this thread: https://discussions.apple.com/thread/5100623?start=0&tstart=0.  I decided to follow the suggestion to let the BootCamp Assistant to create my bootable USB stick. Using the Win8 Enterprise ISO I provided, it created a bootable USB stick that included the BootCamp drivers/software. I used that to install Windows, and my installation DID leave me with a working keyboard and mouse at the end of the process.  Success! But it was to be short-lived.

    I first tried manually running my script to silently install BootCamp (with the idea I could troubleshoot the process). The installation never seemed to run. Weird. Okay, I decided, I'll install manually.  I did, and the install went as expected. Great! Reboot. Still good. 

    Trying to end up with an installation as close as possible to what I'd have if I were able to deploy via MDT, I mapped Z: to my deployment share and browsed to the Applications folder. I manually installed the applications in the same order as my Application Bundle would have done. Some were done manually via the GUI, some (such as Office 2010) were done at the commandline so I could apply the configfile, etc as the scripted install would have done. After installing half a dozen applications, enabling the .NET Framework 3.5 feature about midway to support the applications I knew would require it, I rebooted again. 

    DEATH! My USB3.0 ports were again nonfunctional.  No keyboard. No Mouse. No touchpad. My installation was hosed and again completely inaccessible to me.

    I'm gonna keep messing with this but it's certainly wearing my patience thin and I can only burn so much more time on it. 


    Thursday, June 20, 2013 8:20 PM
  • Will continue to post my progress here.

    I'm fairly certain now that for whatever reason, the USB 3.0 drivers are not being properly installed for the chipset. I modified my Install Application step in my task sequence; I removed BootCamp and replaced it with a silent install of only the Intel Chipset drivers (found in the BootCamp\Drivers\Intel\Chipset folder). I in fact created a separate Intel Chipset Application item in my deployment share for this purpose. Installing Intel Chipset vs. BootCamp, I no longer get an error while my task sequence executes. Every application installs correctly, including the chipset drivers. Every reboot occurs as it should. MDT displays a "Deployment completed with 0 warnings and 0 errors" message at the end. But my USB 3.0 ports fail to function throughout. I have a mouse plugged in and upside down, so I can watch the laser, and on every reboot, the laser turns off partway thru the Windows boot process and never comes back on. No flickers during installation of any drivers.

    Since using the USB media created by BootCamp results in USB ports (and keyboard and touchpad) that initially work upon completion of Windows setup, I intend to redeploy using that method. I"ll then perform each step I performed before, one at a time, rebooting after each, to find out at which specific point I lose my USB ports. This may not prove useful in figuring out why my BootCamp media installation works where my MDT deployment does not, but if I can figure out what kills my USB ports as I proceed thru the setup of my machine, perhaps it will yet prove to be useful in troubleshooting MDT as well.


    • Edited by Bryan-L Thursday, June 20, 2013 9:23 PM Clarification
    Thursday, June 20, 2013 9:20 PM
  • Not being familiar with BootCamp and the USB it creates, can you maybe snag the drivers off the USB it creates (since they seem to work) and re-import them into MDT for delivery during imaging?

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, June 20, 2013 9:24 PM
  • Installing from BootCamp Media again worked for me initially. I gave the computer a name. I did not join it to the domain or enable Windows updates, so I could increment configuration in the slowest and most controlled manner. I created a user account and logged in.

    The first thing I did was open Device Manager. I noted that all the USB devices under Universal Serial Bus Controllers were working. I noted that most of the other Apple hardware showed that drivers were not yet installed. 

    I then installed BootCamp from the same USB stick that Windows was installed from. The installation went perfectly, and then asked for a reboot. I obliged.

    After that reboot my keyboard, mouse, and touchpad failed to function. BootCamp itself killed it. Next step - call Apple.

    What's odd is that the last time I installed using this method, the laptop survived a number of reboots after BootCamp was installed, as I installed various other applications. I don't yet know whether this problem can be shown to manifest consistently or if it's just general bugginess.


    • Edited by Bryan-L Thursday, June 20, 2013 9:38 PM clarity
    Thursday, June 20, 2013 9:37 PM
  • What happens if you just let Windows do it's thing?  Don't install BootCamp and don't push BootCamp drivers?  Some hardware may not work, but is it still functional (mouse, keyboard, touchpad) and usable?

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, June 20, 2013 9:40 PM
  • Interesting idea. I may try to deploy using MDT but modify the selection profile to NOT include the imported drivers for the MacBook Air. 

    I can also try breaking down the BootCamp installation into its separate components by going into the driver folders themselves and installing them individually. 


    Thursday, June 20, 2013 9:46 PM
  • David,

    Yep! I modified my selection profile.  Originally, it included drivers for MacBook Pro Late 2012, MacBook Air June 2013, and Thunderbolt Ethernet drivers. It later included only MacBook Air and Thunderbolt Ethernet drivers as we tried to narrow down the problem. I altered it to include drivers for MacBook Pro Late 2012 and ThunderBolt Ethernet (I essentially turned off MacBook Air drivers and turned on MacBook Pro drivers).

    It's working currently.


    Thursday, June 20, 2013 10:04 PM
  • Hooray, glad it's working!!  Weird that the new drivers don't work, but glad you got it going. : )

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, June 20, 2013 10:07 PM
  • I spoke too soon.  Doing nothing but letting the applications continue to install, it again died.  After the final reboot, it displayed the results of successful deployment with 0 warnings and 0 errors, but no kb or mouse. 

    It's buggy as hell! Murder to troubleshoot.  I'm calling AppleCare to see if they've got any insight. 

    Thanks for everything David.  Clearly I'm doing everything right at this point thanks to your help, but I'm faced with some broken or buggy drivers, or buggy...something.


    Thursday, June 20, 2013 10:20 PM
  • Sorry it broke down again.  Hopefully AppleCare can help point you in the right direction.  Please post back if you find out more details.  Since this turned into more of a Discussion then an answerable Question (unless you feel otherwise, in which case, please mark the post(s) you feel helped the most), please change the type to Discussion. : )

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Friday, June 21, 2013 4:11 AM
  • Final update (for now):

    I spent 90 minutes on the phone with AppleCare yesterday evening, and my takaway is that the haswell chipset appears to be too new to be properly supported by BootCamp. For example, installing from the USB media created by the BootCamp Assistant allows keyboard and mouse to function upon first startup. After doing nothing but booting to the desktop and then restarting the computer, keyboard and mouse fail again to function. Installing from a plain vanilla Windows 8 disk never allows kb and mouse to function (except during the WinPE portion of setup). I'll probably make another attempt at a BootCamp install once Apple releases an update to BootCamp, probably some weeks or months down the road. Meanwhile, I'm going to abandon this effort for now and use Parallels to run my corporate Windows desktop.

    Thanks David for your help and patience in this. If I tackle this again in the near future I'll create a new discussion/question and link to it from here. 


    Friday, June 21, 2013 2:24 PM
  • Hi all,

    Thought I would add my 2 cents also.

    We also purchased a brand new (June 2013) MacBook Air. I'm not deploying using MDT, but using the standard Boot Camp process.

    Ive tried allowing Boot Camp to create the Windows 7/8 USB, also tried using my own External DVD, tried allowing it to download Support Software, and also without. Tried installing Windows using Boot Camp, and also by myself by holding down the Option key. Everything gives me the same result. Through WinPE, kbd+pad works, then once the first Setup screen shows, no kbd+pad. Also no USB ports function. Plug a Microsoft mouse in, and it doesn't get power.

    I've tried integrating the latest Boot Camp Support Software drivers into boot.wim and install.wim, with no help.

    Can't wait for Apple to admit it's their fault! Called them once, and they said its Microsoft's responsibility...

    Friday, July 12, 2013 1:55 AM
  • Hey there,

    We're starting to see new iMacs with Haswell and ran into the same issue as the original post here. We managed to successfully deploy Windows 7 x64 by doing the following:

    • Used Boot Camp Assistant to pull down the latest drivers to a USB stick
    • Injected those drivers into MDT (2010 Update 1)
    • Updated the deployment share and created new boot images
    • Created a USB WinPE (we're using version 3.0) boot drive based on the updated boot image
    • Downloaded the latest Intel USB 3.0 eXtensible host controller drivers from Intel and manually injected those into our USB WinPE boot drive

    At this point we could finally use the USB ports for keyboard and mouse in the WinPE environment.

    • Injected the same Intel USB 3.0 eXtensible host controller drivers from Intel into the driver folder we used for the iMac we were deploying to.

    By doing that last step we finally had USB functionality in Windows after the deployment completed.

    I don't have a lot of experience with Boot Camp but was under the impression that you needed Apple-provided drivers for Boot Camp. We ended up running the Boot Camp drivers package afterwards to see if it broke USB again and it didn't. Anyhow, I hope this helps for anyone else who stumbles across this thread as well.

    Wednesday, October 16, 2013 10:34 PM
  • I loaded up the USB 3.0 drivers (from Boot Camp assistant) into my WinPE 3.1 based boot disk (for MDT 2010) and it was still not working.  Through some trial and luck, I found that I had to have the USB->Ehternet adapter unplugged at the boot chooser and then after choosing "windows" to boot, I had to plug the Ethernet in as the machine was preparing to start Windows.  That made things work OK.
    • Edited by ToddMiller Wednesday, October 23, 2013 7:29 PM
    Wednesday, October 23, 2013 7:28 PM