locked
Vista RTM install issue at Expanding Files RRS feed

  • Question

  • I'm currently trying to install Vista RTM on my desktop and running into an odd issue.  I have two SATA drives - the first is 250 GB and has Windows XP on it.  The second is 200 GB and is empty.  I just bought this drive to install Vista onto.

    Vista detects both drives just fine.  When I choose the second drive to install onto (and have it create a single partition on the drive), the next step, copying Windows files, takes about 25 min to complete.  Then, the expanding files step runs extremely slowly - 47% over 7 hours.  It does not lock up, and I do not receive any errors.  This certainly can't be right.

    The hard drive reports no defects, and it passes all SMART testing.  In fact, Windows XP has no issues whatsoever with this drive.  It's also not a bad Vista DVD because if I use PartitionMagic to shrink my XP drive and create another partition on it, Vista installs just fine in about 25 minutes.

    Anyone seen anything like this?  Thanks for any assistance you can offer.

    Saturday, November 18, 2006 9:30 PM

All replies

  • Yes i have had this problem, they way i got RC2 to install was to go into my motherboard bios and disable hyperthreading on my cpu (Intel P4 3.0ghz) and disable onboard Lan port and 1394 port, doing this managed to get vista to install, once installed just re-enable everything and they will install on next statup with no problem.

    Hope this helps.

    Sunday, November 19, 2006 2:07 PM
  • Very interesting.  I'll give this a shot and see if it helps.  Hyperthreading is enabled on my machine currently, along with 1394 and onboard LAN.

    Thank you!

    - Chris

    Monday, November 20, 2006 4:54 PM
  • Hmm.  Didn't seem to work.
    Monday, November 20, 2006 5:05 PM
  • What motherboard are you using?

    Monday, November 20, 2006 5:57 PM
  • Not sure, the PC is a Dell XPS Gen 3.  I was wondering if there was a SATA driver problem.  I think it's an Intel SATA controller, but Vista apparently detected it fine.  Plus, it seems to install fine on any partition on the first drive.  I even tried moving the second drive to each different SATA port on my motherboard - same result.

    Monday, November 20, 2006 10:20 PM
  •  

    I had this problem with RC2 (RC1 worked just fine) and now have experienced the same problem in RTM.  I would alternately describe the "Expanding Files" problem as the "Installing Windows" problem.  Where I was hung up was after a reboot, with the shifting curtains as a background and "Installing Windows" displayed.        

    In my case I believe the problem was with my Promise SATA controller.  In earlier builds I discovered that the Promise was not supported, and reconfigured my machine accordingly to allow for a boot drive that was not strung off the Promise controller and was able to install. 

    I just gave up on RC2, but have just brought Vista RTM online by unplugging the 2 drives attached to the Promise.  The removal of all drives kept the BIOS for the card from installing.

    When setup continued "Expanding Files" was displayed starting somewhere around 25-27% and all was golden from then on.     

    Wednesday, November 22, 2006 2:26 AM