locked
Out of office stopped working E2007 RRS feed

  • Question

  • in a customer with exchange 2007 over windows 2008 all the sudden out of office stopped working from outlook 2007 and 2010 clients, the only thing they did was to renew the self-signed certificates

    i've checked this thread http://social.technet.microsoft.com/Forums/en-GB/exchangesvrclients/thread/b27f77c3-6b88-43b8-a07a-4040ffe8c05e

    and the 3 virtual folders marked in the proposed solutions are already as told.

    testing with an outlook 2003 client worked perfectly

    any other ideas?

    edit: i ran test-outlookwebservices and this is the output:


    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address Administrator@semino.com.ar.

    Id      : 1007
    Type    : Information
    Message : Testing server DS01.domain.com.ar with the published name https://ds01.semino.com.ar/EWS/Exchange.asmx & .

    Id      : 1019
    Type    : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object  is https://DS01.domain.com.ar/Autodiscover/Autodiscover.xml.

    Id      : 1013
    Type    : Error
    Message : When contacting https://DS01.domain.com.ar/Autodiscover/Autodiscover.xml received the error The underlying connection was closed: An unexpected error occurred on a send.

    Id      : 1013
    Type    : Error
    Message : When contacting https://DS01.domain.com.ar/Autodiscover/Autodiscover.xml received the error Authentication failed because the remote party has closed the transport stream.

    Id      : 1006
    Type    : Error
    Message : The Autodiscover service could not be contacted.

    if i manually browse to https://DS01.domain.com.ar/Autodiscover i get an internet explorer cannot display the page

    any ideas?


    • Edited by Eliminateur Thursday, May 3, 2012 8:45 PM more data
    Thursday, May 3, 2012 8:20 PM

Answers

  • there's only internal site, in owa it's not working either

    Lisa,

    if i enter that command as it is it returns an error in the comma:

    Missing argument in parameter list.
    At line:1 char:37
    + GET-Webservicesvirtualdirectory |FL,  <<<< get-autodiscovervirtualdirectory |fl

    if i remove the comma, it returns empty, or you meant two different commands?

    i've run them separate and they simply return a list of the virtual directories, i don't see anything wrong in them.

    Simon, they simply renewed the old cert, so the names are correct as all the data should be the same except expiration date(they won't use commercial ssl certs, there's no need to incur the cost for this installation)

    Also, from OWA it works perfectly

    edit2: i did a test autodiscover from the O10 client and it returns error 0x800C8203

    what i do find odd its that i can access autodiscover url WITHOUT HTTPS, with http it works ok, but https directly fails.

    how do i need to have the virtual server configured?, does it need to have required HTTPS and 128bit enabled?

    edit3: i've enabled the require ssl and 128bit, the https site fails to load directly but http works.... any idea?

    edit4: i seem to have fixed it, since the certificate was the suspicious thing, i did a get-exchangecertificate and noticed that IIS was not on the list of enabled services, so i enabled it for IIS as well and now the autodiscover webstie can be browsed succesfully from a browser and out of office appears to be working


    • Edited by Eliminateur Friday, May 4, 2012 5:53 PM possible solutions
    • Marked as answer by Eliminateur Tuesday, May 8, 2012 2:39 PM
    Friday, May 4, 2012 12:03 PM

All replies

  • Hello,

    The issue happened on internal or external?

    Is it working on owa website.

    Please run GET-Webservicesvirtualdirectory |FL, get-autodiscovervirtualdirectory |fl and check the result.

    Best Regards,

    Lisa

    Friday, May 4, 2012 8:12 AM
  • You shouldn't be using self signed certificates, as they are not designed for production use.

    If you have simply renewed them then it looks like the SSL certificate is corrupt. Remove and recreate, or better still replace with a commercial SSL certificate with the relevant names in it.

    http://exchange.sembee.info/2007/install/multiplenamessl.asp

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    Friday, May 4, 2012 9:35 AM
  • there's only internal site, in owa it's not working either

    Lisa,

    if i enter that command as it is it returns an error in the comma:

    Missing argument in parameter list.
    At line:1 char:37
    + GET-Webservicesvirtualdirectory |FL,  <<<< get-autodiscovervirtualdirectory |fl

    if i remove the comma, it returns empty, or you meant two different commands?

    i've run them separate and they simply return a list of the virtual directories, i don't see anything wrong in them.

    Simon, they simply renewed the old cert, so the names are correct as all the data should be the same except expiration date(they won't use commercial ssl certs, there's no need to incur the cost for this installation)

    Also, from OWA it works perfectly

    edit2: i did a test autodiscover from the O10 client and it returns error 0x800C8203

    what i do find odd its that i can access autodiscover url WITHOUT HTTPS, with http it works ok, but https directly fails.

    how do i need to have the virtual server configured?, does it need to have required HTTPS and 128bit enabled?

    edit3: i've enabled the require ssl and 128bit, the https site fails to load directly but http works.... any idea?

    edit4: i seem to have fixed it, since the certificate was the suspicious thing, i did a get-exchangecertificate and noticed that IIS was not on the list of enabled services, so i enabled it for IIS as well and now the autodiscover webstie can be browsed succesfully from a browser and out of office appears to be working


    • Edited by Eliminateur Friday, May 4, 2012 5:53 PM possible solutions
    • Marked as answer by Eliminateur Tuesday, May 8, 2012 2:39 PM
    Friday, May 4, 2012 12:03 PM
  • Is the server not being accessed from the internet at all? If not, then continue to use self signed certificates. If the server is being accessed from the internet then you should use a commercial certificate.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    Tuesday, May 8, 2012 9:40 AM