locked
black screen after installing radeon hd 5770 drivers. RRS feed

  • Question

  • IV just built myself a new pc including the above stated  graphics card, everything was fine while installing the drivers for the motherboard, but after installing the drivers for the graphics card the system restarts and goes black on startup. i get the bios screen but everything after that is just black. i know the system is working fine because i can here it loading windows up. The only way i can restore graphics to my pc is to put in my old navidia card and then do a system restore to before installed the graphics drivers.   

    im running a gigabite x58 motherboard, 2.8 i7, 6 gigram. and am on windows 7 home premium 32bit. 

    would be really grateful for some help 

    thanks 

       

    Monday, August 2, 2010 10:57 AM

Answers

  • Hi gamerboy,

    When the radeon is installed, press F8 on boot and select safe mode, or safe mode with networking.

    Try installing the drivers then. Safe mode will use the basic vga to provide a display.

    • Proposed as answer by Linda Yan Wednesday, August 4, 2010 7:34 AM
    • Marked as answer by Linda Yan Monday, August 9, 2010 1:59 AM
    Monday, August 2, 2010 6:59 PM

All replies

  • Hi gamerboy,

    When the radeon is installed, press F8 on boot and select safe mode, or safe mode with networking.

    Try installing the drivers then. Safe mode will use the basic vga to provide a display.

    • Proposed as answer by Linda Yan Wednesday, August 4, 2010 7:34 AM
    • Marked as answer by Linda Yan Monday, August 9, 2010 1:59 AM
    Monday, August 2, 2010 6:59 PM
  • Also, you can try running Windows Update to see if the graphic driver can be downloaded and installed properly.

     

    For more information, please refer to: Update a driver for hardware that isn't working properly


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, August 4, 2010 7:35 AM