none
Easiest way to enable more than 2 concurrent RDP sessions on Windows Server 2016 RRS feed

  • Question

  • Hello everyone,

    I am trying to figure out the easiest way to allow more than 2 RDP sessions at a time on my Windows 2016 Server Standard. I have tried using the google to help, but there are so many suggestions and 90% of them result in the original poster disappearing so I don't know the best way to accomplish this. I don't need anything extravagant setup, I just need more than 2 people to be able to rdp into the server at the same time.

    Any help would be appreciated.

    Thanks,

    Tuesday, June 5, 2018 10:54 PM

Answers

  • Hi,

    By default, system supports 2 simultaneously sessions. That means, if you had a user account log on the system locally, then, there is only one user allowed to establish remote desktop connection to the system at same time.

    You can open Task Manager – Users tab, to check current log on user accounts and sessions.

    If you want to allow more than 2 simultaneously sessions, RDS deployment with appropriate RDS CALs installed is necessary.

    For example, if you need more than 2 connections to your Windows Server 2016 from internal device, then, below RDS serve role might be necessary:
    1. RD Connection Broker.
    2. RD Session Host.
    3. RD Licensing server – there is 120-day licensing grace period, appropriate RDS CALs should be purchased and installed before it has expired.

    You can install all server role on single server system and using session-based quick deployment.

    Deploying RDS 2012 Single Server – Session Based deployment:
    https://ryanmangansitblog.com/2013/03/11/deploying-rds-2012-single-server-session-based-deployment/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 6, 2018 7:04 AM
    Moderator

All replies

  • Hi!

    You could either do it with Group Policy:

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\ Remote Desktop Session Host\Connections\

    • Restrict Remote Desktop Services users to a single Remote Desktop Services session     value: Disabled

    Next, double-click on Limit number of connections and then set the RD Maximum Connections allowed to 999999.

    Or you could edit the registry as follows:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server

    • fSingleSessionPerUser     value: 0
    • fdenyTSConnections value: 0

    Hope you find any of these useful!

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   



    • Edited by Leon Laude Tuesday, June 5, 2018 11:11 PM
    • Proposed as answer by Leon Laude Wednesday, October 10, 2018 7:42 AM
    • Unproposed as answer by TP []MVP, Moderator Friday, March 1, 2019 1:34 PM
    Tuesday, June 5, 2018 11:03 PM
  • Hi,

    By default, system supports 2 simultaneously sessions. That means, if you had a user account log on the system locally, then, there is only one user allowed to establish remote desktop connection to the system at same time.

    You can open Task Manager – Users tab, to check current log on user accounts and sessions.

    If you want to allow more than 2 simultaneously sessions, RDS deployment with appropriate RDS CALs installed is necessary.

    For example, if you need more than 2 connections to your Windows Server 2016 from internal device, then, below RDS serve role might be necessary:
    1. RD Connection Broker.
    2. RD Session Host.
    3. RD Licensing server – there is 120-day licensing grace period, appropriate RDS CALs should be purchased and installed before it has expired.

    You can install all server role on single server system and using session-based quick deployment.

    Deploying RDS 2012 Single Server – Session Based deployment:
    https://ryanmangansitblog.com/2013/03/11/deploying-rds-2012-single-server-session-based-deployment/

    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 6, 2018 7:04 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, June 8, 2018 1:37 AM
    Moderator
  • Hi,

    Is there any update?

    Please click “Mark as answer” if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, June 11, 2018 1:43 AM
    Moderator
  • Do not work for my 2012 R2 windows server :( another way better?
    Wednesday, February 27, 2019 9:42 AM
  • The problem here is that you don't know. You obviously DID NOT try the solution yourself. It does not work. 
    Thursday, July 18, 2019 5:34 PM
  • Your solution doesn't work either so why are you proposing this as a solution.?
    Thursday, July 18, 2019 5:35 PM
  • Hi Eve!

    I am in the same situation. W2019Std with 2 HYPER-V VM's. One of them has the Remote Desktop Services enabled, and is within the 120 days grace period. This configuration is NOT part of a domain, but a WORKGROUP instead.

    Do I still have to install de CALs even though the server is within the grace period? 

    Exact message is:

    "Your remote desktop services session has ended. Another user connected to the remote computer, so your connection was lost. Try connecting again, or contact your network administrator or technical support group."

    I have tried many things, but nothing seems to work. License Manager has a green checkmark. 

    Please help!

    Thank you in advance,

    Gilberto


    <iframe class="ginger-extension-definitionpopup" src="chrome-extension://kdfieneakcjfaiglcfcgkidlkmlijjnh/content/popups/definitionPopup/index.html?title=Right&description=being%20or%20located%20on%20or%20directed%20toward%20the%20side%20of%20the%20body%20to%20the%20east%20when%20facing%20north" style="left:-102px;top:-71px;z-index:100001;display:none;"></iframe>
    Sunday, December 8, 2019 7:47 PM