locked
Defered delivery and delays RRS feed

  • Question

  • We use Exchange on Small Business Server 2003. Users connect through RPC over HTTP using Outlook 2007.

    If a user sends an email to another user on the same server, it takes less than a minute till the message appears in other user's mailbox. However, if sender has "defer delivery" rule enabled in his outlook, there is additional delay (5-7 minutes) on top of the delay set in the rule.

    For example, if a user chooses to delay messages for 2 minutes, message stays in Outbox for 2 minutes, goes to Sent Items folder and it takes additional 5-7 minutes after that till message appears in the other mailbox.

    When we do message tracking on Exchange server, it shows that message was received and processed within a minute and that's the time when message appears in the other mailbox.

    We've confirmed the issue with two test users, with empty mailbox, no other rules and no third party add-ons in Outlook.

    Is it a normal behavior or there is a misconfiguration? Also, where is the message between Outlook sends it and Exchange processes it?

    Wednesday, May 11, 2011 2:06 AM

Answers

  • This is a normal beheavor when Outlook is working in Cached mode.

     

    The defer delivery rule looks to be working in the sense that if you have a rule set up to defer delievry by X mins, it won't leave the outbox before X minutes have elapsed. The problem is that the mail isn't leaving immediately after that time. In fact, it keeps in the local copy, (e.g, the .ost file,) and wait for a tirgger to sync to the server store.

     

    It is an known issue and Microsoft will not fix it.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Fiona_LiaoModerator Thursday, May 12, 2011 6:44 AM
    • Marked as answer by Kistik Thursday, May 12, 2011 12:19 PM
    • Unmarked as answer by Kistik Thursday, May 12, 2011 12:35 PM
    • Marked as answer by Kistik Thursday, May 12, 2011 5:37 PM
    Thursday, May 12, 2011 6:44 AM
    Moderator

All replies

  • This is a normal beheavor when Outlook is working in Cached mode.

     

    The defer delivery rule looks to be working in the sense that if you have a rule set up to defer delievry by X mins, it won't leave the outbox before X minutes have elapsed. The problem is that the mail isn't leaving immediately after that time. In fact, it keeps in the local copy, (e.g, the .ost file,) and wait for a tirgger to sync to the server store.

     

    It is an known issue and Microsoft will not fix it.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Fiona_LiaoModerator Thursday, May 12, 2011 6:44 AM
    • Marked as answer by Kistik Thursday, May 12, 2011 12:19 PM
    • Unmarked as answer by Kistik Thursday, May 12, 2011 12:35 PM
    • Marked as answer by Kistik Thursday, May 12, 2011 5:37 PM
    Thursday, May 12, 2011 6:44 AM
    Moderator
  • Fiona, thank you for clarifying this. Appreciate your time.
    Thursday, May 12, 2011 5:37 PM