locked
Paragraph Alignment and Justification different in Word 2003 and 2010 RRS feed

  • Question

  • Hi all,

    We are migrating some letter templates from word 2003 to word 2010 for our system and we found a alignment problem in word 2010 (actually, it is not a problem and I think the behavior in 2010 is correct)


    In word 2003, the following paragraph alignment will display like this :

    "To enjoy your membership in our service center, please remit a payment of US$

    123456789.00 per annual"

    In word 2010, the following paragraph alignment will show like this

    "To enjoy your membership in our service center, please remit a payment of

    US$ 123456789.00 per annual"

    (US$ 123456789.00 is shown on same line in 2010 but US$ and dollar amount are not

    on the same line in 2003)

    Although I think the paragraph alignment in 2010 is more reasonable, I still want to achieve back

    the look in 2003 such that we can easily to compare results.

    As in one post that I asked help in this forum, one expert shows me that there is option to set back the layout

    look behavior in 2003, I guess if there are some advance settings to achieve this?

    Please kindly advise to me on this.

    Thanks in advance for your help,

    Ray

    Wednesday, July 2, 2014 5:04 PM

Answers

  • As far as I know, this behaviour changed in Word 2007. If the "US$ 123456789.00" or even just "$ 123456789.00" is generated from a field code - such as { MERGEFIELD theamount }, or by using a formatting switch, e.g. { MERGEFIELD theamount \#"$ 0,0.00" }, the result is treated as a single word for wrapping purposes in Word 2007 and 2010. In Word 2003 and Mac Word (2011) wrapping will occur. 

    You can verify that it's not a printer driver issue by increasing the number of spaces, either in the data source if that is where the sapce is coming from, or in the numeric formatting switch - in 2010, the result will still wrap.

    I don't think it's down to any of the per-document compatibility options - certainly setting the options to be the "Word 2003" set in Word 2010 does not change the wrapping, and .docx/.doc makes no difference in Word 2007/2010.

    If the space after the $ is coming from a formatting switch and you want the wrapping in Word 2003 to behave the same way as in Word 2010, you can try using a non-break space (ctrl-shift-space) instead of an ordinary space in the switch. If the space is coming from the data source, it may be harder to change the behaviour in Word 2003.


    Peter Jamieson

    • Marked as answer by RLee1010 Thursday, July 10, 2014 3:15 PM
    Thursday, July 3, 2014 10:02 AM
  • As far as I know, this behaviour changed in Word 2007. If the "US$ 123456789.00" or even just "$ 123456789.00" is generated from a field code - such as { MERGEFIELD theamount }, or by using a formatting switch, e.g. { MERGEFIELD theamount \#"$ 0,0.00" }, the result is treated as a single word for wrapping purposes in Word 2007 and 2010. 

    Sorry, but that just isn't so. In Word 2003 & 2010 the wrapping is the same, regardless of whether you're previewing the mailmerge main document with the field, or the post-merge document without it. Having a space between the $ and the value is what allows them to appear on separate lines. The way to prevent this in either version is to either: (a) not have the space; or (b) use only a non-breaking space between the $ and the value. This is an entirely separate issue from the wrapping changes that occur when changing printer drivers, justification settings and/or file formats.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    • Marked as answer by RLee1010 Thursday, July 10, 2014 3:15 PM
    Thursday, July 10, 2014 4:56 AM

All replies

  • With the change to Office 2010, you've quite possibly also changed printers and/or printer drivers. Because Word relies on data from the active printer's driver to determine the text flow on the page, a change in printer drivers can result in line breaks differing. This can affect pagination as well. Note also that the docx format lays a document out differently than the doc format too. Another thing that can affect the layout in justified paragraphs is whether you've checked the option to do justification the way Wordperfect 6.x does. That tends to fit more text on a line - yet another factor affecting text flow on the page.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    Wednesday, July 2, 2014 11:28 PM
  • As far as I know, this behaviour changed in Word 2007. If the "US$ 123456789.00" or even just "$ 123456789.00" is generated from a field code - such as { MERGEFIELD theamount }, or by using a formatting switch, e.g. { MERGEFIELD theamount \#"$ 0,0.00" }, the result is treated as a single word for wrapping purposes in Word 2007 and 2010. In Word 2003 and Mac Word (2011) wrapping will occur. 

    You can verify that it's not a printer driver issue by increasing the number of spaces, either in the data source if that is where the sapce is coming from, or in the numeric formatting switch - in 2010, the result will still wrap.

    I don't think it's down to any of the per-document compatibility options - certainly setting the options to be the "Word 2003" set in Word 2010 does not change the wrapping, and .docx/.doc makes no difference in Word 2007/2010.

    If the space after the $ is coming from a formatting switch and you want the wrapping in Word 2003 to behave the same way as in Word 2010, you can try using a non-break space (ctrl-shift-space) instead of an ordinary space in the switch. If the space is coming from the data source, it may be harder to change the behaviour in Word 2003.


    Peter Jamieson

    • Marked as answer by RLee1010 Thursday, July 10, 2014 3:15 PM
    Thursday, July 3, 2014 10:02 AM
  • Hi,

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.

    Thanks

    George Zhao
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please click "tnfsl@microsoft.com"

    Thursday, July 10, 2014 1:11 AM
  • As far as I know, this behaviour changed in Word 2007. If the "US$ 123456789.00" or even just "$ 123456789.00" is generated from a field code - such as { MERGEFIELD theamount }, or by using a formatting switch, e.g. { MERGEFIELD theamount \#"$ 0,0.00" }, the result is treated as a single word for wrapping purposes in Word 2007 and 2010. 

    Sorry, but that just isn't so. In Word 2003 & 2010 the wrapping is the same, regardless of whether you're previewing the mailmerge main document with the field, or the post-merge document without it. Having a space between the $ and the value is what allows them to appear on separate lines. The way to prevent this in either version is to either: (a) not have the space; or (b) use only a non-breaking space between the $ and the value. This is an entirely separate issue from the wrapping changes that occur when changing printer drivers, justification settings and/or file formats.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    • Marked as answer by RLee1010 Thursday, July 10, 2014 3:15 PM
    Thursday, July 10, 2014 4:56 AM
  • There is a difference, but it turns out to be a "2-factor" one. As far as I can tell, "enabling an 'east asian' language for editing" is the other factor. When you create a document with such a language enabled, wrapping of currency amounts works differently in Windows Word 2007 and later. Once created, the problem seems to occur even on copies of Word that only have (say) English enabled.

    In Word 2003, having such a language enabled for editing appears to make no difference.

    Whether "enabling of an 'east asian' language is the cause of the problem described by the OP, or the only thing that will result in such a difference, I cannot tell.

    Here, I tested roughly as follows:

     a. back up normal.dot/normal.dotm

     a. open Word 2010 and ensure only English is enabled as an editing language

     b. create a new document 

     c. Type 

    " $          a"
    (space, $, 10 spaces, "a", no quotation marks).

     d. Type text + spaces before that, until the "a" wraps onto the next line.

     e. save and close that

     f. enable (say) one of the Chinese languages for editing.

     g. restart Word

     h. repeat (b)-(d). This time, I think you will see that the $, 10 spaces and the "a" wrap as a unit.

     i. Save that.

     j. disable the East Asian language again and restart Word. Open each document and see how the wrapping behaves.

    Here, I happen to have Chinese enabled as one of the editing languages in my copy of Word 2003 and I do not see the "wrap as a unit" behaviour in that case, or in either of the two .doc fiels saved from Word 2010.

    Here, the behaviour appeared to be the same whether I used $, £ (UK pound sign) or the Yen character symbol, but not the Euro currency symbol.

    I saved my test files (including some created in Word 2003) in 2007 XML format and tried to pin down the significant difference. Per-dcoument compatibility settings didn't seem to be involved. Changing the w:eastAsia language attribute in the following element in the styles.xml file was enough to change the behaviour:
    <w:styles><w:docDefaults><w:rPrDefault><w:rPr><w:lang ...



    Peter Jamieson

    Thursday, July 10, 2014 1:46 PM