locked
Unable to send a new Message RRS feed

  • Question

  • I am getting this Error  when i try to send a new message, Even i tried with different account expect administrator account..Every user has proper permission..Last week i migrate active directory 2003 to 2008 active directory since i  migrate active directory non of account is working. I tried different methods to ensure that every thing is work fine..The Mailbox Database is healthy no issue with Database .User permissions seems to be fine No issue with user Permissions. .User can properly access Active directory and Domain Resources...
    Can any one help me to sort it out issue..

    NOTE:

    I am getting below message

    Request
    Url: https://exchnage.domain.com:443/owa/forms/premium/EditMessage.aspx?ae=Item&a=New&t=IPM.Note&cc=MTQuMC42MzkuMjEsZW4tVVMsNDI5NDk2NzI5NSxIVE1MLDAsMA==&pspid=_1313013772785_450428126
    User host address: 192.168.11.20
    User: zaki
    EX Address: /o=khalil/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=zaki
    SMTP Address: khalil@domain.com
    OWA version: 14.0.639.21
    Mailbox server: EX.khalil.local

    Exception
    Exception type: Microsoft.Exchange.Data.Storage.RightsManagementPermanentException
    Exception message: Rights management operation failed.

    Call stack

    Microsoft.Exchange.Clients.Owa.Core.UserContext.get_IsIrmEnabled()
    Microsoft.Exchange.Clients.Owa.Premium.EditMessage.OnLoad(EventArgs e)
    System.Web.UI.Control.LoadRecursive()
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    Inner Exception
    Exception type: Microsoft.Exchange.Security.RightsManagement.RightsManagementException
    Exception message: BindValidityTimeViolated

    Call stack

    Microsoft.Exchange.Security.RightsManagement.Errors.ThrowOnErrorCode(Int32 hr, LocalizedString contextMessage)
    Microsoft.Exchange.Security.RightsManagement.Errors.ThrowOnErrorCode(Int32 hr)
    Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.DrmEnvironment.InitializeEnvironment()
    Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.Initialize()
    Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.InitializeIfNeeded()
    Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.get_IRMConfig()
    Microsoft.Exchange.Clients.Owa.Core.UserContext.get_IsIrmEnabled()

    Friday, February 3, 2012 10:23 PM

Answers

  • Hi

    Check your time and dates are synchronised between Exchange servers and DCs.  You can also try an iisreset on the Exchange server if you haven't rebooted it already.

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:46 PM
    Friday, February 3, 2012 10:31 PM
  • thanks for your reply ..i already tried all of things which you mentioned but  unfortunately  i am getting same Error, even i restart both servers, I also Dismount the Database, I even created new database  along with new mailboxes..I testes with New database and new mailboxes Issue remain same, No luck...

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 10:16 AM
  • It is Same forest ..I had active directory on  windows server 2003 .. I migrated to Windows Server 2008 R2 Enterprise, There was No issue with Migration, FSMO roles are on new server  Active Directory and Domain controller both are healthy, it's seems to be Issue of Permission But i don't know how to change or  modify User permissions, Even User can Login with their Domain account, I can see Mailboxes on Exchange Server
    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 11:36 AM
  • We don't have RMS installed  in our Environment

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 1:21 PM
  • I tried to run the Eseutil to verify the database

    This is the output of ESEUTIL

    ******************************** MSysOLD2 DUMP ***********************************
    ***************************** MSysDatabaseMaintenance DUMP ********************************
    LastUpdateTime: 0x1CCD2C2BE872A9F
    PassStartTime: 0x0
    PassPagesRead: 0
    PrevPassStartTime: 0x1CCD2C23DCF8F3B
    PrevPassEndTime: 0x1CCD2C2BE872A9F
    PrevPassPagesRead: 71936
    ElapsedSeconds: 0
    PassInvocations: 0
    PassBadChecksum: 0
    TotalInvocations: 2
    TotalBadChecksums: 0

    ******************************** SPACE DUMP *****************************************
    Name                    Type    Owned(MB)     %OfDb  %OfTable    Avail(MB) Avail%Tbl
    =====================================================================================
    C:\exchangedatabase\exc  Db      2256.000   100.00%                  7.063

      Body-1-A               Pri       19.907     0.88%   100.00%        3.313    16.64%
        [Long Values]        LV        14.313     0.63%    71.90%        0.313     1.57%
      MDB Event History Tab  Pri       27.626     1.22%   100.00%       10.157    36.76%
      MSysObjects            Pri       50.938     2.26%   100.00%        0.282     0.55%
        Name                 Idx       17.563     0.78%    34.48%        0.032     0.06%
      MSysObjectsShadow      Pri       30.219     1.34%   100.00%        0.282     0.93%
      NamedProps             Pri       18.782     0.83%   100.00%        0.094     0.50%
    Note: Some small tables/indices were not printed (use /v option to see those smaller than 0.5% of the database).
    -------------------------------------------------------------------------------------

        Enumerated 48863 Tables ( 1156 Internal Trees, 1121 Long Value Trees, 5083 Secondary Indices )

        Pages 72192 ( 60833 Used (84.3%), 11359 Available (15.7%) )


    Operation completed successfully in 268.62 seconds.


    C:\Program Files\Microsoft\Exchange Server\V14\Bin>

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 1:23 PM
  • I check the Event Viewer Getting following Error 

    01

    (PID 4484, Thread 25) Task Get-ExchangeServer throwing terminating exception at stage Microsoft.Exchange.Data.Directory.ADTransientException: An error caused a change in the current set of domain controllers.. Exception: {dcf00bc7-b786-47b9-afe4-5afcfff4915b}

     

    02

     

    (PID 4484, Thread 23) Task Get-MailboxDatabase throwing terminating exception at stage Microsoft.Exchange.Data.Directory.ADTransientException: An error caused a change in the current set of domain controllers.. Exception: {cb3ce889-8291-412f-bb16-7d959a72102f}

    03

    Getting this Error while opening the Exchange management Console


    Exception type: Microsoft.Exchange.Data.Storage.RightsManagementPermanentException Exception message: Rights management operation failed.

    04

    Getting this Error while creating the new mailbox

     

    Summary: 1 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:00:00


    khalil
    Failed

    Error:
    An Active Directory error 0x51 occurred when trying to check the suitability of server 'domain.com'. Error: 'Active directory response: The LDAP server is unavailable.'

    The LDAP server is unavailable.

    Error:
    An error caused a change in the current set of domain controllers.

    Exchange Management Shell command attempted:
    Enable-Mailbox -Identity 'domain.local/ExchangeUsers/khalil' -Alias 'laghari'

    Elapsed Time: 00:00:00

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 1:33 PM
  • Go to the following location and delete the Exchange Management Console file.

    C:\users\<specific user>\AppData\Roaming\Microsoft\MMC\Exchange Management Console

     

    Can't find Exchange Management Console  because it's only showing Roaming\Microsoft\MMC  nothing in MMC folder MMC folder is empty

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Sunday, February 5, 2012 3:38 PM
  • We have only One Domain along with single GC
    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Sunday, February 5, 2012 3:41 PM
  • Thanks Steve,

    Actually time was correct on Guest  Servers i mean Exchange Server and Domain Controller , i figure out the Issue.. We are in  Virtualization Environment  we have Two Hyper-V ..I noticed that One Host has different date wheres Hyper-V is installed So i changed the Date and rebooted the both Host..Now everything is back as same as it was...No body care about Physical host when Virtualization is in place  like time and date,because I am connected with Exchange and Domain Via Remote Desktop.. I never touch the Physical Host or windows from long time because i have nothing with Physical  OS ...well Thanks again for your Information!!...

    Issue Has been Solved......

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:46 PM
    Monday, February 6, 2012 2:46 PM
  • I tried already it didn't work....

     

    I found the Issue ...

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Monday, February 6, 2012 2:48 PM

All replies

  • Hi

    Check your time and dates are synchronised between Exchange servers and DCs.  You can also try an iisreset on the Exchange server if you haven't rebooted it already.

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:46 PM
    Friday, February 3, 2012 10:31 PM
  • thanks for your reply ..i already tried all of things which you mentioned but  unfortunately  i am getting same Error, even i restart both servers, I also Dismount the Database, I even created new database  along with new mailboxes..I testes with New database and new mailboxes Issue remain same, No luck...

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 10:16 AM
  • What do you mean by Migrate? Is it cross forest or within forest?

    If its within forest then there should not be any problem.

    Looking at the above message it is obvious that you have configured RMS. Ensure that you fix RMS. This  is the reason you are not able to send message.

     


    Thanks Sunder
    Saturday, February 4, 2012 11:09 AM
  • It is Same forest ..I had active directory on  windows server 2003 .. I migrated to Windows Server 2008 R2 Enterprise, There was No issue with Migration, FSMO roles are on new server  Active Directory and Domain controller both are healthy, it's seems to be Issue of Permission But i don't know how to change or  modify User permissions, Even User can Login with their Domain account, I can see Mailboxes on Exchange Server
    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 11:36 AM
  • Could you please check RMS. I syspect RMS to be the culprit.


    Thanks Sunder
    Saturday, February 4, 2012 12:47 PM
  • We don't have RMS installed  in our Environment

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 1:21 PM
  • I tried to run the Eseutil to verify the database

    This is the output of ESEUTIL

    ******************************** MSysOLD2 DUMP ***********************************
    ***************************** MSysDatabaseMaintenance DUMP ********************************
    LastUpdateTime: 0x1CCD2C2BE872A9F
    PassStartTime: 0x0
    PassPagesRead: 0
    PrevPassStartTime: 0x1CCD2C23DCF8F3B
    PrevPassEndTime: 0x1CCD2C2BE872A9F
    PrevPassPagesRead: 71936
    ElapsedSeconds: 0
    PassInvocations: 0
    PassBadChecksum: 0
    TotalInvocations: 2
    TotalBadChecksums: 0

    ******************************** SPACE DUMP *****************************************
    Name                    Type    Owned(MB)     %OfDb  %OfTable    Avail(MB) Avail%Tbl
    =====================================================================================
    C:\exchangedatabase\exc  Db      2256.000   100.00%                  7.063

      Body-1-A               Pri       19.907     0.88%   100.00%        3.313    16.64%
        [Long Values]        LV        14.313     0.63%    71.90%        0.313     1.57%
      MDB Event History Tab  Pri       27.626     1.22%   100.00%       10.157    36.76%
      MSysObjects            Pri       50.938     2.26%   100.00%        0.282     0.55%
        Name                 Idx       17.563     0.78%    34.48%        0.032     0.06%
      MSysObjectsShadow      Pri       30.219     1.34%   100.00%        0.282     0.93%
      NamedProps             Pri       18.782     0.83%   100.00%        0.094     0.50%
    Note: Some small tables/indices were not printed (use /v option to see those smaller than 0.5% of the database).
    -------------------------------------------------------------------------------------

        Enumerated 48863 Tables ( 1156 Internal Trees, 1121 Long Value Trees, 5083 Secondary Indices )

        Pages 72192 ( 60833 Used (84.3%), 11359 Available (15.7%) )


    Operation completed successfully in 268.62 seconds.


    C:\Program Files\Microsoft\Exchange Server\V14\Bin>

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 1:23 PM
  • I check the Event Viewer Getting following Error 

    01

    (PID 4484, Thread 25) Task Get-ExchangeServer throwing terminating exception at stage Microsoft.Exchange.Data.Directory.ADTransientException: An error caused a change in the current set of domain controllers.. Exception: {dcf00bc7-b786-47b9-afe4-5afcfff4915b}

     

    02

     

    (PID 4484, Thread 23) Task Get-MailboxDatabase throwing terminating exception at stage Microsoft.Exchange.Data.Directory.ADTransientException: An error caused a change in the current set of domain controllers.. Exception: {cb3ce889-8291-412f-bb16-7d959a72102f}

    03

    Getting this Error while opening the Exchange management Console


    Exception type: Microsoft.Exchange.Data.Storage.RightsManagementPermanentException Exception message: Rights management operation failed.

    04

    Getting this Error while creating the new mailbox

     

    Summary: 1 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:00:00


    khalil
    Failed

    Error:
    An Active Directory error 0x51 occurred when trying to check the suitability of server 'domain.com'. Error: 'Active directory response: The LDAP server is unavailable.'

    The LDAP server is unavailable.

    Error:
    An error caused a change in the current set of domain controllers.

    Exchange Management Shell command attempted:
    Enable-Mailbox -Identity 'domain.local/ExchangeUsers/khalil' -Alias 'laghari'

    Elapsed Time: 00:00:00

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Saturday, February 4, 2012 1:33 PM
  • It seems that you have Domain issue.

    Could you please let me know how many DC's and GC's we have and other event id's.

     


    Thanks Sunder
    Sunday, February 5, 2012 7:02 AM
  • Hi,

    Please go through this

    http://support.microsoft.com/default.aspx?scid=kb;en-us;2019500&sd=rss&spid=13965

     

    Milan

     

     

    Sunday, February 5, 2012 7:58 AM
  • Go to the following location and delete the Exchange Management Console file.

    C:\users\<specific user>\AppData\Roaming\Microsoft\MMC\Exchange Management Console

     

    Can't find Exchange Management Console  because it's only showing Roaming\Microsoft\MMC  nothing in MMC folder MMC folder is empty

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Sunday, February 5, 2012 3:38 PM
  • We have only One Domain along with single GC
    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Sunday, February 5, 2012 3:41 PM
  • Thanks Steve,

    Actually time was correct on Guest  Servers i mean Exchange Server and Domain Controller , i figure out the Issue.. We are in  Virtualization Environment  we have Two Hyper-V ..I noticed that One Host has different date wheres Hyper-V is installed So i changed the Date and rebooted the both Host..Now everything is back as same as it was...No body care about Physical host when Virtualization is in place  like time and date,because I am connected with Exchange and Domain Via Remote Desktop.. I never touch the Physical Host or windows from long time because i have nothing with Physical  OS ...well Thanks again for your Information!!...

    Issue Has been Solved......

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:46 PM
    Monday, February 6, 2012 2:46 PM
  • I tried already it didn't work....

     

    I found the Issue ...

    • Marked as answer by khalilaghari Monday, February 6, 2012 2:48 PM
    Monday, February 6, 2012 2:48 PM
  • No problem. I'm glad that you fixed it in the end.

    Cheers,

    Steve

    Monday, February 6, 2012 3:47 PM