locked
Window Server 2016 Technical Preview 4 (build 10586) RRS feed

  • Question

  • To avoid any confusion I have started a new thread leaving TP 3 now TP 4 (10586)

    In this Version 4 I have tried to test more thoroughly and where possible put workarounds

    Windows 2016 Server Technical Preview 4 (build 10586)

     

    Need to install Cumulative patch for anything to work, this is Mandatory. Cannot start Domain until completed

    Cumulative Update for Windows Server 2016 Technical Preview 4 (KB3118754).

     

     

     

     

    Problem:

    The Settings ->Account does not allow creation of Microsoft (MSA) account

     

    Workaround1:

    Create account win16tp4, in Control panel add administrator in Windows 10 you can login into Windows Store which converts

     your current local account, with Administrator privilege,

    to MSA login Account. You can now use (SSO) Single-Sign-On account  

     

     

    Problem

    Microsoft Azure

    Login in using New MSA account

    Enter "https://manage.windowsazure.com"

    enter your Azure details, same as MSA

     

     

     

    We can't sign your account in.

    Your browser is currently set to block cookies. You need to allow cookies to use this service.

    Cookies are small text files stored on your computer that tell us when you're signed in. To learn how to allow cookies,

     check the online help in your web browser.

     

     

    Workaround2:

    Login to server with your new MSA account as above

    Open Admin Command console

    cd \Users\%USERNAME%\

    attrib -h AppData  ! unhide AppData

     

    Go to Windows File Explorer

    Navigate to C:\Users\%USERNAME%\AppData\Local\

    on the MicrosoftEdge, Right Click in Security tab "Add" the fully qualified MSA name "first.last@domain.name"

     

    Restart Edge

     

    Enter "https://manage.windowsazure.com"

    enter your Azure details, same as MSA

     

    Now Azure Management logs in

    Problem

    Next problem with connecting Azure after configuring as AD domain

     

    see http://sharepointgeorge.com/2012/configuring-active-directory-ad-ds-in-windows-server-2012/

    Really good easy articles on Windows Servers like this!!

     

    [Solved] WS2016 Technical review 4 (10586) wont allow Azure AD Connect to with working Azure MSA account

      

     

    Office 365 and office 2016 download wont register on office 365 server even though works on Windows 10 build 10576 onwards

    I cannot sign in to Office 365 via Office 2016 Excel from Single Sign On.

    Resulting in the whole of Office 2016 will be disable on December 04 2015 (seven days). Just won’t work like Windows 10 which does work and activates the products .

     

    Hardware driver problems

     

    It seems unusual to install Windows 10 client to find out what Windows Server hardware is in Device Manager. This information is then used to select the drivers as in the case of Windows Server has never recognised NVidia graphics.

    The workaround is to download the Download GeForce Experience GeForce drivers http://www.geforce.co.uk/geforce-experience/download

     

    Pioneer BDC-207D BD-ROM Blue Ray DVD drive are not recognised in WS2016 TP4 and automatically installed in Windows 10

     

    The Realtek sound card, you may not want sound on a server, but you should be able to add the device?

     

     

    The problems seem similar to those encountered in Windows 10 Enterprise edition, bits missing, because of OEM Volume database use

     Problem

    Windows Firewall Advanced in TP4. The only thing advanced about this is the age of the code. Simply failed to stop Trojan trivial Ftp code loader, which was found with AVG free anti-virus on a whole computer sweep. These Trojan were found in the Windows Server TP4 partition.

    Workaround? rid of Antimalware and put Windows Defender in place. Replace the firewall with Windows 10 Professional Firewall code, more up to date and will have EDP and Device Guard soon

     

    Problem 

    Finally the Windows Store does not show anything even when I could login!!.

    The Windows store workaround

    Find the item in Google/Bing then click on the item which takes you to the app descriptive page click “get app”

    which takes you to the Windows Store, which if logged in with MSA means you can get the New update Windows Store App,

    but this is NOT Win 10 version, for server it’s NO better than previous version

     

      

    Server Crash Restarts

    ======================

     

    The server had gone into sleep mode due to setting in control panel set as Windows 10 default.

    Server hang 69 seconds after coming out of sleep mode. Started normally then processes started dropping out (not responding).

    This problems repeatable at will. Just set sleep for 1 hour in control panel.

    Pulse power button, then start and close applications.

    Workaround: take away the sleep option in the control panel!, or fix server sleep recovery problem.

     

     

    Log Name:      System

    Source:        User32

    Date:          Fri 27 Nov 15 19:47:18

    Event ID:      1074

    Task Category: None

    Level:         Information

    Keywords:      Classic

    User:          WIN-B9E80EDMKUI\jims.xxxxxx

    Computer:      WIN-B9E80EDMKUI

    Description:

    The process C:\Windows\System32\RuntimeBroker.exe (WIN-B9E80EDMKUI) has initiated the restart of computer WIN-B9E80EDMKUI

     on behalf of user WIN-B9E80EDMKUI\jims.xxxxxx for the following reason: Application: Unresponsive

     Reason Code: 0x4040005

     Shutdown Type: restart

     Comment:

    Event Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="User32" Guid="{b0aa8734-56f7-41cc-b2f4-de228e98b946}" EventSourceName="User32" />

        <EventID Qualifiers="32768">1074</EventID>

        <Version>0</Version>

        <Level>4</Level>

        <Task>0</Task>

        <Opcode>0</Opcode>

        <Keywords>0x8080000000000000</Keywords>

        <TimeCreated SystemTime="2015-11-27T19:47:18.333722300Z" />

        <EventRecordID>3241</EventRecordID>

        <Correlation />

        <Execution ProcessID="480" ThreadID="1528" />

        <Channel>System</Channel>

        <Computer>WIN-B9E80EDMKUI</Computer>

        <Security UserID="S-1-5-21-2465910368-2869589067-776752323-1000" />

      </System>

      <EventData>

        <Data Name="param1">C:\Windows\System32\RuntimeBroker.exe (WIN-B9E80EDMKUI)</Data>

        <Data Name="param2">WIN-B9E80EDMKUI</Data>

        <Data Name="param3">Application: Unresponsive</Data>

        <Data Name="param4">0x4040005</Data>

        <Data Name="param5">restart</Data>

        <Data Name="param6">

        </Data>

        <Data Name="param7">WIN-B9E80EDMKUI\jims.xxxxxx</Data>

      </EventData>

    </Event>

     

     

    full power up Restarted all working ok

    Summary

    This is nowhere near the testing that Windows 10 has received from the Windows Insider Feedback group, but the quality and reliability do not seem to have been tested. Some may think my simple changes a security violation, and not valid, but these simple changes could be carried out remotely!!!.

    Azure Storage works well and it uses my MSA perfectly well, something in the server network is very wrong and that's why Office 365  wont connect via server I believe.

    I have nearly used up my 30 day free Azure testing so I cannot offer much in the way of testing later  




    • Edited by jims.halo10 Thursday, December 3, 2015 4:55 PM
    • Changed type jims.halo10 Tuesday, December 8, 2015 5:26 PM New errors in core systems
    Tuesday, December 1, 2015 6:16 PM

All replies

  • The good news is I have found the answer/fix to the Azure MSA login problem described above.

    In Summary Email address jims.Cloud10@hotmail.co.uk will become

    jims.Cloud10@hotmail.co.uk@jimscloud10hotmailco.onmicrosoft.com

    in the Azure Connector, spot the TWO @ signs, so Azure login fails

    The answer/fix can be found at

    [Solved] WS 2016 technical review 4 (10586) wont allow Azure AD Connect to with working Azure MSA account  

    Thursday, December 3, 2015 4:44 PM
  • Well this may be a problem. I have turned on Windows Server update services and now I cannot download the latest patch "Cumulative Update for Windows Server 2016 Technical Preview 4 for x64-based Systems (KB3116908)." without crashing at start of download with message

    Some update files are missing or have problems. We'll try to download the update again later.

    Error code: (0x80070570)

    Its been doing this for three days tried 27 times. Rebooted done all usual Windows 10 update things but wont load. The original patch worked fine, without Windows Server update services loaded

    Update

    The Windows Standalone update of Cumulative Update for Windows Server 2016 Technical Preview 4 for x64-based Systems (KB3116908) has been downloaded and installed perfect now (10586.17).

    This seems to prove my theory that the Windows Update Server has a problem downloading sefver patches once switched on. This is a know problem for language pack and Windows 10 when connected to a domain server, so its proably the same problem

    The Windows Server update services MMC snap-in reports wont work "Update Reports section" Transaction error!". However "Computers Report Tabular Status". Runs succesfully reporting the number of records being processed the produces summary display. The Net Framework 3.5 Feature will not install due to being blocked by some sort of policy. This v3.5 is needed to support reporting. Something needs updating to use Net 4. There were 4 msi packages related to SQL server which had dependancies which need external downloads and installation before reporting can take place and seeing as these are free why dont the get installed from Server manage feature at same time as Window Server Update Services is added

    Update

    The Windows Standalone update of Cumulative Update for Windows Server 2016 Technical Preview 4 for x64-based Systems (KB3116908) has been downloaded and installed now (10586.17). This seems to prove my theory that the Windows Update Server has a problem.

    This KB3116908 did NOT fix the Windows Update problems


    • Edited by jims.halo10 Tuesday, December 8, 2015 9:15 PM Stndalone Cumulative Update for Windows Server 2016 (KB3116908)
    Tuesday, December 8, 2015 5:25 PM
  • Hi,

    Thank you for your detailed sharing, it would be helpful for other people who has the similar problem. 

    Also, Windows Server 2016 TP4 is still a preview version, you may submit the suggestion/feedback to related department via “Windows Feedback” app.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, December 31, 2015 8:32 AM