Fail to add Hyper-V Role on Windows 2012 Datacenter R2


  • Hi,

    we are trying to enable Hyper-V role on a Windows Datacenter 2012 R2 (Preview). The server is a domain member. The installation fails after the first reboot, with the following event-view error:

    Update Microsoft-Hyper-V-Online of package Microsoft-Hyper-V-ServerEdition-Package failed to be turned on. Status: 0x800f0922.

    Any suggestion is appreciated


    A. Brazo

    Tuesday, September 24, 2013 10:06 AM


All replies


    Brian Ehlert
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Tuesday, September 24, 2013 3:55 PM
  • Hi Aieie,

    Did the problem be solved?

    Elton ji

    Monday, September 30, 2013 6:28 AM
  • Hi

    I have the same problem. Upgrading from 2012 Ent (only Hyper-V and file services) to 2012 R2 fails and a clean install of 2012 R2 Ent (German) is OK but activating the hyper-V fails.

    I recovered to 2012 Ent and try to build an appropriate laboratory environment.



    Monday, September 30, 2013 7:14 AM
  • Hi Frank,

    I don't know if you read the reply of Brian Eh .

    But in my opinion , you may have a try by the following step:

                  remove the "\Boot folder" on your system

                   insert your windows2012 media and chose repair

                   check the partition statue active

                   run bootrec /fixmbr + bootrec /fixboot + bootrec /rebuildbcd

                   rebooting back into windows2012 and try install the hyper-v role again


    If the issue still not be solved,we suggest you to create a new post.


    Hope it helps.

    Best Regards

    Elton Ji

    Monday, September 30, 2013 10:00 AM
  • Hi Elton,

    thank You for Your fast reply.

    Actual I am running a new clean Windows Server 2012 Ent (not R2) installation on this machine and all works fine. 3 of the 5 VMs are running with 2012 R2.

    I'll wait and try an other update to Win Server 2012 R2 later if I have an comparable spare machine.


    Monday, September 30, 2013 1:05 PM
  • Hi Frank,

    May be i misunderstand , but you said " a clean install of 2012 R2 Ent (German) is OK but activating the hyper-V fails" . Did the problem appear after a clean install of 2012 R2 Ent (German) and you didn't try to solve the problem with my recommendation then you installed a new Windows server 2012 Ent ?


    Elton Ji

    Tuesday, October 01, 2013 1:04 PM
  • Hi Elton,
    Yes about 14 days ago, I made an upgrade form Win 2012 to Win 2012 R2 which failed. Then I made a clean install of Windows 2012 R2 on volume C:, which was OK. Then I activated the hyper-V role, which also failed.
    After a few restarts without any sucess, I immediately made a fallback to a clean Win 2012 installation, because we need this pilot server.
    Last week I reconfigured the server and the raid devices and created an extra partition to enable a dual boot configuration on this server. We also decided to change the USB 3.0 controller (from ASUS U3S6 to sempre UP33-I19, which has a newer NEC uPD720201 Chip).
    This morning I made a new attempt. Installing Win 2012 R2 and activating hyper-V in the Dual boot envoriment was fine. So I tried an update of the main partition to Win 2012 R2, which also was OK.
    So the problem is solved.

    Tuesday, October 01, 2013 3:16 PM