locked
OOF and Free Busy not working in Outlook 2007, works fine in OWA RRS feed

Answers

  • Can you connect to :
    http://mail.hmc1.comcast.net/EWS/Exchange.asmx
     
    and if so, authenticate to it

    It should be https:

    Are those values set correctly at the company hosting the Exchange Server?





    • Marked as answer by boulderjoe Monday, November 23, 2009 5:18 AM
    Thursday, November 19, 2009 8:33 PM
    Moderator
  • SOLVED! Andy David had it from the beginning. The problem is that the AS and OOF addresses in the autoconfig file are NOT https. After forcing a local XML with corrected servers I can connect to OOF and FB perfectly.  YAHOO!

    How I solved w/o access to the server:
    -Added to registry: HKCU\Software\Microsoft\Office\12.0\Outlook\Autodiscover  DWORD: PreferLocalXML = 1
    -Added to registry: HKCU\Software\Microsoft\Office\12.0\Outlook\Autodiscover  STRING: *mydomain*.com
    (note that the path is in 8 character paths: C:\PROGRA~1\MICROS~2\Office12\OUTLOO~1\MYDOMA~1.XML [you can copy this path from one of the other xml entries])
    -Put my modified XML (created from copying and pasting XML from autoconfig test and correcting it) into C:\PROGRA~1\MICROS~2\Office12\OUTLOO~1\
    -Test autoconfig to make sure new https servers are appearing

    • Marked as answer by boulderjoe Monday, November 23, 2009 5:15 AM
    Monday, November 23, 2009 5:15 AM

All replies

  • Can you connect to :
    http://mail.hmc1.comcast.net/EWS/Exchange.asmx
     
    and if so, authenticate to it

    It should be https:

    Are those values set correctly at the company hosting the Exchange Server?





    • Marked as answer by boulderjoe Monday, November 23, 2009 5:18 AM
    Thursday, November 19, 2009 8:33 PM
    Moderator
  • I can connect, it automatically takes me to https, and then I get the huge list of xml code. I can post the whole thing or anything of interest. I'm new to exchange, so I'm not sure what the correct values are supposed to be.

    Thanks (I'll paste an exerpt below)

    <?xml version="1.0" encoding="utf-8" ?>
    + <wsdl:definitions xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:tns="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:s="http://www.w3.org/2001/XMLSchema" targetNamespace="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types">

    - <!--
     Availability Service 
      -->
    - <!--
     GetUserAvailability 
      -->
    - <wsdl:operation name="GetUserAvailability">
      <soap:operation soapAction="http://schemas.microsoft.com/exchange/services/2006/messages/GetUserAvailability" />
    - <wsdl:input>
      <soap:body parts="GetUserAvailabilityRequest" use="literal" />
      <soap:header message="tns:GetUserAvailabilitySoapIn" part="SerializedSecurityContext" use="literal" />
      <soap:header message="tns:GetUserAvailabilitySoapIn" part="ProxyRequestTypeHeader" use="literal" />
      </wsdl:input>
    - <wsdl:output>
      <soap:body parts="GetUserAvailabilityResult" use="literal" />
      <soap:header message="tns:GetUserAvailabilitySoapOut" part="ServerVersion" use="literal" />
      </wsdl:output>
      </wsdl:operation>
    - <!--
     GetUserOofSettings 
      -->
    - <wsdl:operation name="GetUserOofSettings">
      <soap:operation soapAction="http://schemas.microsoft.com/exchange/services/2006/messages/GetUserOofSettings" />
    - <wsdl:input>
      <soap:body parts="GetUserOofSettingsRequest" use="literal" />
      </wsdl:input>
    - <wsdl:output>
      <soap:body parts="GetUserOofSettingsResult" use="literal" />
      <soap:header message="tns:GetUserOofSettingsSoapOut" part="ServerVersion" use="literal" />
      </wsdl:output>
      </wsdl:operation>
    - <!--
     SetUserOofSettings 
      -->
    - <wsdl:operation name="SetUserOofSettings">
      <soap:operation soapAction="http://schemas.microsoft.com/exchange/services/2006/messages/SetUserOofSettings" />
    - <wsdl:input>
      <soap:body parts="SetUserOofSettingsRequest" use="literal" />
      </wsdl:input>
    - <wsdl:output>
      <soap:body parts="SetUserOofSettingsResult" use="literal" />
      <soap:header message="tns:SetUserOofSettingsSoapOut" part="ServerVersion" use="literal" />
      </wsdl:output>
      </wsdl:operation>
      </wsdl:binding>
      </wsdl:definitions>
    Thursday, November 19, 2009 9:23 PM
  • Check info:

    1.      Please describe the exchange version, and the topology

    2.      How did the clients connect to the exchange, via outlook anywhere?

    3.      Does the issue happen to all mailboxes, and newly create mailbox?

    4.      When the issues start to happen? Have the OOF/FB worked before?

    Troubleshooting:

    1.      Please see if you can get expected error 600 in the xml page when browse /autodiscovery virtual directory [https://FQDNOfCas/Autodiscover/Autodiscover.xml]

    2.      What’s the permissions on the /EWS virtual directory?

    ·         Administrators: Full Control

    ·         Authenticated Users: Read & Execute, Read

    ·         System: Full Control

    3.      Please verify the setting of authentication  of default virtual directories on the CAS serves (Reference)

    4.      Quotes: “2009/11/19 13:11:00.276: HTTP status code: 3022009/11/19 13:11:00.276”

    Commonly, status code 302 indicates redirection. Please follow the “Http Referral” section in this article to verify the redirection

    5.      Please check if “Enable HTTP Keep-Alives” is checked properly in the IIS [6.0 | 7.0]

    6.      Have you installed .NET Framework 3.5 with SP1 and the .NET Framework 2.0 with SP2 on a CAS server? (KB 958934)

    7.      On the CAS sever, web.config file holding the default IIS configuration in the folder C:\Windows\microsoft.net\Framework64\v2.0.50727\CONFIG. Please open it with notepad, and check the following section, ensure it’s same as mine

    <system.web>

             <authorization>

                       <allow users="*" />

            </authorization>

    8.      Please run ExBPA against the exchange servers for health check

    Resource:

    Your Out of Office settings cannot be displayed...what's wrong?


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Friday, November 20, 2009 7:27 AM
  • Thanks for that reply but I don't have access to the server. I was hoping the problem could be found on the client side via behavior and logs.
    The issue is happening for all mailboxes when Outlook is used. OWA shows information fine.
    The free/busy worked up to a week ago using the LegacyFB=1 switch but has never worked without it. Now it does not work either way.

    Friday, November 20, 2009 4:40 PM
  • You have gathered most of the log files, it’s time to look on the server side.

    Can you describe more about this LegacyFB=1 switch?


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Monday, November 23, 2009 1:54 AM
  • The UseLegacy FB registry addition allowed me to see the FB information until about a week ago.

    Open the registry:
    Go to:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Calendar
    Click edit and create a new DWORD Value
    Give the value name:
    “UseLegacyFB”
    Change the value data to: 1

    Since I have tried to set up my exchange from the beginning I have not gotten free busy or OOF to work without this registry addition, which now no longer works.

    It's really frustrating because I can't talk to the provider of the exchange service. I can call comcast, who then relays everything to their Exchange provider. I'm hoping to identify something to tell them to directly investigate/fix. I'm thinking it might be an error in the autoconfig setup on their side.

    Monday, November 23, 2009 2:43 AM
  • As you probably already knew the purpose of this registry, which will led the outlook 2007 to use the legacy FB mechanism (Public folder). The default method is to use availability service of exchange 2007 for outlook 2007

    If the registry wasn’t working anymore, the issue may be related to public folder.  Yet, the OOF will also rely on the availability service

    Since the issue unlike to be caused by client side, I would suggest you to ask the administrators on the server side to look on their end


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Monday, November 23, 2009 3:35 AM
  • Thanks James, I appreciate your help.
    Monday, November 23, 2009 3:53 AM
  • I think I may have found the problem. the OOF and AS autodiscover URLs are pointing to:
    <OOFUrl>http://mail.hmc1.comcast.net/EWS/Exchange.asmx</OOFUrl>

    When they should be secure: <OOFUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</OOFUrl>

    Is there a way to force a local XML to try that fix?  I've read Outlook 2007 allows an XML file to be deployed to the users machine and can be configured to check the local file first. This XML file can specify the url of the appropriate autodiscover server. How do I go about making it? copy and paste from the autoconfig XML log and change what I need?
    Monday, November 23, 2009 4:49 AM
  • SOLVED! Andy David had it from the beginning. The problem is that the AS and OOF addresses in the autoconfig file are NOT https. After forcing a local XML with corrected servers I can connect to OOF and FB perfectly.  YAHOO!

    How I solved w/o access to the server:
    -Added to registry: HKCU\Software\Microsoft\Office\12.0\Outlook\Autodiscover  DWORD: PreferLocalXML = 1
    -Added to registry: HKCU\Software\Microsoft\Office\12.0\Outlook\Autodiscover  STRING: *mydomain*.com
    (note that the path is in 8 character paths: C:\PROGRA~1\MICROS~2\Office12\OUTLOO~1\MYDOMA~1.XML [you can copy this path from one of the other xml entries])
    -Put my modified XML (created from copying and pasting XML from autoconfig test and correcting it) into C:\PROGRA~1\MICROS~2\Office12\OUTLOO~1\
    -Test autoconfig to make sure new https servers are appearing

    • Marked as answer by boulderjoe Monday, November 23, 2009 5:15 AM
    Monday, November 23, 2009 5:15 AM
  • NEW PROBLEM:

    I got my provider to change the servers in question to https, and now NEITHER the untouched autodiscover settings NOR the manual override settings mentioned above work. :o(

    Autodiscover XML:
    -----------------------------------------------------------------------
    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
        <User>
          <DisplayName>Joe</DisplayName>
          <LegacyDN>/o=HMC1/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=[USERNAME]</LegacyDN>
          <DeploymentId>5bc4ea9a-43fe-4b07-b0df-78081a5129e1</DeploymentId>
        </User>
        <Account>
          <AccountType>email</AccountType>
          <Action>settings</Action>
          <Protocol>
            <Type>EXCH</Type>
            <Server>P1EC2EVS02.HMC1.COMCAST.NET</Server>
            <ServerDN>/o=HMC1/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=P1EC2EVS02</ServerDN>
            <ServerVersion>720180F0</ServerVersion>
            <MdbDN>/o=HMC1/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=P1EC2EVS02/cn=Microsoft Private MDB</MdbDN>
            <PublicFolderServer>P1OAB100.HMC1.COMCAST.NET</PublicFolderServer>
            <AD>P1ADS07.HMC1.COMCAST.NET</AD>
            <ASUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</EwsUrl>
            <OOFUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://p1cas08.hmc1.comcast.net/UnifiedMessaging/Service.asmx</UMUrl>
            <OABUrl>Public Folder</OABUrl>
          </Protocol>
          <Protocol>
            <Type>EXPR</Type>
            <Server>mail.hmc1.comcast.net</Server>
            <SSL>On</SSL>
            <AuthPackage>Basic</AuthPackage>
            <ASUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</EwsUrl>
            <OOFUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</OOFUrl>
            <OABUrl>Public Folder</OABUrl>
          </Protocol>
          <Protocol>
            <Type>WEB</Type>
            <External>
              <OWAUrl AuthenticationMethod="Fba">http://webmail.hmc1.comcast.net/owa</OWAUrl>
              <Protocol>
                <Type>EXPR</Type>
                <ASUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </External>
            <Internal>
              <OWAUrl AuthenticationMethod="Basic, Fba">http://webmail.hmc1.comcast.net/owa</OWAUrl>
              <Protocol>
                <Type>EXCH</Type>
                <ASUrl>https://mail.hmc1.comcast.net/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </Internal>
          </Protocol>
        </Account>
      </Response>
    </Autodiscover>
    ------------------------------------------------------------


    F/B Error Log:
    ---------------------------------------------------------------------------------------------------------
    2009/12/14 11:08:46.145: Getting ASURL

    2009/12/14 11:08:46.145: URL returned from cached autodiscover: https://mail.hmc1.comcast.net/EWS/Exchange.asmx

    2009/12/14 11:08:46.145: Request to URL: https://mail.hmc1.comcast.net/EWS/Exchange.asmx

    2009/12/14 11:08:46.145: Request action: http://schemas.microsoft.com/exchange/services/2006/messages/GetUserAvailability

    2009/12/14 11:08:46.145: Request XML: <?xml version="1.0"?>

    <q:Envelope xmlns:q="http://schemas.xmlsoap.org/soap/envelope/"><q:Body><ex12m:GetUserAvailabilityRequest xmlns:ex12m="http://schemas.microsoft.com/exchange/services/2006/messages"><ex12t:TimeZone xmlns:ex12t="http://schemas.microsoft.com/exchange/services/2006/types"><ex12t:Bias>420</ex12t:Bias><ex12t:StandardTime><ex12t:Bias>0</ex12t:Bias><ex12t:Time>02:00:00</ex12t:Time><ex12t:DayOrder>1</ex12t:DayOrder><ex12t:Month>11</ex12t:Month><ex12t:DayOfWeek>Sunday</ex12t:DayOfWeek></ex12t:StandardTime><ex12t:DaylightTime><ex12t:Bias>-60</ex12t:Bias><ex12t:Time>02:00:00</ex12t:Time><ex12t:DayOrder>2</ex12t:DayOrder><ex12t:Month>3</ex12t:Month><ex12t:DayOfWeek>Sunday</ex12t:DayOfWeek></ex12t:DaylightTime></ex12t:TimeZone><ex12m:MailboxDataArray><ex12t:MailboxData xmlns:ex12t="http://schemas.microsoft.com/exchange/services/2006/types"><ex12t:Email><ex12t:Address>[user]@[domain].com</ex12t:Address><ex12t:RoutingType>SMTP</ex12t:RoutingType></ex12t:Email><ex12t:AttendeeType>Required</ex12t:AttendeeType></ex12t:MailboxData></ex12m:MailboxDataArray><ex12t:FreeBusyViewOptions xmlns:ex12t="http://schemas.microsoft.com/exchange/services/2006/types"><ex12t:TimeWindow><ex12t:StartTime>2009-11-28T13:00:00</ex12t:StartTime><ex12t:EndTime>2009-12-28T13:00:00</ex12t:EndTime></ex12t:TimeWindow><ex12t:MergedFreeBusyIntervalInMinutes>30</ex12t:MergedFreeBusyIntervalInMinutes><ex12t:RequestedView>Detailed</ex12t:RequestedView></ex12t:FreeBusyViewOptions></ex12m:GetUserAvailabilityRequest></q:Body></q:Envelope>

    2009/12/14 11:08:46.145: Sending request

    2009/12/14 11:08:46.590: Request sent

    2009/12/14 11:08:46.590: Response error code: 00000000

    2009/12/14 11:08:46.590: HTTP status code: 200

    2009/12/14 11:08:46.591: XML response:<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Header><t:ServerVersionInfo MajorVersion="8" MinorVersion="1" MajorBuildNumber="375" MinorBuildNumber="1" xmlns:t="http://schemas.microsoft.com/exchange/services/2006/types" /></soap:Header><soap:Body><GetUserAvailabilityResponse xmlns="http://schemas.microsoft.com/exchange/services/2006/messages" /></soap:Body></soap:Envelope>

    2009/12/14 11:08:46.591: XML response processed successfully
    -----------------------------------------------------------

    Any hints anyone?

    Monday, December 14, 2009 6:16 PM