locked
Putting sysprep and capture in task sequence, capture options not showing up RRS feed

  • Question

  • Okay, so I have a task sequence that installs my patches, applications, and customizations like wallpapers, some registry edits for security purposes etc. I finally got it all to work and install how I want it on my virtual box.

    Now my next issue is getting the thing syspreped and captured. I cant get the capture screen(the one that says where you want to save it to) to pop up when trying to capture the image.  I checked my customsettings.ini and I have skipcature=no and docapture=yes. Ideally, I would like to have everything automated in one TS, but I have to figure out how to get the sysprep and capture in my current TS. I have tried creating a sysprep and capture TS and copying the files into my build TS with no dice. I have ran my Build TS and then try to go back and run another TS, the sysprep + capture, with no dice. So at this point Im not sure what to do next.

    If I create a new TS with just the sysprep+capture default settings the option comes out, but that doesn't help me because then it wouldn't include any of my updates, apps or customizations.

    Any help would be appreciated.

    Wednesday, December 18, 2013 6:45 PM

All replies

  • Try removing the domain join.

    Blog: http://scriptimus.wordpress.com

    Wednesday, December 18, 2013 8:14 PM
  • Remove it from where? It's not in my customsettings.ini, nor does it join a domain when I run the TS.
    Wednesday, December 18, 2013 8:18 PM
  • Hmm. Just a thought.

    Let me think on this some more. . .


    Blog: http://scriptimus.wordpress.com

    Wednesday, December 18, 2013 8:58 PM
  • Post your customsettings.ini please (minus passwords etc.)

    Also, have a read of the skipping deployment wizard pages table also to see if anything might be amiss.

    /Andrew


    Blog: http://scriptimus.wordpress.com

    Wednesday, December 18, 2013 9:02 PM
  • [Settings]
    Priority= Default
    Properties=MyCustomProperty

    [Default]
    _SMSTSORGNAME=BUILD
    OSInstall=Y
    SkipAppsOnUpgrade=YES
    SkipApplications=NO
    SkipBitlocker=YES

    SkipComputerName=YES
    SkipDomainMembership=YES
    SkipCapture=NO
    DoCapture=YES
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipDeploymentType=YES
    DeploymentType=NEWCOMPUTER


    SkipLocaleSelection=YES
    KeyboardLocale=en-US
    UserLocale=en-US
    UILanguage=en-US
    SkipTimeZone=YES
    TimeZone=Central Standard Time

    SkipUserData=YES
    SkipSummary=YES
    SkipFinalSummary=YES
    Wednesday, December 18, 2013 9:20 PM
  •  Try this:

     DoCapture=YES
     ComputerBackupLocation=AUTO
     BackupShare=\\Server\Share$
     BackupDir=Captures
     BackupFile=%OSDComputerName%.wim

    Also, comment this line out with a ' and test again
     SkipCapture=NO

    Also comment these out
     SkipDeploymentType=YES
     DeploymentType=NEWCOMPUTER

    These are defaults so can go
     KeyboardLocale=en-US
     UserLocale=en-US
     UILanguage=en-US

    Get rid of this until you get it working. It's helpful for you to debug the properties
     SkipSummary=YES

    /Andrew


    Blog: http://scriptimus.wordpress.com


    • Edited by Andrew Barnes Wednesday, December 18, 2013 9:45 PM updated
    Wednesday, December 18, 2013 9:40 PM
  • Did all of these changes and it still doesn't ask me about capturing the image and where I want it to save etc.
    Wednesday, December 18, 2013 10:05 PM
  • Are you running a post os Task sequence per chance?

    Blog: http://scriptimus.wordpress.com

    Wednesday, December 18, 2013 10:55 PM
  • The only other suggestion I have is 

    Create a Sysprep and Capture task sequence.

    Backup your customsettings.ini and then strip it down to this

    [Settings]
    Priority= Default
    Properties=MyCustomProperty

    [Default]

    Finally, tun the litetouch.vbs on the client again.


    Blog: http://scriptimus.wordpress.com

    Wednesday, December 18, 2013 11:20 PM