locked
Cannot connect to \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query RRS feed

  • Question

  • Hi,

    We have an issue whereby our WSUS database has never been cleaned and this has resulted in all x86 machines not downloading any software updates.

    I've managed to delete around 5000 declined updates through the WSUS console, but I'm now getting stuck with a timeout error.

    I'm trying to follow the steps in the following post :

    social.technet.microsoft.com/Forums/exchange/en-US/7b12f8b2-d0e6-4f63-a98a-019356183c29/getting-past-wsus-cleanup-wizard-time-out-removing-unnecessary-updates?forum=winserverwsus

    but I am getting stuck with the following error :

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to \\ .\pipe\MSSQL$MICROSOFT##SSEE\sql\query.

    ------------------------------
    ADDITIONAL INFORMATION:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)

    For help, click: go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=2&LinkId=20476

    ------------------------------

    The system cannot find the file specified

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Can anyone help? Many thanks.

    Tuesday, October 27, 2015 11:21 AM

Answers

  • you can still perform the same steps in the link you posted whether it's WID or SQL DB. you just connect to the SQL DB using a different command syntax on sqlcmd.exe or you can just use SQL Management Studio and run the command right from the GUI

    i haven't personally dealt with this issue myself though

    • Marked as answer by kingici Wednesday, October 28, 2015 9:47 AM
    Tuesday, October 27, 2015 2:45 PM

All replies

  • looks like you have a space in your named pipe path, make sure you're using this command:

    sqlcmd.exe -S np:\\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query

    note that this only works in the event that you're using the windows internal database for wsus. if you're using a full SQL database the process is completely different

    • Proposed as answer by Steven_Lee0510 Wednesday, October 28, 2015 8:37 AM
    Tuesday, October 27, 2015 12:53 PM
  • Hi,

    I was not involved in the setup of WSUS on our system, so was not aware of the separate database types.

    It does seem as if we are not using the windows internal database for WSUS.

    So with that in mind, do you know what steps I can follow to get past the timeout error that I am getting, as there is still over 8000 declined entries that I need to delete.

    many thanks.

    Tuesday, October 27, 2015 2:42 PM
  • you can still perform the same steps in the link you posted whether it's WID or SQL DB. you just connect to the SQL DB using a different command syntax on sqlcmd.exe or you can just use SQL Management Studio and run the command right from the GUI

    i haven't personally dealt with this issue myself though

    • Marked as answer by kingici Wednesday, October 28, 2015 9:47 AM
    Tuesday, October 27, 2015 2:45 PM
  • Hi,

    To verify the settings of WSUS server, please check the registry settings below:

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, October 28, 2015 8:37 AM
  • all sorted now thanks.

    Realised that the database was not internal to windows, so I was then able to run sql commands direct from the SUSDB datsbase within Sql Management studio.

    Many thanks to you both.

    Wednesday, October 28, 2015 9:46 AM
  • Hi all. Sorry to jump on an old post but I am having the EXACT same issue, and I AM using the Microsot Internal Database. I DL'd the management studio and attempted to connect using

    \\.\pipe\MSSQL$MICROSOFT##SSEE\sql\query

    and named pipes, but I cannot connect. I suspect the database reached it's maximum size, and now will not respond to connections or queries. Please advise. And please do not tell me I have to scrap the entire thing and start over. I've already run the reset procedure, but of course because the database will not respond, it cannot be queried for updates to know which ones to download again.

    This issue occurs because the default settings of WSUS will download ALL updates, even the expired ones, so that the database WILL fill up and fail. It's only a matter of time. I know now how to exclude expired and not needed updates, but this is a time bomb for anyone setting up WSUS the first time.


    Tuesday, May 15, 2018 11:05 PM
  • Turns out the internal database pipe is named different for Windows Server 2012. It's:

    \\.\pipe\MICROSOFT##WID\tsql\query

    Wednesday, May 16, 2018 6:25 PM
  • I was running Windows Server 2012 R2. This worked for me. I also used windows authentication. 
    Wednesday, June 20, 2018 8:49 PM
  • Yes, Make sure you're performing the proper maintenance procedures for WSUS. Too many times issues arise because the maintenance hasn't been done.

    https://www.ajtek.ca/wsus/how-to-setup-manage-and-maintain-wsus-part-8-wsus-server-maintenance/


    Adam Marshall, MCSE: Security
    https://www.ajtek.ca
    Microsoft MVP - Windows and Devices for IT

    Thursday, June 21, 2018 3:51 PM