locked
Taskbar "always combine" doesn't always combine RRS feed

  • Question

  • (Build 7100)  Has anyone else seen this?

    I have "always Combine" set for taskbar icons.  This usually works as expected.  With some notable exceptions.

    I open multiple instances of Windows Notepad in various ways, some by launching a text file in Explorer, some by right clicking an existing Notepad icon and launching a new instance, some using "Open With", etc..  Some files have .txt extension, some do not (hence "open with"). 

    I end up with two stacks of Notepad icons.  The pattern as to which instances end up in stack "a" as opposed to stack "b" seems to be totally random.  Unfortunately, this makes the Notepad icon something of a shell game:  which shell has the pea?

    I run another application that NEVER combines.  I rarely have more two instances of this open, so it isn't that much a problem.  Just curious about why this feature seems to be so unreliable.  Bug?  If so, is it in the Windows base, or in the applications?
    Sunday, July 12, 2009 6:11 PM

Answers

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    As I know, in Windows 7, you can customize the taskbar under three ways. Always combine is set by default, each program appears as a single, unlabeled icon even when multiple items for a program are open. Only different programs are open, can different programs appear as different icons. I suspect

    that your computer is infected by virus so that Windows recognizes these infected files as another application. Therefore, I would like to suggest you scanning your computer with the latest security software.

     

    If you can't find any virus or malware, let's continue the following steps.

     

    1.    Disable "Always combine, hide labels" and re-enable "Always combine, hide labels".

     

    1)     Open Taskbar and Start Menu Properties by clicking the Start button, clicking Control Panel, clicking Appearance and Personalization, and then clicking Taskbar and Start Menu.

    2)     Under Taskbar appearance, select "Never combine" from the Taskbar buttons list.

    3)     Click OK.

    4)     After this feature takes effect, return to Taskbar and Start Menu to select " Always combine, hide labels".

    5)     Run Notepad as before to see if the issue occurs.

     

    2.    Run Group Policy Editor to enable Superbar.

     

    1)     Run gpedit.msc and enable User Configuration\Administrative Templates\Start Menu and Taskbar\Prevent grouping of taskbar items

    2)     Restart explorer.exe

    3)     Right-click on the taskbar and select Properties to choose "Always combine, hide labels".

    4)     Run Notepad to see if the issue persists.

     

    Note: if the button grouping does not change during step 2, repeat step 2 until it does. The group policy may not take effect right away.

     

    Hope this helps. Thanks.

    • Marked as answer by Nicholas Li Friday, July 17, 2009 10:36 AM
    Wednesday, July 15, 2009 9:35 AM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    As I know, in Windows 7, you can customize the taskbar under three ways. Always combine is set by default, each program appears as a single, unlabeled icon even when multiple items for a program are open. Only different programs are open, can different programs appear as different icons. I suspect

    that your computer is infected by virus so that Windows recognizes these infected files as another application. Therefore, I would like to suggest you scanning your computer with the latest security software.

     

    If you can't find any virus or malware, let's continue the following steps.

     

    1.    Disable "Always combine, hide labels" and re-enable "Always combine, hide labels".

     

    1)     Open Taskbar and Start Menu Properties by clicking the Start button, clicking Control Panel, clicking Appearance and Personalization, and then clicking Taskbar and Start Menu.

    2)     Under Taskbar appearance, select "Never combine" from the Taskbar buttons list.

    3)     Click OK.

    4)     After this feature takes effect, return to Taskbar and Start Menu to select " Always combine, hide labels".

    5)     Run Notepad as before to see if the issue occurs.

     

    2.    Run Group Policy Editor to enable Superbar.

     

    1)     Run gpedit.msc and enable User Configuration\Administrative Templates\Start Menu and Taskbar\Prevent grouping of taskbar items

    2)     Restart explorer.exe

    3)     Right-click on the taskbar and select Properties to choose "Always combine, hide labels".

    4)     Run Notepad to see if the issue persists.

     

    Note: if the button grouping does not change during step 2, repeat step 2 until it does. The group policy may not take effect right away.

     

    Hope this helps. Thanks.

    • Marked as answer by Nicholas Li Friday, July 17, 2009 10:36 AM
    Wednesday, July 15, 2009 9:35 AM
  • I realize this is a long time after you asked this question, but since the answer you were given didn't work for me and I found another way, I thought I'd share it.

     

    I don't know about your other application, but the problem with Notepad is that notepad.exe resides in multiple places on your machine.  I'm running 64bit windows, so I have a copy in c:\Windows\SysWOW64 as well as in c:\Windows\System32. 

    The shortcut to notepad in the start menu called the version of notepad in system32.  However, just opening an existing text file would open the version of notepad in syswow64. 

     

    My workaround, which I can't officially endorse or anything, was to change the shortcut in start menu to syswow64, so now I'm always running the same version of notepad.  It's fixed my grouping problem.  Hope it helps.

     

    J

    Monday, April 5, 2010 2:33 AM
  • That's a very good observation, Jeff.  Upon reading the original post (and not noticing that it was so old) I was about to suggest checking to see if both 32 and 64 bit versions are running, because the system will not group 32 and 64 bit apps together, no matter whether they are named the same.  One could debate the logic in that, but it is what it is.

    Most people don't realize that virtually every part of the system on an x64 install is provided in both 32 and 64 bit versions.

    The real bug here is that the 64 bit OS should be starting the 64 bit Notepad.exe file for every different method of starting it, instead of there being a mix of different apps being started.

    Indeed Microsoft removed the ability for the 32 bit Explorer to be run just prior to RTM, making a big stride toward having everything starting 64 bit apps right there.  Apparently they didn't find and fix all the shortcuts to the 32 bit software in all the various places in the system.

    -Noel

    Tuesday, April 6, 2010 1:09 AM
  • Isn't that strange - surely the largest software developer in the world has heard of interface decoupling?
    If you buy three cars and the same wheel falls off all three, do you contact the person who sold you the cars or the person who made them?
    Tuesday, July 27, 2010 5:15 AM
  • 9 years later... still happening in Windows 7, still happening in Windows 10. It happens with Microsoft Word 2013 and other things. Basic user interface bugs go on for years and years and fucking years? This is why I think the computer industry is still in its infancy, either that or it is decrepit, old, and senile. You just can't count on any software company to get it right. It is 2018 and they still can't make the fucking taskbar work as expected? I have two groups of Microsoft Word 2013 documents open at the moment. There appears to only be one version of Word installed and even if there were two, why didn't the company who made this application and the OS itself figure this out!?
    Monday, February 12, 2018 5:49 PM
  • Windows hasn't really advanced this decade, has it, when you consider serious computing needs.

    Microsoft started to ignore their own quite rich desktop UI design rules during the development of Windows 8 then abandoned them altogether with Windows 10.  It seems  that somewhere in their house there must be a "deprecate the desktop" mandate.

    That might be fine - maybe there's a better way to compute - but they're "moving on" without having invented any better way.  And surprise, surprise!  Doing it like a phone isn't better for a serious computer.  Nor does donning a headset and talking to Cortana actually facilitate work.

    We're not seeing moves to make it better, either.  Here I'm personally holding onto Win 8.1 x64 and Office 2010 (for which I had to go out of my way to install the 64 bit variant).

    30 years ago we imagined a Star Trek future where we would be thinking in high level concepts and would have integrated field theory into everyday life.  Unfortunately, Idiocracy is being taken as the "how to" guide instead, and we're having trouble doing even as much work as we did when computers were 1/10th as powerful.

    -Noel


    Detailed how-to in my eBooks:  

    Configure The Windows 7 "To Work" Options
    Configure The Windows 8 "To Work" Options
    Not feeling enough love to make one for Windows 10

    Thursday, February 22, 2018 8:42 PM