none
Error when creating a Protection Group to backup Sharepoint 2010 RRS feed

  • Question

  • I have an error when creating a Protection Group to backup Sharepoint 2010. Here is my scenario:

    - Sharepoint Server details:

    --- OS: Windows Server 2008 R2

    --- DB: SQL Server 2008 SP2 with CU2

    --- SP: Sharepoint Server 2010

    --- Addtional: ran the ConfigureSharepoint.exe command to enable the Sharepoint VSS Writer with Success

     

    When I create protection group, I see the Sharepoint Farm. When i select it.. the pop up appears stating the following:

    One or more prerequisites for protecting this data source are missing.
    Ensure that the following prerequisite software is installed on spsvr.systemcenter.local, the front-end web servers and all of the back-end computers running SQL Server  (including all cluster nodes and mirror partner nodes):

    All Front-end Web servers:
    Windows Server 2008 x64

    All Back-end computers running SQL Server:
    Windows Server 2003 SP1 with Knowledge Base article 940349
            - OR -
    Windows Server 2008

    All Front-end Web servers:
    SharePoint Foundation Server 2010
            -OR-
    Microsoft Office SharePoint Server (MOSS) 2010

    Back-end computers running SQL Server:
    SQL Server 2000 SP4
            - OR -
    SQL Server 2005 SP1
            - OR –
    SQL Server 2008

    Servers hosting a mirrored instance of SQL Server:
    SQL Server 2005 SP1
            - OR –
    SQL Server 2008

    To obtain the required updates, go to http://go.microsoft.com/fwlink/?LinkId=128883

     

    ID: 31312

     

    -- I tried clicking the link but none of the updates apply to my environment. I am stuck.


    Ray Chou | MVP SCOM | http://mymomexperience.blogspot.com
    Monday, October 25, 2010 3:47 PM

Answers

All replies

  • Hi Ray!

    Your missing out on the prerequisites for the SharePoint 2010 workload. Look at this link to verify that you have covered all the needed hotfixes. http://technet.microsoft.com/en-us/library/ff399140.aspx

    BR

    Robert Hedblom

     



    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Wednesday, October 27, 2010 7:55 PM
    Moderator
  • Hi Ray,

     

    What have you done to make it work? We have the same issue.

     

    Thanx alot

    Thursday, February 10, 2011 9:51 AM
  • Hi,

    The above link doesn't give me help because I'm running Windows Server 2008 R2 as hosts, and SharePoint 2010 with SQL 2008 R2. Regarding to the article there is no prerequisites needed for these software versions. However, I've got a solution which works in my case.

    If I checked the DPM error log on the WFE server and I saw warnings about missing registry keys. I have created a string value named "Version" under "HLKM\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\14.0" key with value "14.0.0.4762" and then I was able to start protection.

    Hope that helps! :)

    Marton


    mcsiki
    Thursday, March 3, 2011 11:33 AM