locked
"user declined update at shutdown" message in windowsupdate.log file -- can anyone explain it? RRS feed

  • Question

  • I’ve been troubleshooting a problem with a Server 2012 machine refusing to install updates for a week.  I tried EVERYTHING at https://docs.microsoft.com/en-us/windows/deployment/update/windows-update-resources without success.  Then I finally found the culprit – I always get this message in the shutdown sequence in the windowsupdate.log when I press restart after installing updates:

    2020-01-25 10:37:04:331  772 690 Shutdwn Checking to see whether install at shutdown is appropriate
    2020-01-25 10:37:04:331  772 690 Shutdwn user declined update at shutdown

    2020-01-25 10:37:04:331  772 690 AU AU initiates service shutdown
    2020-01-25 10:37:04:331  772 690 AU ###########  AU: Uninitializing Automatic Updates  ###########
    2020-01-25 10:37:04:331  772 690 WuTask Uninit WU Task Manager
    2020-01-25 10:37:04:643  772 690 Report CWERReporter finishing event handling. (00000000)
    2020-01-25 10:37:05:018  772 690 Service *********
    2020-01-25 10:37:05:018  772 690 Service **  END  **  Service: Service exit [Exit code = 0x240001]
    2020-01-25 10:37:05:018  772 690 Service *************

    My problem now:  I can’t find any documentation about “user declined update at shutdown.”  Does ANYBODY know anything about how this condition is set and unset?


    Sunday, January 26, 2020 7:59 PM

All replies

  • Thank you for those articles, but they seem to deal with Windows 10 machines and automated restarts.  Restarting isn't a problem (this is a MANUAL update) … getting updates to COMPLETE after restarting is.  The machine is under the same group policy as all the other machines in the domain, and none of them have a problem installing updates after a manual restart.  Is there any screen snapshot of gpedit or regedit I can provide that might shed a clue as to what's causing this undocumented Microsoft message?
    Monday, January 27, 2020 4:45 PM
  • Hi,
       

    I tried to reproduce the problem you were experiencing, but it was unsuccessful. It seems that after the client prompts that a restart is required to complete the installation of the update, I disable the Windows Update service and shut down using the shutdown command, and the update will also be installed after the restart.

    So you may want to consider other aspects, such as whether there are any third-party system maintenance applications installed on this client?
       

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 29, 2020 5:44 AM
  • I've also been pursuing an answer at Spiceworks, and the problem seems to have something to do with the rebootrequired key in the registry.  There are snapshots of the key for a Windows 10 machine that's about to restart after installing updates and the same key for the problem machine that's producing the undocumented message and not installing anything.  If you could possibly take a similar snapshot of a Server 2012 machine about to restart, I would really appreciate it.
    Wednesday, January 29, 2020 5:35 PM
  • Hi,
      

    Thank you for your information.
    I tried to install KB4534297 on a Windows Server 2012 R2 server. After being prompted to restart, I deleted the registry key mentioned in the thread. I did see the "user declined update at shutdown" you mentioned during the subsequent restart:
       

        

    But after the server restarts again, the update will still enter the installation process of the update, which seems different from what you mentioned.
      

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 30, 2020 1:35 AM
  • Thank you very much for your time and effort.  That is curious that it did both phases on the startup.  I've got to wait until the weekend before I can be free to work on the machine and reboot it at will.   Knowing that I can safely delete the one key before rebooting helps.  I now plan to run another pass of the reset script, delete the key, restart, and then check for updates online.

    Thursday, January 30, 2020 5:10 PM
  • I will continue to research.
    And look forward to your follow-up research results.
       

    Regards,
    Yic

    Please remember to mark as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 3, 2020 2:09 AM
  • It looks like I'm just going to have to succumb to Microsoft paid support.  Three weeks of trying EVERYTHING in the book -- reset scripts, troubleshooting tools, and countless reboots -- and I STILL can't install anything that requires a reboot.  It definitely is WSUS related -- there are all kinds of WSUS references in the windowsupdate.log file.  I'm quite certain that nobody without Microsoft's proprietary information and tools can fix this.

    All of these errors and warnings appear in the startup section of a windowsupdate.log restart:

    • WARNING: Network Cost is assumed to be not supported as something failed with trying to get handles to wcmapi.dll
    • WARNING: CSerializationHelper:: InitSerialize failed : 0x80070002WARNING: Failed to get Wu Exemption info from NLM, assuming not exempt, error = 0x80240037
    • FATAL: CNetworkCostChangeHandler::RegisterForCostChangeNotifications: CoCreateInstance failed with error 80004002
    • WARNING: RegisterNetworkCostChangeNotification: Error 80004002

    Who's got the time and expertise to wade through all of this?  At least Microsoft's paid WSUS help was effective and stayed on top of the case when I needed them for another complex WSUS issue three years ago.  I'll post if they're able to come through again.


    • Edited by ArtSnob Tuesday, February 4, 2020 11:30 PM addition
    Tuesday, February 4, 2020 11:17 PM