none
Network not responding RRS feed

  • Question

  • Hi,

    We have two windows 2012 R2 hyper-v HP DL 380 G8 Servers. Many times the network inside virtual machines stops responding and then we have to disable the network card in the physical server and enable it again and then it starts working. It happens in both the servers.

    Any Suggestions? Both the hyper-v servers are clustered.

    Thanks.

    Wednesday, September 20, 2017 10:27 AM

All replies

  • Is power management enabled on the NICs?  If so, disable it and allow the NICs to remain fully powered.

    Also ensure you have the latest firmware and drivers recommended by the vendor.  All NICs should be running the same firmware and drivers.  Running the cluster validation wizard will assist in finding version discrepancies. 


    tim


    Wednesday, September 20, 2017 12:04 PM
  • Hi,


    If it is a broadcam adapter then there is a known issue with that and that is resolved with the latest driver. Look here for more details

    Check the VMQ of the network adapters on the host that are used to make the switch. For instance disable VMQ and observe for sometimes.

    example, 

    Disable-NetAdapterVmq –Name "Name of the Guest Traffic Adapter"

    For more details on VMQ please go through the below article, there are 3 parts...

    https://blogs.technet.microsoft.com/networking/2013/09/10/vmq-deep-dive-1-of-3/

    subsequent parts' links are available on that page

    Regards,

    Bala


    Wednesday, September 20, 2017 12:37 PM
  • Hi create_share,

    Could the above replies be of help, if yes, you may mark useful reply as answer.

    In additional, you may also check if the VMs enables "SR-IOV", and if the NIC enables "RDMA" or other advanced features, if yes, you may disable them to check if it could help.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, September 25, 2017 3:05 AM
    Moderator
  • I disabled the power option. Now monitoring. It does not happen everyday.

    Thanks.

    Monday, September 25, 2017 7:09 AM
  • Hi create_share,

    Yeah, if you need additional assistance, welcome to feedback. If after a period of time monitoring, it is stable, you may mark useful information as answer.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 26, 2017 2:26 AM
    Moderator