none
Error ID 30156 in DPM 2010 RRS feed

  • General discussion

  • In DPM 2010 i am getting the error message of "the replica of XX on XXX is inconsistent with the protected data source. All Protection activities for the dat source will fail until the replica is synchronised with a consistency check (ID:3106 DPM is unable to continue protection for XX on XXX because the change tracking information is corrupt (ID: 30156)

    i am getting this on the C,D and E drives. all other backups on this server( BMR, Sys state) are fine

    i have tried multiple times to do a consistency check which shows as ok for 15 mins then the error message reappears. i have removed the items from dpm individually, deleted the replica on disk and reattached. i have even pulled the entire server off DPM, deleted all replicas and rejoined it and still it comes up with the same mesage. i have a dozen other servers that are working fine and half a dozen Virtual servers that are not having any problems either. its not an exchange server and

    it had worked previously without a problem but it has been failing like this for the last week. i have rebooted the DPM server and the protected server and that didn't do anything helpful either

     

     

    Friday, August 12, 2011 4:26 PM

All replies

  • Hi,

    It sounds like the USN journal files are getting corrupted somehow, lets try deleting them and see if new ones work any better.

    1. Delete the USN journal on the PS from an administrative comand prompt run:

             Fsutil  usn deletejournal /D C:   <Replace C: with specific volume one at a time>

    2. Check if USN journal deletion is complete run:

             FsUtil usn queryjournal C:         <Replace C: with specific volume one at a time>


    After a couple of seconds it will say “The volume change journal is not active”. When you see this, you can proceed to step 3.

    3. Now open the DPM UI and run consistency check on the volume. This will create new USN journal.

     


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, August 12, 2011 8:14 PM
    Moderator
  • Thanks for the reply,

     

    have tried this on all three drives but after performing consistency check, they all fail with the same error message as before

     

    Chris

    Monday, August 15, 2011 9:45 AM
  • Did this ever work on this server ?   If so, did you install / update anything recently ?

    I would need to look the the dpmra error logs to diagnose the issue. As a temporary solution see if adding this allows for backups to be taken.  It will take much longer to take the backup, so 15 minute synch will probably not work.

    A) On the protected server, browse to the registry path HKLM\Software\Microsoft\Microsoft Data Protection Manager\Agents\2.0.
    B) Create a DWORD registry value called "ForceFixup" and set it to 0x1.
    C) Restart the DPMRA service on the protected server.
    D) On the DPM server, re-run the consistency check.


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, August 15, 2011 2:16 PM
    Moderator
  • the service worked fine previously on this server and some elements are still working fine. i have changed the synch to allow for the extra time required but when i followed you registry path,, there is is no folder for Microsoft Data Protection manager with the microsoft folder
    Monday, August 15, 2011 2:44 PM
  • Please un-install the DPM agent on the protected server and then re-install it using the manual method: http://technet.microsoft.com/en-us/library/ff399459.aspx
    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, August 15, 2011 6:10 PM
    Moderator
  • Fix worked perfectly and now getting confirmed back-ups on all 3 drives. Many thanks for the help Mike

     

    Chris


    Thursday, August 18, 2011 7:57 AM