Privacy Statement or Browser Has Been Upgraded page loads after June KB2957689 Cumulative Patch RRS feed

  • Question

  • Hi all,

    I am often placed in charge of WSUS for our desktop estate which is primarily Windows 7 SP1 x86 with IE9 as the default browser. During testing today, I found after applying KB2957689 "Cumulative Security Update for Internet Explorer 9" when a user loads IE, an extra tab loads automatically which goes to the "MS IE9 Privacy Statement" page located at This only happens once per user after the patch is installed, so I'd imagine the patch adds, or enables a registry key for the first launch.

    I can find no mention of this behaviour on the KB article, and no searches in the usual places has lead to any other reports of this happening. Ideally we want to avoid any unnecessary demand to the helpdesk by the displaying of the page.

    Can anyone else confirm any similar mentions of this happening, or will I need to log a ticket with Microsoft for this?

    Kind Regards, Steve Sands.

    Wednesday, June 11, 2014 6:47 PM


  • To solve this Problem we set the following Regkey via GPO:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

    The other GPO meantioned above (prevent First Run Wizard) has no effect on this issue.

    • Proposed as answer by Davey400 Friday, June 13, 2014 9:57 AM
    • Marked as answer by theuksandman Friday, June 20, 2014 1:41 PM
    Friday, June 13, 2014 8:52 AM

All replies

  • I can confirm this behaviour. So far I've seen it on a Windows 7 x64 machine with Internet Explorer 10, and a Windows 8 x64 machine, also with IE 10.

    To be clear, it is the "Windows Internet Explorer 9 privacy statement" that is being displayed on these computers, despite the fact that they are both running IE 10.

    Wednesday, June 11, 2014 7:21 PM
  • I'm seeing the same.  Applying the update to IE 10 where it opens a tab with the IE 9 privacy statement.   Installing on Windows 7 x64.
    • Proposed as answer by Jim101a Thursday, June 12, 2014 5:47 PM
    Wednesday, June 11, 2014 7:51 PM
  • I'm seeing this too.  On our PCs with mandatory profiles, this shows on every logon.  There's a registry Dword value called PrivacyPolicyShown in the registry key HKCU/Software/Microsoft/Internet Explorer/ which seems to control this.  I've created a group policy preference to set this value to 1, and the privacy statement is no longer appearing
    Wednesday, June 11, 2014 8:20 PM
  • I tried setting the registry entry Dword value called PrivacyPolicyShown in key HKCU/Software/Microsoft/Internet Explorer/ and it didn't work.  Are you sure this is the correct location for the key?

    I'm also seeing this with IE 10 Windows 7 x64.

    Wednesday, June 11, 2014 11:59 PM
  • I searched the registry on a computer where the message had been displayed and found the registry key at HKCU\Software\Microsoft\Internet Explorer\Main.
    • Proposed as answer by Inquisitor1 Thursday, June 12, 2014 12:07 AM
    Thursday, June 12, 2014 12:00 AM
  • I realized this just after I asked the question.  Thanks.
    Thursday, June 12, 2014 12:07 AM
  • It seems to work, but I can not reproduce the message when the value is removed again.

    Anyone seen any other changes?

    Thursday, June 12, 2014 7:06 AM
  • Thanks for the replies everyone, I'm glad it isn't just our estate with this issue.

    Weirdly, on the same machine I was testing with yesterday, I deleted the Windows profiles of our test users (they aren't roaming or mandatory) and when logging in fresh, rather than going to the IE9 Privacy Statement, it now takes me to the "Your browser has been upgraded" page at

    Which is odd as in our GPO we have set "Prevent performance of First Run Customize Settings" to Enabled, and the choice is set 'go directly to home page' - this user GPO is applied to all domain users.

    I will test on the other boxes today to see if this is the same.

    There is also coverage of the problem at - the last post on there was that one of the lead contributors was going to raise the issue with MS support. 


    • Edited by theuksandman Thursday, June 12, 2014 9:26 AM Added GPO note
    Thursday, June 12, 2014 8:03 AM
  • I saw the same thing on my systems.  I am also seeing IE10 upgrade notices on machines with IE10 that weren't updated.  I really hope this is fixed soon.  I specifically asked about this problem in the MSRC webcast and was told that it was not caused by a security patch.
    Thursday, June 12, 2014 12:31 PM
  • Just want to add to the thread since at my company we are also experiencing the same, IE8 and IE10 resolve this issue by using GPO, I do hope they fix it.

    • Proposed as answer by goofyer Monday, August 8, 2016 11:14 AM
    Thursday, June 12, 2014 3:52 PM
  • Hi goofyer,

    Just to clarify - are you saying that you resolved the issue for IE8 and IE10 using that GPO? Or that the issue only happened for you on IE9? I ask because we already have that GPO set to 'enabled' and 'go directly to homepage' and the issue still occured.


    • Proposed as answer by McPaul Friday, June 13, 2014 8:49 AM
    • Unproposed as answer by McPaul Friday, June 13, 2014 8:49 AM
    Friday, June 13, 2014 7:33 AM
  • To solve this Problem we set the following Regkey via GPO:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

    The other GPO meantioned above (prevent First Run Wizard) has no effect on this issue.

    • Proposed as answer by Davey400 Friday, June 13, 2014 9:57 AM
    • Marked as answer by theuksandman Friday, June 20, 2014 1:41 PM
    Friday, June 13, 2014 8:52 AM
  • We´ve got the same issue with ie9. after installing kb2957689 there will be a several tab open once every user authorization... 

    We´re also having the GPO configured like in goofyer´s example... There is a Policy for preventing the performance of first run costimize settings and also "go directly to the home page"...

    Bit it still happens that there are users complaining about the "problem" getting a second tab open with the information of an ie9 update...

    can someone explain it a bit more detailed?

    I also searched at HKCU\Software\Microsoft\Internet Explorer\Main (see Ryan G. Steele´s post) but i also found nothing important there...



    Friday, June 13, 2014 9:10 AM
  • I will Agree with McPaul, but it is a combination of both since in my company we use IE8 and IE10 we  enable the "Prevent First Run Wizard" so it affects all browsers and it will stop the "IE9 Privacy Tab" on IE8 specially, but in my case for IE10 it opened another Tab "ie-10-welcome-upgrade1" page, which the regKey "PrivacyPolicyShown"=dword:00000001 fixes and its only applicable to IE9 and above but not IE8, which I recommend to add a item-Level targeting so you don't end up pushing it to machines  that don't need it.

    we also updated our GPO Central Store IE admx to support IE10 a while back and the Policy I mention above name change to the below. Sorry for any confusion

    thank you McPaul for pointing that out.


    • Edited by goofyer Monday, June 16, 2014 2:47 PM edit
    Friday, June 13, 2014 3:05 PM
  • To solve this Problem we set the following Regkey via GPO:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

    The other GPO meantioned above (prevent First Run Wizard) has no effect on this issue.

    I tested just setting this key manually in HKLM and it seemed to work across each user profile as well.  I'm trying to integrate the patch with a deployment of IE10 so this simplifies things for me. 
    Friday, June 13, 2014 7:35 PM
  • I've just been checking on the thread and an MS team member has issued a response on this:

    "This behavior is by design and was introduced by enabling search suggestions.
    But based on feedback here, the IE team made a backend change Wed night to prevent the Privacy Policy from appearing on a new tab. Users should now see a “Your browser has been upgraded” page which has a link to the updated Privacy Policy instead of loading it in a new tab.
    They’re eager to hear back to confirm this has resolved the issue for your customers.
    Thanks for taking the time to provide this valuable feedback.

    doug neal
    Microsoft Update (MU)"

    Still doesn't help too much as there's still an unnecessary tab that displays in an enterprise environment which admins are struggling to hide!

    Saturday, June 14, 2014 5:01 PM
  • They should have made it goto a page that closes itself.
    Tuesday, June 17, 2014 6:21 AM
  • Also have this issue, and we have had no effect from setting the policy setting above. We are now pushing out the key via GPP, hope that works.
    Tuesday, June 17, 2014 1:09 PM
  • Cite:

    KB2964846 is one of the 25 GDR fixes included in MS14-035; cf.


    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Tuesday, June 17, 2014 5:23 PM
  • Based on everyone's feedback here it is clear WSUS admins have two options to present to their management:

    1) Raise a change request to roll out the following entry via Group Policy before the patch goes to everyone:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

    (or the same entry but in HKLM)

    2) Advise the user base of the new tab beforehand (perhaps a global mail or intranet note) and advise your Service Desk accordingly of potential extra calls.

    At least for me these are the options I've presented - we have a small window where live test machines are the only ones who have the patch so far, but it will need to go live asap.

    Wednesday, June 18, 2014 2:54 PM
  • I added a blog post that include the steps on adding the Group Policy Registry Preference

    "Your Browser has been upgraded" Tab being displayed after installing MS14-035

    Thursday, June 26, 2014 9:11 PM
  • I tested this. it will prevent the  "Welcome to IE" page


    PolicyPrevent running First Run wizard

    Category PathComputer Configuration\Administrative Templates\Windows Components\Internet Explorer\

    Supported OnAt least Internet Explorer 7.0

    Registry KeyHKLM\Software\Policies\Microsoft\Internet Explorer\Main



    This policy setting prevents Internet Explorer from running the First Run wizard the first time a user starts the browser after installing Internet Explorer or Windows.

    If you enable this policy setting, you must make one of the following choices:
    - Skip the First Run wizard, and Go directly to the user´s home page.
    - Skip the First Run wizard, and Go directly to the "Welcome to Internet Explorer" webpage.

    Starting with Windows 8, the "Welcome to Internet Explorer" webpage is not available. The user´shome page will display regardless of which option is chosen.

    If you disable or do not configure this policy setting, Internet Explorer may run the First Run wizard the first time the browser is started after installation. 

    === Detailed values: === 
    Id: FirstRunOptions
    ValueName: DisableFirstRunCustomize

    item: decimal: 1 => Go directly to home page 

    item: decimal: 2 => Go directly to "Welcome to IE" page 


    Best regards

    Michael Rosenstock

    Friday, July 11, 2014 3:33 PM
  • How does this pertain to the topic at hand, Michael?

    Have you read ?



    KB2964846 is one of the 25 GDR fixes included in MS14-035; cf.

    Several more "GDR fixes" were included in MS14-037, too; cf.

    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Friday, July 11, 2014 5:34 PM
  • I'm not sure that the question being asked addresses the same issue that I am having or not but considering all that I have read I think the solution, at least for me, is to download IEAK and create a custom installation. But let me explain; my situation is a bit unique because I am dealing with public access computers which are locked down and in production. I recently had to re-image one of these computers and it turns out that the image that I used was old so it was still on IE8. Our standard is IE10 so after installing several updates I downloaded and installed it. While logged in as an administrator I launched IE and got the first run defaults; no problem, I simply did what I would normally do on a first run. Unfortunately, since it is locked down I can't do that with  the public user account, and to make matters worse its a guest account so it is deleted at every logout and re-created at every login. Finally we are using a proxy server; every time someone tries to browse to an Internet site that is not allowed the server directs the session to the same special page.  In the registry, "PrivacyPolicyShown" is already set to 1 and Group Policy is configured as recommended here.

    I thought that if I could figure out which object in the registry indicates that the first run of IE has already happened that would solve the problem. Unfortunately, I have to be able to tell that specific user that IE has already been run once and, hard as I try, I can't seem to find anything in the registry or Group Policy that will do that. Last night as I was going home it occurred to me that if I can tell the IE10 installation to act as if the first run has already happened that might solve my problem. I'm going to give it a try and I'll let you know if I'm successful.


    Wednesday, September 10, 2014 2:25 PM