KB4480970 causes on the Windows 2008 R2 Server impossibility to connect to by Clients RRS feed

  • Question



    today after installation of  KB4480970 (automatically by Windows Update as Important) to our Windows 2008 R2 Standard Server the server stopped serve Clients by shared storage (haven't tried anything else).  The Client has issued an error Invalid handle and couldn't connect (tried on Windows 7 Pro SP1 clients with installed KB4480970 only). After uninstallation it started work again, so the problem is positively in the KB4480970. Pls stop distribute the KB4480970 to the Windows 2008 R2 Server and correct the behavior. Thank You in advance.

    • Edited by Wednesday, January 9, 2019 1:13 PM
    Wednesday, January 9, 2019 12:45 PM

All replies

  • Hi I have also experienced this issue on a Windows 7 machine which we use for file sharing.

    When I uninstalled the update this resolved the issue

    Wednesday, January 9, 2019 4:05 PM
  • We have seen this issue as well with some (possibly) interesting details as it pertains to this update (KB4480970) and RDS on Server 2008R2:

    • This seems to impact only users in the ADMINISTRATORS group on the local machine - non admin users login fine
    • This seems to impact only users using the RD Gateway - if the same user logs in via simple RDP they are allowed 
    • This does not restrict the actual "Administrator" account from logging in via the gateway or simple RDP 3389 at all - only other named users who are in the administrators group

    With KB4480970 still installed, removing the users who were being rejected from the administrators group immediately allowed them to logon. I'd be interested to see if this is true in others environments.

    The Event ID generated in the in the security logs is:

    Event ID 4625

    Failure Information:

    Failure Reason: An Error occured during Logon.

    Status: 0xc0000008

    Wednesday, January 9, 2019 4:20 PM
  • This is also an issue on 2008 Std with KB4480968 causing RDS connection problems. I've removed both KB4480970 and KB4480968 from several systems that displayed this problem this morning and that has cleared the issues on both 2008 Std and 2008 R2 systems.

    Microsoft really needs to stop breaking things that have worked for years with their new updates. It's extremely aggravating.

    Wednesday, January 9, 2019 4:36 PM
  • Follow-up: We have not tried this in the impacted machine, but... I am unable to post the URL at this time, but has a posting /win/2019/01/09/netzwerk-issues-with-updates-kb4480970-and-kb4480960/

    that refers to a workaround from             /contentid/397581#comment-1336425

    reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f

    • Proposed as answer by IDOCH Thursday, January 10, 2019 3:58 AM
    Wednesday, January 9, 2019 4:57 PM
  • reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f

    i've just tried to adding this key to the registry and it's working well, thanks

    OS: Windows 2008 Server Standard SP2 (non-R2)

    • Edited by bovito Thursday, January 10, 2019 2:03 AM
    Thursday, January 10, 2019 2:02 AM
  • **PLEASE read the sites mentioned in the post above  (just remove the spaces from the urls)

    They are the actual source for the "fix" but they also provide more information about the security implications of the registry change.

    Thursday, January 10, 2019 3:56 AM
  • Hello,
    This a known issue for both KB4480970 and KB4480960.

    Just use the recommended workaround and I believe it would be fixed soon.
    Hope my answer could help you and look forward to your feedback.
    Best Regards,

    Please remembers to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Thursday, January 10, 2019 6:39 AM
  • This  HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\system /v LocalAccountTokenFilterPolicy  filter policy worked for me.  In my case, the symptom was inability to connect with NTLM authentication in peer-to-peer network (no domain controllers) after installing KBB4480970. 
    Thursday, January 10, 2019 1:07 PM
  • Hi,

    the fix of this issue is out now: (did not try yet)

    Monday, January 14, 2019 2:02 PM
  • Hi, thanks!
    Thursday, January 17, 2019 11:51 AM