none
Media Deployment Issues RRS feed

  • Question

  • Hello,

    I am having an issue with my Applications not copying to the USBDeploymentShare when updating the Media Content.

    I have made sure I have selected everything I want in the selection profile but they don't seem to come across?


    Alex Olver

    Wednesday, May 18, 2016 5:23 AM

Answers

  • You can but, it involves manually editing an XML file in %deployroot%\Control 

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    • Marked as answer by brimanyo Wednesday, May 18, 2016 10:51 PM
    Wednesday, May 18, 2016 10:46 PM
    Moderator
  • So you mean no sub folders would be the best way to have it?

    Alex Olver

    • Marked as answer by brimanyo Thursday, May 19, 2016 12:28 AM
    Wednesday, May 18, 2016 11:07 PM

All replies

  • Hi Alex,

    This can happen if you have applications you've created that were not imported during creation IE: application with alternative path.  I would try importing the application instead when creating the application.

    Ryan

    Wednesday, May 18, 2016 5:44 AM
  • Can you explain what you mean by importing? Sorry.

    Alex Olver

    Wednesday, May 18, 2016 6:00 AM
  • When you create a new application it presents a window where you can choose Application with source files or Application with source files elsewhere on the network - application with source files elsewhere on the network will not copy to the USB media.
    Wednesday, May 18, 2016 6:04 AM
  • I see, yea that's the way I imported the applications in the first place.

    However please see attached image because I have made sub directories.


    Alex Olver


    • Edited by brimanyo Wednesday, May 18, 2016 6:28 AM
    Wednesday, May 18, 2016 6:09 AM
  • Don't use sub directories. MDT only knows what the application was imported to. What you change it to later (as seen in your screenshot) doesn't make it so MDT knows about it to sync.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Wednesday, May 18, 2016 6:45 AM
    Moderator
  • Really ok...? So this is best practice?

    Well if I copy them manually it should work I guess?


    Alex Olver

    Wednesday, May 18, 2016 11:00 AM
  • To reiterate what Ty is saying:  in your screen shots, under General you have the Source Directory has \Applications\USB Custom Start Layout.  Under Details, you have the Working Directory as \Applications\USB\USB Custom Start Layout.  These are 2 different directory structures.  The Working Directory does not fall under the  Source Directory.  The Source Directory I believe is what will get copied to the Media.  The Working Directory is where MDT expects to find the installation files
    Wednesday, May 18, 2016 2:02 PM
  • Yes I realize this is the issue, can I change this so the source is the same as the working?

    Alex Olver

    Wednesday, May 18, 2016 10:29 PM
  • You can but, it involves manually editing an XML file in %deployroot%\Control 

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    • Marked as answer by brimanyo Wednesday, May 18, 2016 10:51 PM
    Wednesday, May 18, 2016 10:46 PM
    Moderator
  • Yea no worries I will give that a try then, this will solve my issue of sub directories then?

    Alex Olver

    Wednesday, May 18, 2016 10:51 PM
  • That should be able to work around it for now.  I don't think it is very maintainable long term though.

    Many questions such as where do I find logs and what logs are interesting are found in: MDT TechNet Forum - FAQ & Getting Started Guide Please take the time to read it. Also if you don't post logs your problem won't be easily solved.

    Wednesday, May 18, 2016 11:03 PM
    Moderator
  • So you mean no sub folders would be the best way to have it?

    Alex Olver

    • Marked as answer by brimanyo Thursday, May 19, 2016 12:28 AM
    Wednesday, May 18, 2016 11:07 PM
  • I have taken away all the sub folders now and just adjusted the way I name the applications.

    Alex Olver

    Thursday, May 19, 2016 12:03 AM