locked
Firefox & OOTB 2010 Silverlight Webpart RRS feed

  • Question

  • I am having serious issues with the out of the box silverlight webpart.  In IE my XAP file works perfectly, however in firefox although it renders perfectly i cannot interact with it properly in firefox.  The top left corner of my zap file does not match where the mouse thinks it is.  So if i want to click on a dropdown..i have to place my mouse about 300px down and 200px right of the actual box.  So it appears that they are not lineing up correcly.  I have check thed webpart in firefox as a test page and appears fine so i think its something to do with the silverlight webpart.



    Chris
    Chris
    • Edited by Mike Walsh FIN Saturday, November 28, 2009 8:00 PM Urgent Issue removed from Title . Completely wrong in a forum postely
    Saturday, November 28, 2009 5:24 PM

Answers

  • Ok...an update..

    I have solved this issue...It appears that microsoft in their wisdom decided to have inline styles on div elements (especially ones with classes already assigned to them). 

    to resolve this problem i had to override the style of the WP-Body in the silverlight control host.

    #silverlightControlHost .ms-WPBody{
    	overflow: visible !important;
    }
    

    I hope this helps other people.

    chris

    Chris
    Saturday, November 28, 2009 6:35 PM

All replies

  • Does anyone have an idea?  i have check to see if it was my masterpage so i changed back to the default one but this also does not appear to be working..:(

    Chris
    Chris
    Saturday, November 28, 2009 6:13 PM
  • Ok...an update..

    I have solved this issue...It appears that microsoft in their wisdom decided to have inline styles on div elements (especially ones with classes already assigned to them). 

    to resolve this problem i had to override the style of the WP-Body in the silverlight control host.

    #silverlightControlHost .ms-WPBody{
    	overflow: visible !important;
    }
    

    I hope this helps other people.

    chris

    Chris
    Saturday, November 28, 2009 6:35 PM
  • If you in future post anything that says Urgent Issue in the Title, I will delete the thread whether or not it has replies.

    Forums are not for Urgent issues and this is a forum for a Beta product which makes it even more unnecessary to say anything anywhere in your post that your question is urgent.

    Asap and critical will get posts deleted too. For non-Betas you can ring MS Customer Support Services if you are in a hurry. For Betas just post normally with no attempt in your post to pressure forum members.


    (Moderator)

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Saturday, November 28, 2009 8:04 PM
  • No problem...thank you for the info.

    Chris
    Chris
    Saturday, November 28, 2009 10:43 PM