none
User get access denied to Project Server every day in EPM 2010 RRS feed

  • Question

  • Hi all,

    We have an issue with some users losing access to the Project Server every night. They cannot access the PWA and cannot open project with MPP. We have created a user group that is synced to an AD group. The group has all the correct permissions according to the project manager template. Last week, users suddenly could not access the PWA anymore. Now, when we add them to the default Project Managers group, the access is restored temporarily. Every morning they have lost access again and we have to remove them from the Project Managers group and add them again to give them access.

    We have already tried disabling AD synchronisation for resources and for security groups. We are using EPM 2010. The users are active. We even tried setting the permission levels for the user account directly instead of using a group.

    I found this thread with a similar issue, but the solution does not work longer than a day for us: http://social.technet.microsoft.com/Forums/en-NZ/projserv2010setup/thread/6de483d2-a562-40b4-abf7-ca968a042da6

    Anybody that can help us?

    Thanks,
    Quint Mouthaan

    Monday, May 2, 2011 8:01 AM

Answers

All replies

  • There are 2 places where AD sync is enabled, one is for Enterprise Resource Pool(ERP) and other is you security groups, make sure you schedule ERP sync well ahead before the Project server group sync is done, so if you haven't yet disabled the ERP sync then perhaps this might be the reason of security access being revoked,

    Enable both the Sync, first schedule the ERP sync, then after 30 min or so to be safe (Again time you could verify from queue) schedule the ERP sync

    Let us know if this helps


    Thanks | Sunil Kr Singh | http://epmxperts.wordpress.com
    Monday, May 2, 2011 8:01 PM
    Moderator
  • We have disabled AD sync on both places and still we have the issue.

    We have traced back the issue to a custom integration with SAP HR data. The custom component updates resource availabilities based on data from SAP HR. This is the only thing it does. It does not update any permissions of the users, it just delete and creates availabilities with either 0 or 100 % availability.

    After running this component, users do not have access to PWA anymore. Is there a relationship between user availability and their access to PWA?

    Tuesday, May 3, 2011 8:55 PM
  • Hi Quint,

    There shouldn't be.

    How exactly is your SAP HR interface setting the availability in Project Server, through availability dates, max units or the resource calendar?

    Does the code perform an update, ordoes it delete the whole record and writing a new one back with the updated values. This would be the only way I could think of that PS could get confused and not sync access.


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Wednesday, May 4, 2011 12:01 PM
    Moderator
  • The interface is updating the availability through the PSI by deleting rows from the dataset ResourceDataSet.ResourceAvailabilitiesRow and inserting new rows.

    Another update, I said before that we had to remove the user from its security group and readd him to restore access, but it turns out that just opening the user and saving it without changing anything is enough to give him access again.

    Wednesday, May 4, 2011 1:13 PM
  • Quint:

    It sounds like your add-on is mishandling the Resource update in some way. I suggest that you post your code on the developer forum for Project Server or open a support case with Microsoft.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG
    Wednesday, May 18, 2011 2:54 PM
    Moderator