Installation of windows server 2008 hangs during the last step "Complete Installation" RRS feed

  • Question


    I download the Windows Server 2008 Enterprise image from MS dowload center and then burn it to a DVD. Then I start the installation on my desktop PC with this disk. After an automatic reboot the progress bar finally meets about 75% and it says "Complete Installation"(last step of the total progress). In a short while the installation hangs and my PC loses its response  completely. The cursor in the screen don't move. I press the every key on the keyboard but it dose not give any sign of response. The harddisk also seems to be hang forever. I even tried to left it for about half an hour but no change was found. So, what 's the real problem?


    And more, I tried the installation with the same disk on a virtual machine and everything goes fine. So the disk should be OK. By the way I can install Windows Vista on my same machine and the same patition correctly.


    Accoding to other guys' suggestion, this problem seems to be some kind of Windows's incompatibility with hardward. But how can I find that wrong hardware? I read in another thread that someone tried to disable all the not necessary device built on the motherboard in the BIOS. Maybe I should try to do the same thing.


    Any suggestions??


    Configuration of my desktop PC:


    CPU   AMD Athlon X2 4000+

    Board    MSI  Neo-V2 (nforce 520)

    Memory   4GB DDR2 800MHz

    Video    ATI HD2600 pro

    Harddisk  ST 160G SATA

    Net   Realtek RTL8168 Gigabyte (built in)

    Friday, March 14, 2008 5:52 AM

All replies

  • I've got the same problem, except I'm installing Standard x64 from our volume license CD to a brand new HP DL380 G5.

    Any information you can share is appreciated.
    Friday, June 20, 2008 4:04 AM
  • More information on my situation:

    I've verified that the hardware is certified for Server 2008.
    HP had an updated driver for the array controller, but injecting this at installation made no difference.
    I've verified that this is a true hang, as I left it at this point for more than 48 hours with no progress.  Can't CTRL-ALT-DEL, have to physically power off machine to recover.

    At this point, I'm at a loss.

    The media is genuine Microsoft and shows no signs of being faulty and the hardware is brand-new HP, on the certified list.

    Any suggestions?

    Sunday, June 22, 2008 9:19 PM
  • More information:

    I successfully installed 2008 Server 32bit to the problem server, so I'm fairly sure this problem is x64 driver / firmware related.  The unfortunate part is that this hardware is supposed to be supported and I've definitely got all of the latest firmware.

    I looked at the setupact.log and setuperr.log files, but setupact.log file only shows success messages and the setuperr.log file is empty.
    Monday, June 23, 2008 3:38 AM
  • I've found the problem, but not the root cause.

    As it turns out, the Server 2008 Standard x64 will not install on this hardware with more than 4GB of RAM installed.  If I leave only 2GB of RAM installed during Windows installation, the installation succeeds.  Once installation is complete, I can install as much RAM as I want and the server runs with no issues.  If, however, I attempt to install the OS with more than 4GB of RAM, the installation hangs as described above.  This behavior is consistent and repeatable.  Memory diagnostic utilities show no errors.

    Anyone have ideas as to why this occurs?
    Monday, June 23, 2008 10:02 PM
  • I get the same installation error when I am using Windows 2008 / 64 bit on Asus P6T6 Pro WS using SAS disk. I am using only 3Gigs of ram but the system still hangs when Completing installlation..
    Monday, January 5, 2009 8:55 PM
  • I have the same problem but with my Server 2008 Standard x86. Installation freeze at "Completing installation" .

    - MSI K9N Neo-F
    -2 GB RAM
    -WD (SATA)
    -CD/DVD (SATA)
    -Realtek network and sound card

    I have tried with Vista OEM drivers but no luck ....
    Saturday, May 16, 2009 10:16 AM
  • we have a dl580 g5 hp proliant server with 80 GB of ram.
    during installation of windows server 2008 R2 RTM
    at the last step "completing installation" the server was hanging,
    after decreasing ram to 64GB the problem was solved
    after installation we added extra memories and everything worked correctly

    I hope this will help you

    • Proposed as answer by Siavash Irani Tuesday, September 15, 2009 7:14 AM
    Saturday, September 5, 2009 10:50 PM
  • I have a Dell PowerEdge server with 8GB of RAM installed. Installing Server 2008 R2 RTM x64.
    I am now waiting at the last step : "completing installation". It has now been like this for an hour or so.
    Maybe there is a disk controller driver issue, because it shouldn't take this long.
    The dots behind "completing installation" are moving, cursor is moving. There is disk activity.
    I guess I just have to wait some more and see what happens.

    Im just too impatient. After about 2,5 hours installation was done. Still it shouldn't take this much time.
    Saturday, October 17, 2009 9:26 PM
  • I'm not sure if any of you are still having this issue.  I came across it last week intially.  I have 4x DL580 G5 servers.  The first install started with the issue of locking at the "Completing Installation...".  I thought it might be some issue over the network, using the .iso file.  So, I tried USB with same issue.  Trying the network again, different network card, same thing.  Then, I went to my 2nd DL580.  That install went perfectly!!!  Both are DL580's, same hardware setup, secondary disk enclosure, 16x 72gb drives, HP SC44Ge Host Bus Adapter, SAS Expander Card, HP nc382T.  These machines were purchased the same week and serial numbers are practically next to each other.  Have not double-checked the BIOS version yet but am planning to.  I hope that is the issue.  Will be starting the other 2 dl580 installs soon also.  If any of you have any input, please let me know!!

    Saturday, January 30, 2010 3:38 PM
  • Hi

    am able to solve the problem!
    i am also having the ame problem before. i removed the PCI-e and PCI-x cards and installed windows 2008 server.
    it installed smoothly. after installtion complete i fixed again PCI-e and PCI-X cards it working fine.
    any how thanks to all for the help.

    Mirza Majid Baig

    Monday, February 8, 2010 11:43 AM
  • Hey Guys...

    No need of removing the PCI-e and PCI-x cards just install the OS using HP smart start... all the drivers will be installed..


    Friday, February 19, 2010 9:04 AM
  • I've got 8.30 smartstart and it doesn't recognize the 2008 r2 os on the disk.  Any other solutions besides going to the buggy 8.40 smartstart disk?

    Monday, May 24, 2010 7:11 PM
  • Does Windows Server 2008 R2 not show up in the list @ all?  Are you sure you are using the SmartStart x64 CD?  Or does it not recognize the actual .iso /flat files file?  Using USB/CD/network share for the OS install?  Had a somewhat similar issue recently, but when I put the .iso on the USB I was using for SmartStart boot, it recognized the .iso.  I believe that the issue was actually a network problem reading the .iso file.
    Monday, May 24, 2010 7:19 PM
  • Hey! try to change the DVD Drive of your server, i got same problem before, i just replaced the DVD Drive and it worked fine. And make sure that you selected the correct OS in smart start cd.


    Majid Baig

    Monday, May 24, 2010 8:18 PM
  • We were using an IBM x3850 X5 with 512 GB of RAM, we reduced the RAM to 16GB (lowest we could go with an 8GB DIMM pair), still no joy. Removed the PCI HBA's, still no joy, removed the two PCI 4-NIC cards and it finally installed!!

    Only took about 10 attempts to build a server!! At least with 16GB of RAM it doesn't take 15 minutes to boot each time =)

    I haven't put the RAM and PCI cards back in yet, but judging from the above posts I am confident. Will report back if it fails.


    Thursday, July 21, 2011 5:05 PM
  • I was having the same problem installing Server 2008 Standard on a 32bit VM. 

    I disconnected my USB flash drive - NO GO - Then I also disconnected my CD/DVD (IDE) drive (while Server 2008 was still installing and I DID NOT RESTART).

    Server 2008 Standard installed immediately after this and after installation I took it off Autodetect and reconnected it to the .iso file it was originally connected to.

    I hope this helps




    Thursday, December 15, 2011 9:04 PM
  • Glad i found this. I received a HP ProLiant ML350 G5 Server from work and was having trouble install several different OS's with the exact same problem.

    Removed the PCI-e / -x cards and bingo! I had first tried to reduce the RAM but that didn't work.


    Tuesday, August 14, 2012 9:59 PM
  • Having the same issue on an Intel 2600CP dual Xeon CPU, over 4Gb ram, took out the PCI-x quad nic, left the ram in and away it went!  Also the first message afterwards is about needing a driver for the DVD/CD but it's actually for the RAID controller or other drive controller...

    Thanks for the info, it saved me lots of time!

    Thursday, August 16, 2012 10:15 PM