none
Wpad proxy problem with ie10 and 11 RRS feed

  • Question

  • Hi,

    We have been using a wpad.dat file for a number of years now to deploy our proxy settings. We currently have ie9 on all machines and the wpad.dat file works. When we upgrade to ie10 or 11 the wpad settings do not work and we have to manually set the proxy. Does anyone know how to get this working with ie10 and 11?

    We have the wpad.dat file on a web server, are using DHCP 252 and have an entry in DNS. The OS on the machines is Windows 7 and Windows 8.1.

    We want the user to be able to access the internet a work and also access the internet externally without manually changing the proxy settings.

    Friday, August 29, 2014 5:12 AM

Answers

All replies

  • Hi,

    Here is a important thing that I want to point out, If you are using Windows Server 2008 (or later) as your DNS server, you might have to disable the DNS Server Global Query Block List, or even modify the registry to edit the list of blocked queries to remove "wpad" from the DNS global query block list, otherwise, WPAD will not work.

    Here's a blog we can refer to:

    http://blogs.technet.com/b/isablog/archive/2008/02/19/windows-server-2008-dns-block-feature.aspx

    Some other troubleshooting steps in the link below are also helpful

    http://serverfault.com/questions/54567/internet-explorer-isnt-auto-discovering-http-wpad-wpad-dat-auto-config


    Yolanda Zhu
    TechNet Community Support

    Monday, September 1, 2014 9:10 AM
    Moderator
  • Hi Yolanda,

    Thanks of the reply. We have come across the block list issue previously and have turned this off. The Wpad file works with Internet Explorer 7,8,9 but not with 10 or 11. I have tried using Wireshark as suggested in the second link. It looks like ie 10 and 11 are try to go directly out and are not look for the Wpad file at all. 


    Firefox and Chrome also work.
    • Edited by slam123 Tuesday, September 2, 2014 6:39 AM
    Tuesday, September 2, 2014 6:31 AM
  • Hi,

    So this issue only happens on IE 10 and 11, thus, I think the general requirements to make wpad work have been met, but I still would like to share it with you:

    • If you want to use DHCP, then the DHCP must be configured to serve up the "site-local" option 252 ("auto-proxy-config") with a string value of "http://xxx.yyy.zzz.qqq/wpad.dat" (without the quotes) where xxx.yyy.zzz.qqq is the address of a web server (either IP address or DNS).
    • If you want to use DNS, then a DNS entry is needed for a host named WPAD.
    • The host WPAD must be able to serve a web page.
    • The file named wpad.dat must be located in the WPAD websites's root directory.

    Please also check if you have checked 'Automatically detect settings' under Internet Options -> connections -> Lan Connections in IE 10 and IE 11


    Yolanda Zhu
    TechNet Community Support

    • Proposed as answer by Loganm Wednesday, January 7, 2015 6:41 AM
    Friday, September 5, 2014 9:32 AM
    Moderator
  • Thanks but the requirements that you mentioned are already met. It just doesn't work with ie10 or 11. I will try modifying the wpad script. 
    Sunday, September 7, 2014 11:23 PM
  • If I change the proxy script to:

    BackupRoute="DIRECT";
    UseDirectForLocal=true;
    ConvertUrlToLowerCase=false;
    function FindProxyForURL(url,host)
     { return "PROXY ipaddress:port";
     }

    it works. It looks like the isInNet doesn't work with ie10 or 11.

    Monday, September 8, 2014 6:23 AM
  • I now have automatically detect for ie10 and ie11 working. The problem turned out to be that ie10 and ie11 don’t except tabs in the wpad file anymore. Once I removed the tabs and restarted my computer auto detect started to work. I used the autoprox.exe in the link below to test the wpad.dat code.

    http://blogs.technet.com/b/emeaie/archive/2013/11/04/optimizing-performance-with-automatic-proxyconfiguration-scripts-pac.aspx

    • Marked as answer by slam123 Tuesday, September 9, 2014 12:37 AM
    Tuesday, September 9, 2014 12:37 AM