Windows Update stalls/hangs and does not update RRS feed

  • Question

  • Hello,

    So I'm back again after having formatted the machine I was having difficulties with (see below).

    To recap I tried so far,

    1. Windows Update Troubleshooter: Found and fixed errors. I ran this multiple times through out the various attempts to get WU working. FWIW it seems to find and fix the same errors. Is this common?
    2. sfc /scannow: Found no corrupted files.
    3. DISM /Online /Cleanup-image /Restorehealth: Found no issues.
    4. Ran through all of the steps outlined here:
    5. Tried everything mentioned here:
    6. I checked the version of Windows Update and it seems the version on the machine is later than what's listed at this URL,
    7. Deleted this reg key to confirm no proxy was set.
    8. Ran multiple virus scans with different programs which returned nothing.
    9. Confirmed there is no proxy in the network.
    10. Tested downloading large and small files from different sites which occurred without issue.
    11. Changed the MTU.
    12. Downloaded a fresh image from the VLSC site.
    13. Tried Windows 8.1 Enterprise and Pro (same issue occurs on both).
    14. Tried 2 different hardware platforms (Acer Laptop and HP desktop).

    Unfortunately the issue is ongoing now with a total of 3 machines. I thought it might be specific to the hardware platform of the laptops so I formatted and installed on a different vendor and  hardware platform but the same issue occurs. All 3 machines activate without issue and the Volume Subscription site says we still have 9 activations. 

    The most common errors I see in the logs are 

    [1] 2019-03-07 15:29:03:180 944 6ec DnldMgr Regulation: {117CAB2D-82B1-4B5A-A08C-4D62DBEE7782} - Update 493F1B5D-EC0C-4185-A347-486FD9E04BDF is "PerUpdate" regulated and can NOT download. Sequence 8961 vs AcceptRate 1000.

    [2] 2019-03-07 15:29:03:305 944 6ec DnldMgr  * Update is not allowed to download due to service regulation or download size limitation.

    The interesting thing is that Windows Update, without fail, will update the Store apps but only the Store apps.

    So then I thought that maybe the image has all of the necessary updates already but when I attempt to install Office, it tells me that a certain KB is needed. I know this update is normally installed by Windows Update. Attempts to install it independently also hang. 

    I've run this through a few friends more experienced than me in the Windows realm and they too are scratching their heads so any advice or insight is appreciated.

    The Windows Update logs can be found here:

    Monday, March 11, 2019 10:09 PM


  • I am not going to add the logs because after multiple other attempts I gave up and just went with Windows 10 due to there being a looming deadline. 
    Tuesday, July 2, 2019 3:58 PM

All replies

  • Hi,


    According to the latest log you uploaded, I’d like to confirm which way to update.


    If you used WSUS, please try the following suggestions:


    1. rename the Spupdsvc.exe file:


    2. Rename SoftwareDistribution folder:

    In cmd, net stop wuauserv;

    Rename C:\Windows\SoftwareDistribution folder;

    In cmd, net start wuauserv.


    If the issue still persists, please try to install update manually.


    Hope this helps. 

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Friday, March 15, 2019 1:52 AM
  • Thank you for responding. WSUS was not and is not used in the network.

    I have not tried renaming Spupdsvc.exe. I will try that again when I have time to look at the issue again.

    I already tried stopping wuauserv, renaming the SoftwareDistribution folder, and starting it again. That is one of the steps noted in my initial post and in the link you shared.

    I also tried installing the update manually as I noted above. It too just hangs.

    Monday, March 18, 2019 1:45 AM
  • Hi,


    Thanks for your replying!


    We’ll closely monitor this thread. If you get any progress, please let us know.


    If you have any questions, please feel free to contact us.

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, April 3, 2019 3:02 AM
  • So I searched for spupdsvc.exe but I did not find it on the machine. I'm assuming this is because it only exists on a  WSUS host, which does not exist in the network.

    The 2 Acer laptops still won't update but the HP desktop magically just started updating out of nowhere. I had already tried multiple AV vendors but decided to try Microsoft's MSR and as soon as it started, the HP began updating. I thought it might be a fluke so I tried it again on another machine and running the MSR tool does nothing to kick off any updates.

    I'm at a loss as to what to try next. It's tangential but I'm not sure what I understand the reasoning is for Microsoft to continue to release outdated images in the VLSC.

    Any suggestions would be appreciated. This is really an unnecessary headache. :)

    Thursday, April 25, 2019 12:16 AM
  • To add further info on some limited progress, I tried to install KB2919442 which is the prerequisite for the 2014 service stack update (KB2919355) which is in turn the prerequisite for the 2016 service stack update (KB3173424) and it too appeared to do nothing but state "Searching for updates on this computer". Pressing on the "Cancel" button does nothing.

    Out of frustration I went ahead and tried to install the 2016 service stack update and that installed without issue but still no updates are ever shown/found when using Windows Update which stays "checking" state.

    I then tried to install KB2919442 again but the same behavior of what appears to be checking for updates with never providing/finding an actual update.

    Please keep in mind that I rebooted in between each install attempt to try and start fresh. I then ran the Windows Update Troubleshooter again which found an error it fixed (0x80070057).

    I'm now attempting to let Windows Update run again which appears to be doing something based upon the CPU utilization spike and will check back later today or tomorrow. I will post the logs from today's fun as well when I check back.

    Tuesday, May 7, 2019 5:51 PM
  • I am not going to add the logs because after multiple other attempts I gave up and just went with Windows 10 due to there being a looming deadline. 
    Tuesday, July 2, 2019 3:58 PM