locked
"A disk read error occurred. Press CTRL+ALT+DEL to restart" after WDS image deployment RRS feed

  • Question

  • Hello,
    I have read through the other forums on this error and am yet to find a response in which is related to my issue. Most of the posts I had read in which this error occured were sudden happening on their machines. My issue is slightly different: I have a classroom full of 18 HP Compaq dc5700 Small Form Factor pcs. My objective is to reimage the machines in which would be done via WDS server. To get to the point of my problem (I can get into further detail if needed to on response), I took one of the machines from the classroom and re-formatted it via Windows XP SP2 CD and made my image on this machine(including adobe's, antivirus, etc...). Once the image was made I captured it to my WDS server successfully and got everything set up to deploy. I had begun to deploy the image on the other machines and all went smoothly. I had noticed how these machines had the HP Recovery Partition along with the main Partition and unallocated space while selecting the area of the hardrive for WDS to deploy to (within the deployment steps). An example of this step can be found here. I then deleted each of the partition such as what I had done on past bench pcs using WDS so that I was left with my 74.5 GB of unallocated space. I installed the image in this unallocated space and when the computer had rebooted after the deployment finished I first got the following error: "Warning: Your system recovery partition was removed. Press F10 to start the system recovery anyway or another Key to delete the recovery partition". So, I tried pressing another Key and I then got this: "OS Missing". Then it continues on to self-PXE boot. No matter what I have tried to press or do I keep ending up back at the "A disk read error occurred. Press CTRL+ALT+DEL to restart". I had played around during the WDS deployment stage of partition managing mentioned earlier and each produce the same results. I also got this error at some times: "A system partition overlaps your recovery partition. Press F10 to start the system recovery anyways or another Key to delete the recovery partition". in which results me back to my main "disk read" error. 

    Things I have tried since:
    DOD Wipe CD (wipes all partitions/cleans hardrive) then WDS deployment  = same result error

    Using software such as GP Partition Software to create a smaller partition for imaging then WDS deployed = same result error
     
    Removing and replacing the CMOS battery along with resetting the CMOS via the CMOS button located on the motherboard then WDS deployment = same result error

    Any help, suggestions, hints, etc... are much appreciated. I am on a deadline to have this classroom ready before school starts for the beginning of this year so I am willing to try any propositions anyone may have. Thank you for taking the time to read through my post and hopefully you have some information in which could be benefitting.

    Thanks again,
    JCTech35
    Tuesday, July 28, 2009 8:18 PM

Answers

  • Hello again LDVG,
    I have figured out a way to fix this issue. I did not have a chance to try your method although it may have worked as well. The solution I was able to find that for sure works is to simply pop in the XP CD and boot to recovery console. Then (dependent on what I had previously done with the partitions) run fixboot (if possible hardrive partition is found) and also run fixmbr. Fixmbr was the main aid in this solution for it resets the master boot record which must have been where this error had been resulting from. After running these I rebooted and (once again dependent on previous partition formatting) on most machines re-deployed my WDS image and everything went smoothly from there. In doing this process I believe it is the SIDS that are also reset for when you reboot after image deployment you must go through the short WinXP personalized setup process as you would on a fresh copy of XP. Although this was a manual per-machine process using only 3 XP CD's, I was able to get it done quickly. I just want to personally thank you for helping and for all the suggestions. I appreciate it.

    Thank You,
    JCTech35
    • Marked as answer by Tim Quan Tuesday, August 11, 2009 1:40 AM
    Thursday, August 6, 2009 9:25 PM

All replies

  • I had this problem and this is how it was fixed.

    http://support.microsoft.com/kb/931761


    MCTS 70-620 Certified
    Tuesday, July 28, 2009 8:44 PM
  • This is what I did in my task sequence in the MDT workbench for Windows Server 2003.

    In the New Computer only section, I added a Run Command Line custom action.
    The name is "VDS Disk Alignment (REQUIRED)"
    The description is "Configures the WinPE registry to format the registry so that the partitions are created by using the Windows Server 2003 procedure/alignment."
    The command line is REGEDIT /s "%DEPLOYROOT%\APPLICATIONS\VDSALIGN.REG"
    The Start In folder is %DEPLOYROOT%\APPLICATIONS

    In the %DEPLOYROOT\Applications directory I created a .REG export. This is what it contains.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\vds\Alignment]
    @="Alignment Settings in Bytes"
    "Between4_8GB"=dword:00000000
    "Between8_32GB"=dword:00000000
    "GreaterThan32GB"=dword:00000000
    "LessThan4GB"=dword:00000000

    So what happens is that right before the Format Disk sequence, this command runs and sets the alignment. 


    MCTS 70-620 Certified
    Friday, July 31, 2009 1:45 PM
  • I appreciate the help LDVG, but what if I am not using MDT for deployment. I had it installed on my WDS server initially but the hardrives crashed and I had to rebuild it. I simply never reinstalled MDT, not that I ever got completely comfortable with it. I have been deploying straight from WDS. Is there a way to translate what you had done in MDT into a simply WDS form?

    Also, I have tried both of the methods listed on the microsoft support page you suggested. The only thing close to disk translation in the BIOS was located in the security menu(options: Password Set/None). I don't believe this is what the directions are referring to but I looked through each menu and there are no other translation options listed. As for the registry editing method, if this is to be done on the "capture" machine then I checked and there is no 'VDS' listed under that directory in the registry for that pc. If it is to be done on the "deploy" machines then I am also unable to do this due to the fact I cannot access any OS on the machines to get to the registry due to the disk error. It is possible I am missing something in the directions or on the machines, and if so then I can only ask that you could reword it more specifically so I could fully understand.

    For reference: The machines are running Win XP Professional and the server is running Win Server 2003 R2.

    Thanks,
    JCTech35
    Friday, July 31, 2009 7:41 PM
  • OK I re-read your post. I've seen something similar with Dell 4600 PCs. There's an OEM partiton and when a captured image
    is applied to the disk, WDS sets the [Disk] option in BOOT.INI as 1. For example,

    multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP. In order to correct this, the Disk should be 0.

    If you can boot to a plain WinPE DVD, you should be able to edit the BOOT.INI file. It has the attributes of hidden, read only, and system. So you need to change this temporarily.

    From a WinPE command line:
    attrib C:\boot.ini -r -s -h
    notepad C:\boot.ini
    Change the setting and save the file.
    You can either change the attributes back now or reboot and test it first.

    Now, doing this on several PCs, at the moment the only way I can think of fixing it is to do it manually.

    The Disk Translation BIOS setting I've never heard of, might be some legacy option.
    MCTS 70-620 Certified
    Friday, July 31, 2009 11:35 PM
  • Okay,
    I have made a WinPE disk and booted to it. I ran the commands and opened up the file. The problem is that the 'disk' is already set to '(0)'. All are set to 0 except for the partition(1). The boot.ini file reads as follows:

    [boot loader]
    timeout=0
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


    This was all done on one of the client machines.
    Also, I had talked to someone else about this type of an issue and they brought up the idea of it maybe having to do with the MBR (master boot record) since this does not get wiped when the disk is reformatted or wiped. I am going to try playing around with that on a few machines in the mean time. We are down to about 2 weeks before school so the urgency of this simply keeps rising. I am still open for any suggestions or comments.

    Thanks,
    JCTech35
    Monday, August 3, 2009 7:03 PM
  • OOPS!! Sorry, I meant Partition, not Disk.
    Please try changing the 1 value to 2. The OEM parititon may be on 1.


    MCTS 70-620 Certified
    Tuesday, August 4, 2009 7:09 PM
  • I have also tried changing this attribute and the results stay persistent. I still am getting the error on restart after the change so I am going to try a re-deployment onto the machine. I am also in the process of making another image from scratch on one of the other machines which also produced the error. And could you be more specific as to what you are speaking of in the boot.ini file attributes? Could you show me specifically what you are saying the attributes should be and the file should look like according to your wording.

    Thanks,
    JCTech35
    Tuesday, August 4, 2009 7:29 PM
  • In the system root (C:\) there is a file called boot.ini. It is normally hidden, read-only, and a system file. Before being able to edit it, we need to modify those attributes. The steps to do this are mentioned above in my July 31st post.

    The boot.ini contains data that looks like this.

    [boot loader]
    timeout=0
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

    In your case, try changing both lines that contain partition(1). In your case, the default could be 0 or 1, so try setting those to the other. When you've done this, save the file with notepad in WinPE. The command prompt should be still open, so do
    attrib C:\boot.ini +r +s +h
    this makes the file attributes to how they are by default.

    Restart the PC, if it still doesn't boot, restart again, go back into WinPE, do the steps from my previous post, but now try changing the paritition() values to 1 or 2 or 3. Don't make it look like partition(123) or anything. Just try each number sequentially like partition(0), save, reboot, try partition(1), save reboot, and so forth.



    MCTS 70-620 Certified
    Thursday, August 6, 2009 2:32 PM
  • Hello again LDVG,
    I have figured out a way to fix this issue. I did not have a chance to try your method although it may have worked as well. The solution I was able to find that for sure works is to simply pop in the XP CD and boot to recovery console. Then (dependent on what I had previously done with the partitions) run fixboot (if possible hardrive partition is found) and also run fixmbr. Fixmbr was the main aid in this solution for it resets the master boot record which must have been where this error had been resulting from. After running these I rebooted and (once again dependent on previous partition formatting) on most machines re-deployed my WDS image and everything went smoothly from there. In doing this process I believe it is the SIDS that are also reset for when you reboot after image deployment you must go through the short WinXP personalized setup process as you would on a fresh copy of XP. Although this was a manual per-machine process using only 3 XP CD's, I was able to get it done quickly. I just want to personally thank you for helping and for all the suggestions. I appreciate it.

    Thank You,
    JCTech35
    • Marked as answer by Tim Quan Tuesday, August 11, 2009 1:40 AM
    Thursday, August 6, 2009 9:25 PM
  • Great, thank you.

    I wanted to mention that sysprep is absolutely mandatory when deploying images. I think I understand that you are saying they were sysprepped before the deployment. What's happening is that since the PCs hadn't booted (because they couldn't) XP Mini-Setup never ran, so now that Windows can boot it goes through the Mini-Setup process. All of those settings can be skipped or configured automatically through sysprep.inf. That's a whole different subject, but good to hear you're running now.
    MCTS 70-620 Certified
    Thursday, August 6, 2009 10:57 PM
  • HERE I GET THIS DUMB THING THAT POPS UP ON MONITOR AND I CANT SEEM TO GET IT FIXED. ANY HELP HERE WOULD BE GREATLY APPRECIATED. HERE IS WHAT POPS UP AFTER I BOOT UP MY PC. I AM RUNNING WINDOWS XP.

    "A DISK READ ERROR OCCURRED"
    PRESS CTRL+ALT+DEL TO RESTART
    Sunday, October 4, 2009 1:47 PM
  • Hi All,

    I ran into this issue on a compaq workstation W9000.
    After exhaustively trying everything in the book (cables, jumpers, resetting BIOS, FIXMBR, FIXBOOT, chkdsk, etc.), I discovered that it was a BIOS issue.  Setting the disk configuration in the BIOS to LBA (from the default factory setting) fixed the problem.

    I saw this issue after moving a new drive from 1 system to another w/W2K3 Server SBS, I thought it was a boot manager issue at first since I could access the drive from a BartPE disc as well as the Windows setup disc.

    Hope this helps others!

    • Proposed as answer by BeefyDog9000 Sunday, November 22, 2009 7:55 AM
    Sunday, November 22, 2009 7:55 AM
    • Proposed as answer by Exjaded Friday, February 5, 2010 8:36 PM
    Tuesday, December 29, 2009 5:46 AM
  • This is caused by a wrong partition layout.

    1. Backup all your files to another disk on another computer (just copy paste entire contents)
    2. Format the broken partition with windows leaving all values default or use the windows install CD to prepare your partition.
    3. Remove any files left on the formatted partition.
    4. Copy your files back to the original disk.

    • Edited by Jooch Wednesday, November 6, 2013 10:54 AM typo
    Wednesday, November 6, 2013 10:54 AM