locked
A Sector-Seek-Across-Logical-Boundaries Problem RRS feed

  • General discussion

  • About two months ago, my home computer which had been always connected to the network and had been running Microsoft Windows Vista Home Premium  developed a very unusual problem.  The main disk drive (Western Digital WD5000AAKB ATA drive) which had been partitioned into two equal-size logical drives started making loud clicking sounds with no apparent load on the operating system or on the drive.

    The temperature of the components of the computer is always held in the operating range by an extensive set of fans and an external heater and this temperature is displayed independently on an analog gauge.  The +12V output of the computer power supply (the output of the supply that drives the disk drive motors and parts of the display card) is also monitored and independently displayed on another analog gauge.  The sound output on both channels of the stereo sound chip on the motherboard are also independently displayed on two analog VU meters.  This sound output then is sent through another external stereo amplifier with an independent external switching power supply before driving the stereo home-built speakers.  The sound amplification is chosen in such a way to reveal any fluctuations in the power supply output of the computer system that fall in the audio range with amplifier gain at maximum and with no actual sound output from the computer's sound chip.  This way, one can hear the disk drives transferring data as the data rates change and one can also hear any heavy bus transactions taking place as the demand on the CPU of the computer varies.  The normally-very-high-speed fluctuations are aliased down into the audible range by small non-linearities in the system which are always present.

    The loud clicking sound from the disk drive is always followed by a huge (several volts, with voltage nearly down to +9V) voltage drop on the +12V supply and one can hear the disk spinning down momentarily through the audio system.  Before anything is halted in the operating system, the disk spins up as the +12V returns to normal, and the operating system continues as if nothing has happened with no error message.  This pattern repeated itself at random intervals, averaging one click in an hour or so, and sometimes much more often.  There is also some indication that the pattern is repeated more often near the low end of the operating temperature range, but this was not a very conclusive evidence.

    At first, I thought that the disk drive hardware somehow had been damaged and the disk was about to crash.  I backed up the disk using the Western Digital's version of the Acronis True Image software and there were no problems during the backup, even though disk again made those loud clicks every now and then.  I scheduled a disk check on the boot partition and asked for identification of faulty sectors.  The disk check ran at boot time and found no errors.  I booted the computer back up, and it ran with those loud clicks appearing at about the same frequency.  Heavy copy operations (about 5 GB per copy) went well with no disk faults at all, but with just those annoying loud clicks every now and then.  There was nearly no impact on the computer's performance.

    I listened to the loud clicks for a long while (several weeks), and made note of any error messages of any kind in the operating system.  The only reported errors were that the Windows could not open a file it needed (it did not say what file it was) and the software "Google Earth" has stopped functioning properly.  These errors were always reported simultaneously with an announcement of a new version of "Google Earth".  Installing the new version always fixed those two errors simultaneously.  These errors had appeared before the loud-click problem, and they were fixed the same way. However, it was possible that the latest "newest" version of the "Google Earth" was doing something strange, even when it was not running, as those errors mentioned above were announced even when I did not use the "Google Earth" software at all.  So, something was marking the disk drive sectors in some non-standard way.  However, the "disk check" should have fixed these problems and it did not fix anything on the boot drive, as far as the loud clicks were concerned.   There was another piece of software that came with other software I use, namely the McAfee Security Scanner that came with the Mozilla Web Browser system.  Neither the Microsoft Security Essentials (The software I use almost all of the time and always updated to current) nor McAfee Security Scanner reported any problems.

    Another week passed, and loud clicks kept coming back. Then, after I checked a "popular" headline news item ("Harvard Sex Club") on the standard "att home" page, McAfee Security Scanner came up all by itself and announced that a web page I had visited had left a compromising entry in the system.  It supplied an "IP" address for this web page.  So, I went to the Web page using the Microsoft Internet Explorer 9, which I use every now and then for specific purposes.  The web page turned out to be "YAHOO"'s standard image search page which was a legitimate web page I used all the time.  This was strange.  Why would a standard web page be bad all of a sudden?  I told McAfee not to fix anything all by itself, and shut it off.

    I listened to the loud clicks again with my ear very close to the disk drive.  It occurred to me that the disk drive might have been forced to seek passed the boundary of its logical partition into the other partition to look for a very small piece of a file, then back and then the same thing again over and over again until the drive electronics noticed the bad seeks and temporarily pulled the heads to parking area until it was safe to move the heads again.  That would make a loud click and the platter would temporarily spin down.  Some software (either "Google Earth" or "McAfee") had installed that bad "protection" system.

    I decided to set the computer to disk check the other partition of the disk first with bad sector identification and fix, immediately followed by a disk check of the boot partition with the same stringent settings, after an immediate reboot, with the computer off the network during the checks.  This took almost all night, but the computer was up in the morning.  There were no trace of the loud clicks.  I cleared the "Problems Found" list, and I did not load the "Google Earth" update.

    The computer is now running at full load (Large Network file transfer + Live TV at 30 fps + Mozilla Web Access to type this message + Occasional manual system checks by me) with no problems, and it has been this way for the few days since the repair.  I'll determine which software caused the problem and write it up...

    -- Yekta

    Sunday, December 9, 2012 11:54 PM

All replies

  • Yesterday, December 20, 2012, I used my network computer in the morning, before I took off for my currency and CFI practice flight in Van Nuys airport.  The computer was working very well. I had a very nice flight, and I came home around 8 PM.  I turned the computer on, and I watched TV for a while, while I ate my dinner.  Then, I turned the network modem on.  I got the mail, and I ran Mozilla to read news summaries.  A few minutes after I turned the network modem on, the disk drive started clicking again with increasing "click" frequency. 

    I scheduled a disk check on the boot partition, and disk checked the other partition on the boot disk.  The disk drive kept clicking.  I rebooted the computer, and it started checking the boot partition.  I went to sleep.  I woke up at about 3:45 AM and I noticed that the computer had just finished checking the boot partition and it was about to boot from that partition.  The disk drive was clicking nearly wildly.  The machine booted fine with the clicking drive and I set the Microsoft Security Essentials to custom scan all of the disks, and started the scan process.  I went back to sleep, with the drive clicking a little bit more than occasionally, in the distance.

    I woke up around 7:30 AM.  The scan was progressing normally.  The drive clicked every now and then.  By 10:30 AM, I noticed that the drive was clicking in a very particular manner.  Whenever it clicked, it always did it twice: Click, a second or so of silence, and then Click again.  The time interval between the sets of double-clicks was about 13 minutes.  I timed the clicks using my clock-radio and the timer on my wireless phone, for about one hour and a half.  The precise time interval was 13 minutes-and-16 seconds +- half a second of error in starting and stopping the timers.  This indicated that the problem was most likely caused by a piece of software in the computer instead of a disk drive hardware failure, as heavy disk activity was in progress due to the security scan and that would only aggravate a hardware problem in the disk drive instead of making it a relatively occasional event.  Whichever software that was causing the problem was not getting much attention due to the higher priority security scan.

    The scan of the boot partition was completed shortly after noon, and I rebooted the computer.  The disk drive was clicking wilder than ever during the boot, and the system came up as if there were no problems.  I looked around in the operating system and noticed that "Google Earth" had somehow reinstalled all 173 MB itself on December 20, 2012, using my slow, 75 kB per second maximum (usually about half of this rate on the average), network connection. 

    I definitely had not loaded its update since December 9, 2012.  I did not know how it got in without letting me know.  I never perform a completely automatic update.  I uninstalled both the "Google Earth" and the "Google Chrome".  I also made a new Windows configuration, disabling some of the unused "Windows" options.  This took some time and the disk drive was clicking ever more frequently.  I rebooted the computer and the clicks were ever more frequent.  The system again came up fine, with the clicks. 

    I connected to the network, updated the Microsoft Security Essentials, and loaded another important security update released today which was made to fix a security problem in Microsoft Windows Vista, that enabled unauthorized remote control of the computer!   As the updates were installed, the drive kept on clicking wilder than ever...

    This time, I decided to check on the boot sector of the boot partition as the disk was clicking as soon as the boot process started, while I turned the computer on.  I shut the computer down and set the boot CMOS ram to boot from the original Microsoft Windows Vista Home Premium DVD.  The DVD boot software came up very slowly and I chose the "Repair the Windows installation" option.  After a while, with a very slow disk access that did not cause any clicks, the software came back and informed me that it needed to replace the boot block and its back-up.  I chose the "replace" option and it did so.

    I set the boot CMOS ram to boot from the hard disk and rebooted the computer.  As soon as the system came up, I scheduled a disk check of the boot partition and rebooted the computer.  The disk check completed with a lot of clicks, but the system booted with a lot less clicking later.  Encouraged by this result, I immediately started a disk check on the other partition on the same disk.  This action also emitted a lot of clicks, and the system became usable with almost no clicks.  I rebooted the computer once more and started to use it.  I uninstalled the unneeded "McAfee" software as well, just in case. 

    I connected to the network and received more mail.  I used Mozilla to read news and check weather.  I typed in this message.  There are no "wild" clicks.  The clicks now appear at precisely 13 minutes-and-16 seconds intervals and in pairs as mentioned above, with network connected and with almost no load on the system, this time.  I will look into this further, needless to say...

    I also noticed that the "Shutdown" screen background picture became a bit "grainy" lately.  I took  pictures of a part of this screen using the camera in my wireless phone.  One of those is shown below and it is a very accurate representation of what is visible on the screen:

    Another one is shown in my next reply due to the "only two pictures per message" limitation.

    -- Yekta

    Saturday, December 22, 2012 8:48 AM
  • Here is the other picture:

    -- Yekta

    Saturday, December 22, 2012 8:52 AM
  • I had posted the previous two replies on Saturday, December 22, 2012 at 12:54 AM.  Right after I posted them, I printed this whole thread into a local ".xml" file so that I had a record of what was in them when I posted them.  I have just logged in (Sunday, December 23, 2012, 11:03 PM) to the "technet" forum, and I noticed that they had been re-posted on Saturday, December 22, 2012 at 8:48 AM, almost 8 hours later.  The first reply had also been posted twice.  I took the replica reply off with a note to the editors.  It looks like forum file system has had some problems in the immediate past.

    Here is what happened in the meantime:

    Right after I posted the previous two replies, I shut the computer down and went to sleep.  Next morning (still Saturday, December 22, 2012), I brought the computer up, connected it to the network,  received mail and looked at the news.  I then disconnected it from the network.  As before, the boot disk was clicking every 13-minutes-and-16-seconds. 

    I noticed that the several disk checks I had performed previous day had actually modified some of the icons on the desktop.  It had removed the actual icon pictures from the icons and it had left the standard "shortcut" icon image in place of each.  These now-icon-pictureless programs were: Hoyle's Mega MahJong, X-Plane IX, Microsoft Flight Simulator X, Microsoft Visual Studio 2005, Microsoft Visual Studio 2008, MSDN Library for Microsoft Visual Studio 2005 and MSDN Library for Microsoft Visual Studio 2008.    Trying to restore the icons using the "Change icon" feature of the icon "Properties" went nowhere.  The "Change Icon" selection did show the correct icon picture and did let one select it.  However, it would not restore the icon picture when one pressed the "OK" button after the selection.

    Deleting the shortcut, and making another shortcut did work for some of the icons, except in the case of Microsoft Visual Studio 2008.  It just would not let one select the correct icon picture even with a new shortcut.

    I concluded that those listed programs were somehow damaged by whatever came through the network, and I decided to repair those using their installation CD/DVD's. Hoyle's Mega MahJong was fixed almost instantly.  After X-Plane IX DVD finished repairing the program, and exited, the boot disk which was clicking every 13-minutes-and-16-seconds, all of a sudden started clicking every second or so.  

    I immediately scheduled a boot-disk disk-check and proceeded to shut the computer down.  This action did not stop the fast clicking even during the shutdown.  I then remembered how the clicking sounded through the stereo system:  There was a fast read noise (a high-pitched "whoop") just before the click, followed by the click, and a short "spin-down" noise.  I concluded that the code that  was causing the boot disk (on IDE 1, master only) click, was also trying to read from the other IDE channel (IDE-2, CD and DVD readers only) at the same time, perhaps with the assumption that the second disk partition was on IDE-2 (which is false, the second disk partition is a logical partition on this computer, not a physical one).  I immediately ejected all CD and DVD's from the drives and left them with the open trays.  The clicking stopped instantly, the machine shutdown normally.

    I brought the computer up, and after the disk checks, I repaired all of the programs mentioned above using their CD/DVD's.  The boot disk drive kept clicking every 13-minutes-and-16-seconds, but no other wild clicks were observable.  After another few disk checks, and reboots the computer was stable enough to back the disks up.  I used Western Digital's Acronis True Image program to make an image copy of the boot disk and its logical partition on an off-line disk drive.   Then, noting the distinct possibility that the version of Acronis True Image I had might also be damaged, I got the most recent version of the Western Digital's version of the Acronis True Image program from Western Digital's web site, with no problems.  I shut the network off, installed the new version of Western Digital's Acronis True Image program and I started to make another image copy of the boot disk and its other logical partition.  I then went to sleep. 

    In the morning of Sunday, December 23, 2012, the computer had been up for a long time with no problems, except the occasional click mentioned above.  While looking at the past back-up disk-image file sizes, I noticed that some of the back-up disk-image files were much shorter  some of the others even though they were the same image copies of the boot disk and its other logical partition.  I concluded that there was somehow a huge, somewhat "detached" sector mass, like a linked list, not really part of the data in the file system, and check-disk was not freeing it up due to again some vague attachment points to its various parts.  Some bad code had obviously been constructing it.  Following this oddly-linked list rapidly with the disk read-head could produce any pattern of clicks.

    I decided to de-fragment all of the disk drives.  First de-fragmentation ran for about 14 hours and came back with a statement that another de-fragmentation is needed.  I checked the free space on the boot disk:  The de-fragmentation had freed up 29 Giga-Bytes more, which was 33 percent of the boot drive size.  De-fragmenting the disk further took little time (a few minutes), but it  did not improve anything.  Every time, the de-fragmenter came back with the message that further de-fragmentation was needed, indicating that something was moving oddly in the file system.

    The clicking had also stopped completely, and that was until I used Mozilla with whatever add-ons it had to type this message.  Sometime after I logged in to the Forum, the 13-minutes-and-16-seconds period clicking started again.  Now, however, the source of it does not seem to be so mysterious...  More later.

    -- Yekta

    Monday, December 24, 2012 8:28 AM
  • I decided to address the non-converging disk de-fragmentation problem next.  With the computer off the network (DSL modem power shut down), I shut down the Microsoft Security Essentials program.  Then, I de-fragmented the disks one more time, followed by a disk check for each.  After a reboot to disk-check the boot drive, the de-fragmentation program returned with a no-further de-fragmentation-needed message.  The system, however, took back 1 Giga-byte out of the freed 29 Giga-Bytes mysteriously. I then verified that the de-fragmentation was stable and turning on the Microsoft Security Essentials program did not change this latter result.

    Encouraged by the stabilized system, I continued to trace the "disk-clicking" problem.  The idea was to load the computer with CPU and graphics display intensive programs which needed almost no disk access, to 100 percent load and to see whether the period of the disk clicks changed.  I ran Marine Aquarium Version 3, Marine Aquarium Version 2, and the Hoyle's MegaMahJong introduction display to occupy the entire display and to load the CPU to 100 percent.  I have a picture of this screen in one of my threads titled "Difference in The Behavior of Microsoft Windows Vista Home Premium Between System Booted While Connected to A Network And System Booted While Not Connected to A Network".  The picture is in my reply dated Tuesday, December 27, 2011 6:22 AM, with the details of the parameters of the running programs.

    The period of the disk-clicks did not change appreciably.  It increased to 13-minutes-and-19-seconds. At this point, the data about the disk clicks did not make sense.  The disk-click period was relatively constant whether the disk was accessed all the time (as in the case of an Acronis True Image disk backup with nearly 100 percent disk load and with low load on the CPU) or not (100 percent CPU load with almost no disk access).  The fact that the disk had produced no errors during all of that recent activity in the past (except the boot sector damage and quite a few damaged programs on the disk, before the recent activity)  did not help the "mechanical-disk-failure" theory at all.

    I decided to check the sector structure on the disk by formatting the second partition on it and reloading the data and the programs onto it from its Acronis True Image backup.  I started the format procedure and it seemed to work until it formatted about 20 percent of the partition and again wild clicking started.  I cancelled the format procedure, rebooted the machine and tried again and got the very same result.  Despite the fact that the mechanical-disk-failure almost certainly was not the case, I decided to load the CPU to nearly 100 percent during the format procedure so that the disk access rate was slowed down.  I used the Marine Aquarium 2 (as mentioned above) and another little, but very CPU and GPU (graphics processor) intensive game called Rubik's Cube Challenge to achieve this, and it worked.  The format procedure completed, although slowly, with no problems.  It was late at night and I went to sleep.

    Next morning, I loaded the freshly formatted partition from its Acronis True Image backup, and verified that every restored program worked.  They did.  Only Microsoft Flight Simulator X, with Acceleration needed repair, and it consumed 3 more Giga-Bytes of the recovered 29 Giga-Bytes.  The system became stable after this with a total of 25 recovered Giga-Bytes of storage.  However, the disk-clicks came back again.  They had nothing to do with the sector structure on the boot disk.

    [Note added on December 30, 2012, at 07:58 AM PST: I also booted the computer from the floppy drive with a bootable MS-DOS floppy made on another machine.   This method booted only into the floppy as the disk drive with no hard disk drivers loaded.  The disk-clicks did not cease.

    The computer had already been placed on a vibration isolation platform made out of three layers of soft rubber feet and two 0.75" thick, 22"x12" very dense particle boards which eliminated any ground-vibration leaking in, and causing the disks to click.]

    After having considered everything probable and possible, it was time to think about the impossible, as I had no other option left.  The impossible option was that something else, which was not connected to the computer data bus and its interfaces, was causing the "disk-clicks" even though the disk-clicks well seemed to be correlated with the access rate of the boot disk and its partitions.

    I decided to open the side cover of the computer and check on everything.  I shut the computer down, and cut the AC power to its DC power supply.  I opened the cover and then restored the power to the computer and booted it back up.  I waited for the clicks to appear, and surely they did so.  I pressed on every connector going to the boot disk drive and they were in tightly. All cables were held rigid by cable ties, as I had built this box myself, with nothing dangling.  I then noticed that the clicks were coming from somewhere else, not from the boot disk drive.  The source of the clicks were near the bottom of the disk cage.

    The clicks were coming from an old (29 February 2004, a leap-year drive made on the leap day, which was a Sunday) 120 GB Western Digital Disk drive (one of the very first SATA drives, WD1200JD-00GBB0) at the bottom of the cage which was only powered, but not connected to any SATA interface.  I had installed it there as a test drive with a rigidly coiled, but not connected SATA interface cable years ago, to check on things as needed. I checked its power connector: It was so tightly in that I nearly needed a tool to pull it out.  I shut the computer down and pulled out the Molex power plug (this is a dual power connector drive:  It has a standard 4-pin Molex power connector and a SATA power connector).  I rebooted the computer and surprise: No clicks.  I could not believe it.   I shut the computer down,  I removed the entire disk drive,  closed the computer up, and rebooted it back.  There were no clicks anymore.

    I went through the de-fragmentation and disk checks once again, and there were no changes to the system.  It was working very well and it still is working fine with much improved response times.  There is nothing wrong with the system power supply: All of its voltages are as stable as before.

    I connected an external power supply and a SATA-to-USB adapter to the old 120 Western Digital Drive and powered it up.  The drive came back up with no clicks.  I plugged it in to a USB 2 port and it mounted just fine, and came up as the test disk.  I copied about 63 Giga-Bytes onto it and the copy operation went through with only three small file errors.  I decided to format this drive, and the operating system came back with an error that it could not format the drive.  I partitioned the drive into 4 smaller partitions and only two of the 4 partitions were formattable.  It seemed that the powered, but disconnected-from-the-system-data-bus disk drive got its surface damaged.  Figuratively speaking, "something cooked and ate the duck decoy, not realizing that it was made out of wood".

    I will test this old drive in another computer I have and see what happens...

    -- Yekta


    • Edited by Yekta_Gursel Sunday, December 30, 2012 4:07 PM More detail added, and one drive size corrected.
    Sunday, December 30, 2012 8:47 AM
  • I have looked into the "grainy looks" in the "Shutdown" screen in Microsoft Windows Vista Home Premium a little further.  The "grainy looks" does not appear when the system is shutdown before logging into the computer.  It does appear when the system is shutdown after logging into the computer.  The major difference between these two cases is that AMD Radeon HD Catalyst Control Center display driver is engaged after log-in, and user preferences for brightness, contrast and screen "gamma" are applied.  None of these overall controls, however, can explain large changes in "grainy looks" in different portions of the screen for a known displayed image.

    Here is a close-up picture of a part of the shutdown screen before logging into the computer in full resolution of my wireless phone camera:

    And, here is the picture of the same area of the shutdown screen after logging into the computer, in full resolution of my wireless phone camera:

    There is a vast difference between these two images, other than brightness, contrast and screen "gamma" settings.

    -- Yekta

    Wednesday, January 2, 2013 3:42 AM
  • I took the disk drive to a machine with a newer BIOS that had the better S.M.A.R.T. (Self Monitoring Analysis and Report Technology) capability in BIOS.   The original machine has a less sophisticated S.M.A.R.T.  During boot,  this BIOS tests the drive to see whether the drive is likely to fail soon.  It worked on the drive for a while, and then it disconnected it from the interface.  I insisted on booting with it, and it brought it briefly up, then it disconnected it again.  The drive surface is obviously damaged.

    I also figured out how the disk de-fragmenter managed to free up 29 GB of disk space without removing anything from the system disk.  It turns out that the Microsoft Security Essentials eats up disk space in nearly 2 GB chunks every now and then as it is being updated.  It is somehow leaving linked sectors on the disk as, so-called, "garbage" and it seems not to be "garbage collecting" afterwards.  The disk de-fragmenter noted this and collected the "garbage" laboriously, but very efficiently.

    In the meantime, about 20 GB of disk space was devoured back into "garbage" gradually over a few weeks.  I'll look into this further and let you know what I find out...

    -- Yekta

    Saturday, January 19, 2013 5:33 AM
  • Last Saturday (February 2, 2013) morning, I shut the computer down normally using the Windows "Shutdown" menu, as I was going out and not expecting to be back until late in the evening.   It shut down, making the usual noises through the connected stereo amplifier.  I switched the computer internal power supply off using its switch, and then I switched the surge-protected outlet strip the power cord was plugged in off, using its own switch and then I went out.   I came back sometime in the evening, and turned the outlet strip on.  Its lights came on indicating the availability of power and ground connections and surge protection.  I then turned  the computer power supply on using its own switch, and pressed the logic "Power On" switch on the computer's front panel.  Nothing happened.

    Somewhat puzzled, I went through the whole sequence one more time, after shutting everything off.  Still, nothing happened.   I thought that the computer internal power supply's switch might be broken and I decided to put the problem aside until morning.

    In the morning, I opened the computer up and removed the internal power supply, a Diablotek PHD 450 I had bought in June 2011 (it was made in April 2011).  I put an old, smaller wattage power supply back in and brought the computer up.  There was nothing wrong with the computer.

    I took the Diablotek PHD 450 to another room and connected power to it, and switched it on.  I then checked the 5 V Standby power voltage between the ATX 20-pin power connector pin 9 (5V 2A Standby power, purple wire) and pin 7 (common power ground, black wire).  There was no Standby power.  This Standby power is used to power the mother board test circuits up to decide whether the rest of the high-power (3.3 V, 5 V, -12 V and +12 V) outputs of the power supply should be turned on using the PS_ON (negative logic, ground to turn on) line (pin 14, green wire) on the ATX 20-pin connector.  Should the power supply be working with the Standby power available, the response to the PS_ON command is seen on the PWR_OK line (pin 8, gray wire) on the ATX 20-pin connector as a high logic-level (5 V), with all of the power outputs on the ATX 20-pin connector turned on, as well.  

    I tried the PS_ON command by grounding the pin 14, and as expected, nothing happened.  It was possible that the power switch on the power supply itself was broken, or the internal power supply slow-blow fuse was blown.  The slow-blow fuse is visible through the fan opening on the power supply enclosure, so I checked it with a flash light.  It seemed to be intact.  I checked on the operation of the power switch by first disconnecting the AC power cord from the power supply and then connecting an Ohm-meter between the line and neutral prongs  (two parallel, flat prongs) of the male AC power socket on the power supply and then operating the switch.  The Ohm-meter readings will not change, should the switch be broken.  They will change (it will not read zero ohms, but it will read different values for the two positions of the switch), should the switch be functioning.  The switch was operating well.

    The label on the Diablotek PHD 450 power supply said that it was under warranty for three years.  I checked the manual, and it said the same thing.  The following picture shows the manual warranty page:

    The manual also advised to check their web page (www.diablotek.com) for technical assistance.  I checked their web page, and I found a somewhat different warranty page there:

    It said that in order to receive the three year warranty, the power supply had to be registered within 30 days of the receipt.  Otherwise the warranty period was one year.  None of this was in the manual and I did not remember seeing a registration card when it had arrived.  By the way, the power supply had arrived in a Diablotek DA 500 box, from TigerDirect, but inside the box was a Diablotek PHD 450 which was what I had ordered. 

    I checked the amount I had paid for the power supply and it was $35 (about 36 Tacos from Taco Bell, not cheap) with shipping.  I decided to open it up and see what was wrong with it, instead arguing about the warranty clauses, as I had bought it more than a year ago. 

    So, I neatly opened the power supply enclosure up.  It is a slide-and-snap-shut enclosure with four screws and the enclosure does not readily open up when one removes the screws.  One also has to take the fan-grill screws off, which lowers the fan into the enclosure with no way of removing the large fan.  But, this last action supplies sufficient finger space around the fan to release the snaps on one side and then pull the cover up on that side and slide the cover toward that side to separate the  halves of the enclosure.

    What I have seen inside is the subject of my next reply as I have run out of picture space (only two per message) in this message...

    -- Yekta

    Tuesday, February 5, 2013 4:05 AM
  • Inside the supply, I noticed the liberal use of what appeared to be a bright-red, paint-like glue. All power resistor leads, fan connector, input power supply filter capacitor drain resistors, and even the insulation under the circuit board had this material applied to them.  The following picture shows this material on the insulation under the circuit board.

    I then noticed the odd AC line wiring at the input of the power supply.  I made a partial schematic of the power supply, as shown in the next picture, in order to explain why the wiring is more than odd:

    Note the HP (Hewlett-Packard) type, line cord input connector at the lower left corner.  The connections to everything to the right and above this connector are inside the power supply enclosure.  Note the connection labeled "L".  This is the so-called neutral (low voltage,  but not necessarily at ground potential) side of the AC line connection.  Note the connection labeled "N".  This is the so-called "hot" (high voltage, 115 V)  side of the AC line connection. 

    Now, the ON/OFF switch, the slow-blow fuse and the RTC (Thermal contact resistance, a thermal fuse type) are installed after the input filter (0.47 uf capacitor and toroidal-core chokes), which means that even with the ON/OFF switch set to OFF position (L connection broken at the switch), 115 V AC is still applied across the 0.47 uf capacitor and the toroidal core chokes inside the power supply as long as the line cord is plugged in.  Any short or other failure of those components will send an uncontrolled high-current (15 Amps) at high voltage (115 V) through those causing a literal melt down at best.  Neither the slow-blow fuse nor the RTC can prevent this as they are installed after these components.  Note also that the ON/OFF switch is installed on the low voltage side on the L line, which maintains a high voltage presence all inside the power supply along the N (high voltage, 115 V) line, as the N line is never broken.

    The correct circuit is obtained by installing the slow-blow fuse, the RTC and the ON/OFF switch, in the order stated, on the N line (115 V), right after the HP type Line cord connector, and then install the input filter (0.47 uf capacitor and the toroidal core chokes) after those. The output (right) side of the toroidal core chokes then connect to the CX1, drain resistor, and the input transformer directly, now protected by the fuses and the ON/OFF switch.  The Diablotek PHD 450 input stage is not wired correctly as delivered.

    When the Diablotek PHD 450 is plugged in and turned on, the functioning input stage produces a DC output nominal voltage of 330 Volts across the connections labeled B+ and B-, with an input voltage of 115 V AC (selector switch set to 115 V). This is the case in my broken power supply which means that the failure is after the input DC power supply circuit.

    The top half of the partial schematic shows the main switching oscillator section of the power supply which is based on the TI (Texas Instruments) UC3843A Current-mode Pulse-Width-Modulator Controller chip.  This part of the circuit also contains an unexplainable element:  Two high-power resistors (1.2 Ohms (gray colored) and 0.12 Ohms (pink colored)) connected (soldered in) in parallel.  In such an arrangement, only 9.09 percent of the total current through the assembly will go through the 1.2 Ohm resistor.  90.9 percent of the total current will go through the 0.12 Ohm resistor, with both resistors supplying the same voltage drop.    This means that ten times more power is dissipated in the 0.12 Ohm resistor with both resistors at the same power handling rating.  This does not make sense.  Again, the Diablotek PHD 450 is not correctly wired as delivered. 

    My next reply shows these two resistors, as no space left for those pictures in this one...

    -- Yekta

    Tuesday, February 5, 2013 5:32 AM
  • Here is the 1.2 Ohm, 5 percent value tolerance resistor (gray body, brown-red-gold-gold color code stripes):

    And here is the 0.12 Ohm, 5 percent value tolerance resistor (pink body, brown-red-silver-gold color code stripes.  I had to take it out of the circuit to make sure that the third silver stripe was really silver colored, but not gold colored.):

    I equalized the resistor values to 1.2 Ohms, and the power supply still did not work.  The fault is somewhere in another component in the rest of the circuit.  I'll let you know when I find time to find out...

    -- Yekta

    Tuesday, February 5, 2013 5:44 AM
  • The next part of the power supply circuit I have looked at is the non-working 5 V, 2A STANDBY supply circuit.   As I have mentioned before, this is the power which is supplied first to the motherboard.  After self tests, the motherboard turns rest of the power supply on.  This particular design locks out all the rest of the power supply, should the 5V, 2A STANDBY supply be defective, by controlling the output of all of the other switchers by the voltage produced by the 5 V, 2 A STANDBY supply through the use of opto-couplers in the power supply circuit.

    The picture below shows the traced schematic of the 5 V, 2 A STANDBY power supply circuit in the Diablotek PHD 450 power supply:

    The 5 V, 2 A STANDBY switching power supply design is based on the Power Integration's TNY 267 Tiny-Switch-II chip (the 7-pin chip in the 8-pin DIP packaging in the schematic).  The "dotted" connections and the circuit elements on them in the circuit are optional for the TNY 267 chip, and the Diablotek PHD 450 power supply does not have those components.

    I have checked every component and connections on this schematic.  The output chain on the secondary winding of the transformer have all functional parts and perform as designed.  The opto-coupler is also intact.  The components on the primary side of the transformer and the transformer itself are also working with the exception of the TNY 267 chip.  This chip is connected correctly and all of the correct voltages are supplied to it.  It seems that its output MOSFET (700 V maximum voltage across)  has  stopped switching.  The chip produces very weak switching waveforms which can barely sustain the current flow through a 500 Ohm resistor at the power supply output at 5 V.  The circuit itself has a 47 Ohm load resistor at its own output, so it was producing hardly any voltage at all (two hundred milli-Volts or so).

    The chip is readily available from many suppliers and costs about $1.42 each in quantities of 10, and $1.72 each in quantities of 1, with a $5 shipping charge for the total.

    I might get some and fix the whole thing up, together with all of the other bugs I have found.

    -- Yekta

    Friday, February 8, 2013 9:03 AM
  • I ordered a few of the TNY 267 chips, and the chips arrived two days ago.  I desoldered the original TNY 267 chip and gently pulled it out the printed circuit board holes using two old dental picks.  I put one of the new chips in and soldered it back on the circuit board pads.   I then plugged the Diablotek PHD 450 power supply circuit in and turned its power on.  

    To my surprise, the 5 V, 2 A STANDBY switching supply did not produce the expected output voltage of +5 V.  It was still producing very weak switching waveforms.

    This meant that some component on the switching side of the 5 V, 2 A STANDBY power supply was malfunctioning only when the power was turned on, but the same component was normally functioning, as measured by instruments,  when the operating voltages were turned off.  I knew at this time  that TNY 267 was not one of those components.

    There are only four other components on the switching side of the 5 V, 2 A STANDBY power supply, that are subject to the high voltage of 330 volts at 132 kHz of switching rate (nominally 0 to 330 V and back 132,000 times per second; this is like a sledge-hammer pounding on the components, in sharp contrast to what happens in low voltage, 5 V to 12 V,  circuits): The diode, the transformer primary winding, the resistor and the capacitor which are connected to B+ and the Drain D of the TNY 267 chip (see the schematic I have traced and drawn in my previous message).

    None of these four components showed any sign of "burn-out".  The resistor (47 kilo-Ohms nominal) was certainly performing fine under high-voltage switching waveform, as well as the primary winding of the transformer.  That left only two components to be checked under switching, high-voltage operation:  The diode (1 N 4005) which was operating fine, and the capacitor.

    The capacitor looked to small for the value and the voltage ratings it had to have: Its value was to be 0.1 micro-Farads (that is because of the time constant it had to form with the 47 kilo-Ohm resistor), but it had to stand 330 volts, at the least.  The data sheet for TNY 267 chip recommends a high-voltage rating of 1,000 Volts.

    I noticed that whoever assembled the Diablotek PHD 450 switching power supply had used the same kind of capacitor for the one that was connected to Pin 1 (Bypass, BP) of the TNY 267 chip, which is a 0.1 microFarad, low voltage (15 to 25 Volts maximum, as that Pin  1 voltage is clamped to 6.3 V maximum by the chip itself) capacitor, and for the one that was connected across the switching high-voltage (330 V) through the TNY 267 output MOSFET  (Pin 5, Drain, D), the one I was talking about above.

    And, sure enough both of those capacitors were low voltage, 0.1 micro-Farad, common by-pass capacitors and the 5 V, 2 A STANDBY power circuit of the Diablotek PHD 450 power supply was working literally by a miracle: Low voltage capacitor had (more-or-less) survived the relentless pounding of the switching high-voltage waveform for nearly a year and a half.

    The picture below shows the low voltage capacitor (The tiny, yellow one with the marking of "104" underlined)  I removed from the 5 V, 2 A STANDBY power supply circuit, which was connected across the high-voltage switching waveform.  The two, much bigger capacitors are two 0.047 microFarad, 400 V rated, capacitors which I have connected in parallel to get a 2 * 0.047 micro-Farads = 0.094 micro-Farads which are well within the 20 percent tolerance to the required value of 0.1 micro-Farads.

    I soldered the 0.094 micro-Farad, 400 V assembly in place of the well under-rated small capacitor,  and plugged the Diablotek PHD 450 power supply in.  I turned its power on and the the output of  the 5 V, 2 A STANDBY power supply circuit with its 47 Ohm power drain resistor (between + 5 V and circuit ground) instantly jumped to the specified +5.06 Volts.

    This small capacitor may also have been the cause of the failure of the old 120 GB, SATA disk drive I have had in the computer as that disk drive have had been only connected to the computer power supply and to nothing else.  It was just powered with the rest of the computer, but there was (and could be) no disk access.  Intermittent insulation failures in this capacitor can place sharp spikes on the higher current power supplies in the Diablotek PHD 450 which are controlled by its 5 V, 2 A STANDBY power supply with the bad capacitor, and those spikes, in turn, can force the disk drive electronics to RESET, causing random head retractions at arbitrary intervals, which damage the disk drive eventually, making it "click" somewhat regularly during all that time...

    -- Yekta


    • Edited by Yekta_Gursel Friday, February 15, 2013 7:54 PM Typographical error fix.
    Friday, February 15, 2013 7:51 PM
  • I have completely fixed the Diablotek PHD 450 computer power supply.  It is in its enclosure, producing all of the voltages it is supposed to produce once again. 

    Here is a summary of what I have done:

    1) In my message dated Tuesday, February 5, 2013, 5:13 AM, I presented a directly traced schematic of the input part of the Diablotek PHD 450 power supply.  In that schematic, I have shown a magnetically coupled, isolation transformer feeding the Bridge rectifier of the input linear power supply.  Although this is the best way to isolate the actual power supply, the Diablotek PHD 450 does not use a magnetically coupled, isolation transformer.  It has another, but this time non-toroidal, input filter transformer feeding the bridge rectifier.  This arrangement does not supply any isolation from the line in the input linear power supply, but results in a smaller filter-transformer element.  Below is the corrected schematic that shows  this bug/feature in the Diablotek PHD 450 power supply which is by no means unique to this power supply.

    2) The HP-type line cord receptacle and the ON/OFF switch on this power supply are made out of a low-melting point plastic.  The leads to these components were nevertheless soldered by the manufacturer, which was contrary to the common use of low melting point plastic receptacles and switches.  In these cases, only female quick-slide connectors are used on the wires that are to be connected to these components.  The quick-slide connectors are attached to the wires by either crimping or soldering, then the connection is established by pushing these female connectors on the male tabs of these low-melting point plastic receptacles and switches.  This way no heat damage ever occurs.  Otherwise, connection tabs come loose even when unsoldering wires from these receptacles and connectors.  I converted all of these kind of connections to quick-slide connections in the input AC wiring of the Diablotek PHD 450 power supply.

    3) The case ground connection (the Earth ground connection, the safety lead in the case of AC power shorting into exposed metal parts of the computer) in the Diablotek PHD 450 power supply is made in an indirect way.  A soldered wire to the Earth ground connection in the input power receptacle goes to an isolated pad on the printed circuit board of the Diablotek PHD 450 power supply.  This pad is then pressed on to the metal case of the power supply by one of the circuit board bolt-down screws.   This wire should be directly bolted to the metal case of the Diablotek PHD 450 power supply.  A separate, threaded bolt hole is even supplied for this purpose by the manufacturer, but it was never used by them.  I connected the Earth ground connection of the AC receptacle (Labeled E on the power cord) directly to this bolt hole, by a properly colored and current rated wire with a quick-slide on one end for the AC receptacle and with round-hole connector at the other end.

    4) There is another bolt-down pad on the printed circuit board of the Diablotek PHD 450 power supply which is only connected to the DC power ground of the computer.  This pad was kept from touching the power supply case by a black-painted, circular piece of paper which was nearly pierced by the protruding leads of the components on the printed circuit board.  I made a thicker plastic insulator, out of a 2 liter soda bottle plastic material, and installed in place of the thin piece of painted paper.

    5) The 250 V 8 A slow-blow fuse, and the RTC thermal fuse in the Diablotek PHD 450 power supply is directly soldered to the printed circuit board and it is placed after the input filter and the ON/OFF switch as shown by my schematic.  I mounted an externally accessible fuse holder on the power supply case, placed between the  AC receptacle and the line voltage selector switch and wired this fuse holder and the RTC thermal fuse directly onto the N (the high-voltage, 125 V AC at potentially 15 Amperes) lead of the AC receptacle.  The fuse can now be replaced without removing the power supply from the computer and without opening its case.

    6) The AC line, 125 V, 8A, Single-pole, single throw (SPST), rocker,  ON/OFF switch was placed on the L (Neutral lead, nearly at Earth ground potential) lead of the AC line, which left 125 AC voltage all over the printed circuit board of the Diablotek PHD 450 power supply, even when the switch was turned off.  This switch should at  least be placed on the N lead.  I happened to have a 125 V, 8 A,  Double-pole, Single throw (DPST), rocker, ON/OFF switch which fit exactly in place of the original switch.  That one was from a very old power supply, but one can get one from Radio Shack for less than $3.50 at the present time.  This switch cuts off both the N, and the L leads of the AC line.

    7) All of the other components are moved to the printed circuit board, after the fuse and after the switch connections.  The components that can move a little has been fixed in place with a high-temperature, silicon rubber glue.

    Note that, for everything to work fine, the house wiring itself has to be correct, free of any lead reversals.  I had made sure of that by using several AC line debuggers.  One such very useful, small  item is Sperry Instruments, "CORRECT" house wiring checker/indicator, readily available at Home Depot.  They might have other brands with  the same functionality as well.

    The picture below shows my new input wiring of the Diablotek PHD 450 computer power supply:

    8) I replaced the 0.12 Ohm resistor that was in direct parallel connection with the 5V supply current limit and sense resistor (1.2 Ohms) of the Diablotek PHD 450 power supply with another 1.2 Ohm resistor with the same power dissipation capacity, restoring the current sense function.  I might fully load the power supply to optimize this resistor value later.

    9) And finally, I replaced the 0.1 micro-Farad, non-high-voltage rated ceramic capacitor which was in the high-voltage switching circuit of the 5 V 2 A STANDBY power supply of the Diablotek PHD 450 power supply.  This was the capacitor that had been breaking down under high-voltage, bringing the entire power supply down.    I put a same value, high-voltage rated capacitor assembly in its place.  You can use two in parallel of Radio Shack Catalog #55046814, MLR503K630, 0.05 micro-Farads, 630 V capacitors.  They are $1.29 + tax each.

    The Diablotek PHD 450 power supply now works once again, and this time it is correctly wired...

    -- Yekta

    Tuesday, February 19, 2013 2:15 AM
  • The best backup software I have seen is the Acronis True Image software which lets one restore even the boot disk without any loss.  The disk drive manufacturers (Western Digital or Maxtor, for example) have versions of this software for their disk drives available free of charge in their web sites.  These versions do work for other disk drives as well, should one have at least one drive manufactured by the companies above in the system.

    I always backup the entire system before any foreseen major change, and I did really test the power supply after I completely fixed it.

    Here is the real picture of a problem I have mentioned in my messages above:  The line cord female plug for the standard computer power supplies (Hewlett-Packard or the IEC version of it) has a labeling on it which is, not any "intuitively obvious".  In fact, it looks like plain reverse labeling. 

    The picture below shows the plugs at both ends of the molded connector line cord with the cord bundled under them:

    The male plug below is the standard U.S.A. 3-wire AC line cord plug.  The big, and round pin on it is the Earth ground connection.  As you are looking at the picture above, the flat pin to the right of the big, round pin on this plug is the Neutral connection to the AC line, which is identified by the larger flat slot on the wall socket this standard U.S.A. 3-wire line cord plugs into.  Again, as you are looking at the picture above, the flat pin to the left of the big, and round pin is the Hot (125 V AC at 15 Amperes) Line connection to the AC line, which is identified by the smaller flat slot on the wall socket this standard U.S.A. 3-wire line cord plugs into.

    The female plug  above is the Hewlett-Packard or IEC type plug that connects to the computer power supply.  As you are looking at the picture above, the top-most rectangular slot  that is also in the middle of the three-slot arrangement is the Earth ground connection.  Should one connect an Ohmmeter between the big-and-round pin of the standard U.S.A. 3-wire AC line cord plug below and the top-most rectangular slot that is also in the middle of the 3-slot arrangement of the HP (or IEC)   plug, the Ohmmeter will definitely read zero indicating a full connection. 

    Again,  as you are looking at the picture above, should one connect an Ohmmeter between  the flat pin to the right of the big-and-round  pin on the standard U.S.A. 3-wire line cord plug below (the "Neutral" connection to the AC line) and the rectangular slot to the right of the top-most rectangular slot which is also in the middle of the 3-slot arrangement of the HP (or IEC) plug above, the Ohmmeter will definitely read zero indicating a full connection.  But, this slot is labeled with an "L" on the HP (or IEC ) plug, as if it were to be a "Line" connection.

    One more time:  As you are looking at the picture above, should one connect an Ohmmeter between  the flat pin to the left of the big-and-round  pin on the standard U.S.A. 3-wire line cord plug below (the "Line" or "Hot" connection to the AC line, 125 Volts AC at 15 Amperes) and the rectangular slot to the left of the top-most rectangular slot which is also in the middle of the 3-slot arrangement of the HP (or IEC) plug above, the Ohmmeter will definitely read zero indicating a full connection.  But, this slot is labeled with an "N" on the HP (or IEC) plug, as if it were to be a "Neutral" connection.

    Every line cord I have for computer power supplies are labeled as shown above, and I wonder why...

    -- Yekta


    • Edited by Yekta_Gursel Tuesday, February 19, 2013 2:52 PM Tyographical error fix.
    Tuesday, February 19, 2013 2:52 PM
  • Did you verify by actually measuring that "N is neutral, L is line, E is earth ground"?  On the ready-made with  molded plugs cable I show in the picture, that is not the case.

    -- Yekta

    Wednesday, February 20, 2013 2:00 AM
  • Here is the U.S.A. standard 3-wire, 125 V, 15 A, AC cord plug (the very same one as the one in my previous messages) as it plugs into the U.S.A. standard 3-wire, 125 V, 15 A outlet.  Note the taller flat slot on the outlet which is always wired to the Neutral side of the AC line in the U.S.A.

    -- Yekta

    Wednesday, February 20, 2013 5:34 PM
  • Today, I put in the now-fixed Diablotek PHD 450 power supply into the computer. 

    As I had indicated before, I had raised the value of one resistor (0.12 Ohms in parallel with 1.2 Ohms) in the 5V 2A STANDBY power circuit to 1.2 Ohms for testing and optimizing reasons.  The voltage drop across this resistor pair is the current sense signal which controls the current limit of the entire power supply.  With the motherboard held at RESET (I have a toggle switch in parallel with the normally open momentary contact RESET switch on the computer case), the motherboard and the power supply came up and indicated very stable and very quiet (far less noisy than those before the fix) voltages.  I then took the motherboard off the reset, to enable the computer to boot, and to load the power supply as all disks and other active peripherals were fully turned on at this time.

    As I had expected, the six times higher value (0.6 Ohms vs. 0.11 Ohms) of the resistor pair caused a net reading of current which registered six times higher and the power supply current limit activated, safely halting the boot shortly after the start.  This verified that the power supply and its protection circuits were fully functional.

    I then restored the total resistor value to 0.11 Ohms and re-located the 0.12 Ohm resistor off the printed circuit board up near the top of the heat sinks right in front of the power supply fan.  As I have had explained before, this is the highest power dissipating resistor in the power supply and it was packed away from the air flow behind the linear power supply capacitors (which, by the way, are rated at 105 degrees Celcius maximum temperature in the power supply, instead of the regular 85 degrees Celcius maximum temperature capacitors) near the bottom of the hot heat sinks.  Note that power supply does not need two resistors in parallel with values differing by a factor of 10.  It just needs one resistor with the correct value (0.12 Ohms or so).  I do not know why the manufacturer have done this, as it will not increase the power handling of the pair by more than 10 percent.

    I put everything back together as I had described before and I put the power supply back into the computer.  It came up very nicely.  The power is no longer wishy-washy, with rock-stable voltage levels.  The noise on the voltages went down by nearly a factor of 10.  This noise is very evident during shutdown through the stereo system I have connected to the computer.  It became so low, that I thought I had turned the volume control down.  It was all the way up.

    I then typed this message in...

    -- Yekta

    Sunday, February 24, 2013 7:15 AM
  • About the IEC (HP type) female plug to U.S.A. standard 3-wire male plug computer power supply cords:

    The only backward brand (the line and the neutral are interchanged) I have found so far, is the "SHENGYI" brand power supply cords.  They came with the last two power supplies I had bought, and one of those is the "Diablotek" power supply.   I went around the house, and I measured the "YUNG LI", "NANAI", "KING CORD", "FOX CONN", "YOUZHI DIANXIAN", etc. brands.  All of the latter are correctly wired as labeled on the IEC side, except the"SHENGYI" brand.

    One has to measure these cords before plugging them into one's equipment...

    -- Yekta

    Friday, March 15, 2013 12:48 AM
  • I measured all of the power cords of the type I mentioned above in my house.  Here are rest of the correctly wired brands of cable: "AWIN", "SHIH YANG", "I-SHENG", "SANGLE", "UL" (with a dot under the letters UL), "COXOC", "YU CHOU", "CHI CHO", "S.S. HI-TECH", "LONG HUI", and the only U.S.A. made one: "ElectriCord" in script letters, followed by "WESTFIELD, PA".

    Again, the only the-line-and-the-neutral-interchanged contrary-to-its-own-labeling brand of cable is "SHENGYI".

    -- Yekta

    Friday, March 15, 2013 4:11 AM
  • As I have noted above, the repaired power supply is performing exceptionally well.

    I noticed that my wireless phone battery lasted much longer when it was trickle-charged slowly through an USB outlet attached to the computer with the repaired power supply.  So, I decided to make a USB current-limited charger-adapter that ran off my motorcycle's electrical system when the ignition key is turned on.  This way, I might be able to use the phone's other features more often, like the camera and the network access, without limiting the wireless phone capability.

    I designed and built an excellent, spike-supressed, and multi-stage filtered, precision 7.5 V to 18 V input and 5.0 V output converter with a multi-stage LED display, and USB output socket.  The converter works very well.  I had decided to install a "12 V POWER OUTLET", identical to those used in automobiles, into my motorcycle, and I had bought the BELL 12 V POWER OUTLET from the local "Pep Boys" automotive parts store.  "Pep Boys" does not list this unit on their web page anymore, but Amazon still carries it (Part # Bell Automotive 22-1-39052-8).

    The problem arose this morning as I was wiring the plug interface to the BELL 12 V POWER OUTLET, as illustrated in the multi-part picture below:

    The upper-left quadrant in the picture above, shows the BELL 12V POWER OUTLET and a selection of standard plugs I have at home for it.  These plugs were  for various electronic devices that were to be powered through the "standard" BELL 12 V POWER OUTLET.  

    I first noticed that all of the plugs did cause a short at the power outlet by shorting the outer tube of the outlet to the central tab in the outlet when they were moved sideways by some slight amount and the outer tube had a large-enough diameter to allow this sideways motion.   This seemed impossible, until I directly  looked into the  Bell 12 V POWER OUTLET.

    The upper-right quadrant in the picture above is the view into the Bell 12 V POWER OUTLET.  Note that the outer tube reaches the end of travel near the plane of the central tab, and then it is continuously bent in to form a narrow ring around the central tab.  As originally bought, the central tab was also bent out of plane in a tilt toward the camera.  In this configuration, the central pin of all of the plugs slid readily on the tab when the plug moved sideways and filled the insulating gap between the tab and the edge of the circle formed by the outer tube, causing an uncontrolled short at the power outlet.  The plug does contain a fuse internally, but this fuse behind the central pin and it is not in the short-circuit to protect anything.

    I decided to push the central tab in, in the Bell 12 V POWER OUTLET to make it flat, so that there was more room between the central tab and the edge of the ring formed by the outer tube.  This action made two of the six plugs work almost perfectly, although one could still make them cause a short especially during plugging in, should a little too much force was used.  These two plugs are shown in the upper-left quadrant in the picture above, placed to the left of the BELL 12 V POWER OUTLET.

    The rest of the plugs still shorted with lesser effort:  The first two of the four plugs, from left to right, to the right of the Bell 12 V POWER OUTLET caused a short upon plugging them in with no effort.  The difference between these two and the two to the left of the BELL 12 V POWER OUTLET is the conical or stepped, thick metal sleeve around the central pin, on the plugs to the right of the BELL 12 V POWER OUTLET.  The plugs to the left have plastic sleeves instead.  This electrically conducting, metal sleeve which is in contact with the central pin, fills the narrow gap between the central tab and the outer tube ring readily upon pressing the plug in, and causes a short circuit as described above.

    The third plug, from left to right, to the right of the Bell 12 V POWER OUTLET, has a plastic sleeve, but the tip of its pin is made significantly wider than the body of its pin and the edge of this wide, pancaked tip fills the narrow gap between the central tab and the outer tube ring with some sideways motion (readily supplied by the spring loaded cover of the Bell 12 V POWER OUTLET), causing an immediate short.

    The last plug, from left to right, to the right of the Bell 12 V POWER OUTLET has a plastic sleeve at the tip, but a metal ring just behind it with a somewhat longer central pin.  Of the four plugs to the right of the BELL 12 V POWER OUTLET, this one offered the most resistance to a short, but it still did it with some more effort.

    I I took the Bell 12 V POWER OUTLET apart, to machine the ring at the bottom of the outer tube to a larger diameter.  The lower left quadrant in the picture above shows the BELL 12 V POWER OUTLET housing, its outer tube and the outer tube connection tab which slides between the inner wall of plastic housing and the outer wall of the tube to supply electrical connection to the tube.  The hole at the bottom of the tube can only be enlarged to the edge of the kink in the tab.

    The lower right quadrant in the picture above shows a properly made 12 V POWER OUTLET mounted into a transformer power supply.  Note that the entire bottom of the outer tube is not made out of metal.  It is an insulating, orange colored plastic, and there is no narrow gap between the outer tube and the central round tab.  The central round tab rises above the bottom, toward the camera, and it is made in the form of a cup which captures the central pin of the plug.  In addition, the inner diameter of the outer tube (0.838 inches) in this latter outlet is 18 mils (0.018 inches) smaller than the inner diameter of the outer tube of the Bell 12 V POWER OUTLET (0.856 inches), allowing no sideways motion to cause a short.  This latter outlet does work with all six types of plugs shown above with no effort.  Unfortunately, I could not find one of these nice outlets.  I will machine the Bell 12 V POWER OUTLET and make it work with the entirely plastic sleeve plugs shown above.

    I looked around the web and found ready made, "designer" USB adapters (with less filtering and regulation than those in mine, probably), all with entirely metal sleeves, obviously designed to reduce wear and tear, as shown below:

    These will cause an instant short, should anyone plug them in to a BELL 12 V POWER OUTLET without machining the Bell 12 V POWER OUTLET first.

    -- Yekta

    Wednesday, April 10, 2013 12:26 AM
  • I want to see a 5000 W charger.

    --
    .
    --
    "Vegan Fanatic" wrote in message news:81d943fd-5b8e-4128-bdf4-6603bb893d58...

    I have a USB charger for the US/Canada grid market, charges up my apple product faster as it has more current.

    There are also inverters for use in a motor vehicle that are useful. The bigger 5000 W models need to be connected to the battery.


    Windows MVP, XP, Vista, 7 and 8. More people have climbed Everest than having 3 MVP's on the wall.

    Hardcore Games, Legendary is the only Way to Play

    Developer | Windows IT | Chess | Economics | Vegan Advocate | PC Reviews


    David Candy
    Wednesday, April 10, 2013 8:44 AM
  • I fixed the Bell 12 V POWER OUTLET shorting problem.  The multi-part picture below shows the parts that are modified to remove the short and the re-assembled product.

    I enlarged the hole at the bottom of  the outer tube to its maximum extent.  I then re-assembled the BELL 12 V POWER OUTLET  using high-temperature silicon glue (orange compound) to bond the outer tube to the inner wall of the BELL 12 V POWER OUTLET and also to seal all of the small holes and the wiring gaps in the BELL 12 V POWER OUTLET to make it water-proof when its lid is closed.  I also put a silicon rubber buffer between the central tab and the re-machined edges of the outer tube.

    The Bell 12 V POWER OUTLET now works will all of the plugs I have mentioned in my previous message, without any shorts.

    -- Yekta

    Wednesday, April 10, 2013 9:58 PM
  • I was designing and building some electronics hardware I needed for some repairs during the last two weeks.  I decided to make a complete cable tester for the IEC power cords at the same time, as this would not take much time to accomplish with the set-up I had.

    The multi-part picture below shows the versatile IEC cord tester with its three components, its self-testing features and the schematic of its custom-made components:

    The upper-left picture in the multi-part picture above shows the components of the versatile, three component IEC and standard extension-power-cord tester, from left to right: The IEC socket to standard 3-wire, 125 V 15 A socket adapter, 125 V line wiring tester, and the low-voltage cable internal short and polarity switch tester.

    As shown, the IEC and the standard extension cord tester will analyze and display the conditions listed below:

    (1) Line (L) shorted to Neutral (N) between the two ends of the cable, {Low-voltage tester}

    (2) Line (L) shorted to Ground (E) between the two ends of the cable, {Low-voltage tester}

    (3) Neutral (N) shorted to Ground (E) between the two ends of the cable, {Low-voltage tester}

    (4) Line (L) switched with Neutral (N) between the two ends of the cable, {Low-voltage tester} or {Line-voltage tester}

    (5) Line (L) switched with Ground (E) between the two ends of the cable, {Low-voltage tester} or {Line-voltage tester}

    (6) Neutral (N) switched with Ground (E) between the two ends of the cable, {Low-voltage tester}

    (7) Line (L) not connected between the two ends of the cable, {Line-voltage tester}

    (8) Neutral (N) not connected between the two ends of the cable, {Line-voltage tester}

    (9) Ground (E) not connected between the two ends of the cable, {Line-voltage tester}

    (10) Any internal intermittent cable problem involving the conditions (1) through (9) above, {Low-voltage tester} or {Line-voltage tester}

    (11) The cable, as constructed is fine.

    You cannot vote on your own post(12) Line (L) has bad (high-resistance) connection between the two ends of the cable, {Low-voltage tester}

    (13) Neutral (N) has bad (high-resistance) connection between the two ends of the cable, {Low-voltage tester}

    (14) Ground (E) has bad (high-resistance) connection between the two ends of the cable, {Low-voltage tester}

    The bottom-left picture shows the battery and lamp test configuration of the low-voltage tester:  A clip lead is connected between the Ground (E) and Neutral (N) pins of the standard 125 V 15 A male plug on the low-voltage tester.  Both of the LED's light-up when the batteries are fresh (9 V) and the LED's are functional (20 mA DC current flow at 9 V, LED's will turn on until the battery voltage is down to nearly 2 Volts, dimming as the voltage drops). 

    The middle-left picture shows the internal wiring self-test and storage configuration of the low-voltage tester.  LED's will not light up when the internal wiring has no problems, and no current will flow through the tester in this configuration.  As a result, the low-voltage tester does not need an on/off switch which improves its reliability.  Note that the low-voltage tester is ALWAYS used by itself or with the IEC socket to the standard  125 V 15 A socket adapter in the loop-mode (explained below) only.  It is NEVER plugged in into a live wall socket.

    The center-right picture shows the schematics of the IEC socket to standard 125 V 15 A socket adapter and the low-voltage tester.

    The multi-part picture below shows the IEC and the standard extension cord tester testing a SHENGYI IEC power cable with an internal Line (L) and Neutral (N) switched, and a NANAI IEC power cable with no faults.

    The upper-left picture shows the SHENGYI cable plugged into the low-voltage tester. This is always the first test performed as it will detect all internal shorts. The LED's do not light up even when the cable is bent and wiggled, indicating that the cable has no permanent or intermittent internal shorts. One can now proceed with other tests.  Should a short is indicated, the short is fixed first before proceeding with other tests.  Alternatively, one should use another cable in this case.

    The upper-middle picture shows the SHENGYI cable plugged into the low-voltage tester and the IEC socket to the standard 125 V 15 A socket adapter, with the low-voltage tester also plugged into the socket adapter, forming the test loop.  Any internal polarity switch will induce a short in the loop and one or both LEDs will light up indicating what is switched. The LED near the edge of the BLACK box in the low-voltage tester is LIT, indicating a Line (L) switched with Neutral (N).  This condition can also be tested at line voltage (recommended in case something is intermittent).

    The upper-right picture shows the line-voltage test of the SHENGYI cable.  In this test, the SPERRY "CORRECT" line tester is plugged into the 125 V 15 A socket of the IEC socket to standard socket adapter, and the IEC cable is plugged into the IEC socket of the same adapter.  Now, and only now, the standard 125 V 10 A male plug end of the IEC power cord is plugged into an active 125 V 15 A wall socket.  As indicated, the SHENGYI cable has no open connections inside, but the Line (L) is still switched with Neutral (N) at the operating voltage, as indicated on the SPERRY "CORRECT" indicator on the socket adapter box.  This completes the IEC power cord test.

    The lower picture sequence shows the same tests performed in the same order on the NANAI cable.  In the lower-left and lower-middle pictures no LED's are lit which indicates the lack of shorts or polarity switches in this cable.  The lower-right picture shows the SPERRY "CORRECT" indicator showing "CABLE OK" in the line-voltage test configuration.

    Note that one can use the IEC and the standard extension cord tester to test standard extension cords and outlet strips as well.  This only requires one known-good IEC power cord (as verified by the tester before).  In this case the test standard extension cord or outlet strip is connected between the socket adapter and the low-voltage tester in the loop mode and between the socket adapter and the SPERRY "CORRECT" indicator in the line-voltage test mode, with everything else as described before.

    Note also that the IEC and the standard extension cord tester can also test connection resistance between the ends of a correctly made IEC power cable or a correctly made standard extension cord.  To do this, for an IEC power cable for example, connect the low-voltage tester to the socket adapter and then connect the IEC cable to the socket adapter.  LED's will not light up as there are no shorts or polarity switches for a correctly made cable.  Now, use a clip lead to connect pairs of pins (L, N, E) on the standard 125 V 10 A  male end plug of the IEC cord. One or both of the LED's will light up.  Should any of these pairs have significant resistance, the intensity of the lit LEDs will be dimmer as compared to that in the battery and lamp test performed first.  One also has to connect all pairs in the battery and lamp test performed before to note the intensities in all cases.  Also make sure that the clip lead is well made, but this is easily checked visually as the plastic cover on the clips slide back to reveal the connections fully.

    Another note:  Somehow the forum has not been displaying this entire thread for the last two days.  It always leaves some pictures out.  I do not know what causes this.  I tested the two available "JAVA" versions, and that was apparently not the problem.  The problem seems to be with  the Microsoft server.  Let me know, should you not see a picture described in the text.  I can send you those separately.

    -- Yekta



    • Edited by Yekta_Gursel Saturday, April 20, 2013 5:00 AM Omitted words ("connection") added.
    Friday, April 19, 2013 8:57 PM