none
MDT 2013 Update 1, Win 10 Pro x64, LTIApply returns non-zero code -2147024809 0x80070057 RRS feed

  • Question

  • Hello,

    I'm attempting to automate the Win 10 upgrade process on a lab PC. The PC has been built from a Win 7 Pro x64 image (domain joined, but not activated), and then I have attempted to run the LiteTouch.vbs script from the deployment share scripts folder to update this to Win 10.

    The deployment fails silently, but the BDD log reports (last part):

    <![LOG[LTICopyScripts processing completed successfully.]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTICopyScripts" context="" type="1" thread="" file="LTICopyScripts">
    <![LOG[Property SourcePath is now = \\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[LTI upgrade OS using  \\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[New ZTIDiskPartition : \\W10-UPG-TEST\root\cimv2:Win32_LogicalDisk.DeviceID="C:"    \\W10-UPG-TEST\root\cimv2:Win32_DiskPartition.DeviceID="Disk #0, Partition #1"]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Upgrading from \\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64\setup.exe using command: "\\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64\setup.exe" /auto Upgrade /Quiet /NoReboot /PostOobe C:\MININT\Scripts\SetupComplete.cmd /PostRollback C:\MININT\Scripts\SetupRollback.cmd /DynamicUpdate Disable /ImageIndex 1]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[About to run command: "\\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64\setup.exe" /auto Upgrade /Quiet /NoReboot /PostOobe C:\MININT\Scripts\SetupComplete.cmd /PostRollback C:\MININT\Scripts\SetupRollback.cmd /DynamicUpdate Disable /ImageIndex 1]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Command has been started (process ID 3852)]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[ZTI Heartbeat: command has been running for 0 minutes (process ID 3852)]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Return code from command = -2147024809]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Setup failed to upgrade OS from  \\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64\setup.exe, rc = -2147024809]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="3" thread="" file="LTIApply">
    <![LOG[Requesting reboot for setup.exe to complete Upgrade action]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Property SMSTSRebootRequested is now = true]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[ZTI ERROR - Non-zero return code by LTIApply, rc = -2147024809  0x80070057]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="3" thread="" file="LTIApply">
    <![LOG[Command completed, return code = -2147467259]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LiteTouch" context="" type="1" thread="" file="LiteTouch">

    The LTIapply log is as follows:

    ![LOG[Microsoft Deployment Toolkit version: 6.3.8298.1000]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[The task sequencer log is located at C:\Users\ADMINI~1.W10\AppData\Local\Temp\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Will boot into Windows PE architecture x64 to match OS being deployed.]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[TargetOS is the current SystemDrive]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[ Open Control File: OperatingSystems]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[------  Upgrading Windows  ------]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Verify we have necessary files locally, if not, copy it]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Property SourcePath is now = \\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[LTI upgrade OS using  \\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64]LOG]!><time="13:01:53.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[New ZTIDiskPartition : \\W10-UPG-TEST\root\cimv2:Win32_LogicalDisk.DeviceID="C:"    \\W10-UPG-TEST\root\cimv2:Win32_DiskPartition.DeviceID="Disk #0, Partition #1"]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Upgrading from \\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64\setup.exe using command: "\\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64\setup.exe" /auto Upgrade /Quiet /NoReboot /PostOobe C:\MININT\Scripts\SetupComplete.cmd /PostRollback C:\MININT\Scripts\SetupRollback.cmd /DynamicUpdate Disable /ImageIndex 1]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[About to run command: "\\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64\setup.exe" /auto Upgrade /Quiet /NoReboot /PostOobe C:\MININT\Scripts\SetupComplete.cmd /PostRollback C:\MININT\Scripts\SetupRollback.cmd /DynamicUpdate Disable /ImageIndex 1]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Command has been started (process ID 3852)]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[ZTI Heartbeat: command has been running for 0 minutes (process ID 3852)]LOG]!><time="13:01:54.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Return code from command = -2147024809]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Setup failed to upgrade OS from  \\ALPHA\DeploymentShare$\Operating Systems\Windows 10 Pro x64\setup.exe, rc = -2147024809]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="3" thread="" file="LTIApply">
    <![LOG[Requesting reboot for setup.exe to complete Upgrade action]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[Property SMSTSRebootRequested is now = true]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="1" thread="" file="LTIApply">
    <![LOG[ZTI ERROR - Non-zero return code by LTIApply, rc = -2147024809  0x80070057]LOG]!><time="13:03:48.000+000" date="09-23-2015" component="LTIApply" context="" type="3" thread="" file="LTIApply">

    Is there anywhere that gives a list of the LTIApply return codes and their meaning? This seems to be the only indication that gives any useful information.

    Wednesday, September 23, 2015 1:04 PM

Answers

  • You can't upgrade a non activated PC.  Windows 10 doesn't seem to like that and I suspect it is by design.

    Most important details are logs. If you are unsure how to post logs or where to find them then reference https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/

    Wednesday, September 23, 2015 5:47 PM
    Moderator

All replies

  • You can't upgrade a non activated PC.  Windows 10 doesn't seem to like that and I suspect it is by design.

    Most important details are logs. If you are unsure how to post logs or where to find them then reference https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/

    Wednesday, September 23, 2015 5:47 PM
    Moderator
  • Thanks Ty, I had wondered if it might be related to that. I shall find an activated Win 7 machine and run it against that.

    Update: Yes, that fixed it (ran it against an activated OEM Windows 7 Pro).

    I also had to add the WindowsUpgradeAdditionalOptions=/compat IgnoreWarning to the customsettings.ini file, as per one of the other related questions on the left.

    After that it deployed properly.

    • Edited by EasyBob_UK Thursday, September 24, 2015 1:54 PM
    Thursday, September 24, 2015 8:42 AM