none
DPM 2016 Could not find a suitable storage with enough free space ID: 33510 RRS feed

  • Question

  • Error come when creating new protection group. I have tried 2 virtual servers, one with SQL 2014, one with SQL 2016. I have tried several disk setups, vhdx file, physical disk and iSCSI disk. I have 99% free space in DPM Storage Pool Disks (Microsoft Virtual Disk). odd thing is that disk is unallocated in windows disk management. I have used 2012R2 for several years.
    Friday, October 14, 2016 9:56 PM

Answers

  • Hi

    DPM 2016 running on a Windows 2016 server only support the new DPM Modern Storage feature which uses ReFs formatted volumes instead of disks.  The volume(s) must not reside on a Windows Dynamic Disks, just a basic disk which should be GPT if the disk is 2TB or larger.  Add the volume(s) to the DPM storage pool, then protection can succeed.

    See Add Storage to DPM 2016 (fixed link)


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Monday, October 17, 2016 6:04 PM
    Moderator

All replies

  • I have the same issue on 2 different installations
    • Proposed as answer by Luigi Devoto Friday, April 28, 2017 10:10 AM
    Saturday, October 15, 2016 11:14 AM
  • I am seeing the very same issue with DPM 2016 (with Update Rollup 1 for System Center 2016) on Windows Server 2016. I have a 12 TB volume mounted through iSCSI, and it is totally empty. After deleting the volume and remounting it through DPM, I see it has 99 % free space but it still fails and complains about missing disk space.

    The exact same setup worked with DPM 2012 R2, so there is something fishy here with how DPM 2016 recognizes the storage.

    Saturday, October 15, 2016 5:15 PM
  • Yes, indeed :-/. I also tried before adding rollup 1, same problem.
    Sunday, October 16, 2016 4:41 AM
  • I rebuilt the whole thing using GA-bits from MSDN for both Windows Server 2016 and DPM 2016 (with Rollup 1), but this time mounting the disk through iSCSI from Hyper-V host server, in hopes that things would look different for DPM. It's still the same: I see 100 % disk space is available for disk-based backups (through DPM-settings and Disk Management utility in Windows). Using PowerShell to create a new protection group also gives an error of insufficient disk space.

    Sunday, October 16, 2016 9:09 AM
  • Deleted
    Sunday, October 16, 2016 5:35 PM
  • Hi

    DPM 2016 running on a Windows 2016 server only support the new DPM Modern Storage feature which uses ReFs formatted volumes instead of disks.  The volume(s) must not reside on a Windows Dynamic Disks, just a basic disk which should be GPT if the disk is 2TB or larger.  Add the volume(s) to the DPM storage pool, then protection can succeed.

    See Add Storage to DPM 2016 (fixed link)


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.


    Monday, October 17, 2016 6:04 PM
    Moderator
  • Thanks, the article greatly helps in understanding how the storage should be set up. It's confusing as DPM accepts the storage in Dynamic Disks, and it would help if the wizard would advice against this.

    And just to clarify on this, the proposed approach works and my DPM 2016 on Windows Server 2016 works using storage through iSCSI formatted as ReFS.

    Tuesday, October 18, 2016 6:33 AM
  • Thanks very much :-))).
    Wednesday, October 19, 2016 5:57 PM
  • The link provided does not work. I have formatted the disks as ReFs and added them all to the pool. They show up as healthy and unused. Over 100TB of disks available. When I go to create a protection group, it says there is no suitable storage available. I have no options to change anything on these disks that would allow me to try variables, so I suspect something is wrong with DPM. 2012 R2 works just fine and, while I get that it now requires ReFs, I have done exactly that. Since your link doesn't work, I'm not sure how leverage this answer.
    Tuesday, June 27, 2017 7:18 PM
  • HI,

    I updated the link - can you tell me what operating system DPM 2016 is installed on and attach a screen shot of the DPM storage pool.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, June 28, 2017 3:01 AM
    Moderator
  • Getting the same problem here, I can add the storage just not use it. DPM 2016 on Server 2016. At least I'm not the only one.

    Thursday, July 20, 2017 6:45 PM
  • Hi,

    DPM 2016 installed on Windows 2016 uses "volumes" for storage pool.  Please remove the disk from the storage pool, create a volume and add the volume to the storage pool.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Thursday, July 20, 2017 8:19 PM
    Moderator
  • I can confirm this works. Tnx a lot was searching for hours.
    Tuesday, September 26, 2017 11:44 AM
  • @Mike Jacquet

    I already have GPT disks, formatted with ReFS...

    Total disk space is 15 TB, out of which 13.5 TB is free..

    already backing up AD and Exchange in the same drive

    now, when I am configuring another server it is giving me insufficient disk space error.


    Regards Gohar

    Sunday, March 17, 2019 7:45 AM