locked
Service Manager Notifications RRS feed

  • Question

  • Hi,

    I followed the sample tutorial in

    https://technet.microsoft.com/en-us/library/hh519719(v=sc.12).aspx

    I configured Notification Channels

    I create notification templates

    I create subcribe to notifications

    Verify notification configuration

    But i don't receive email. How will i know what is the issue? Why email is not working.

    Did I miss something?

    Thank you


    Monday, March 5, 2018 1:47 PM

Answers

  • Hi

    I assume you are using an Exchange Server? 

    The error you are getting is from the Exchange Server rejecting the SMTP commands from the Service Manager Server. The Exchange Server is not accepting Anonymous connections, this is configured on the Receive Connectors in Exchange.

    I would probably change the Service Manager Notification Channel to "Windows Integrated" and put the password for the service manager workflow account in. 

    Or you could create a receive connector in Exchange that allows anonymous connections.

    Regards

    Glen


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    Monday, March 5, 2018 7:46 PM
  • Hi

    The problem is your Notification Channel. All the other steps are correct. In the guide that you followed it mentioned Windows Integrated connections to the SMTP server, but it used an anonymous example. 

    You have configured the notification channel to use anonymous connections when the SMTP server (in your case Office 365?) is expecting Windows Integrated connection.

    To allow a server from On-Prem to use Office 365 as a smtp server, have a look at this article. It talks about printers and MFD's, but it also applies to any application or server using the Office 356 service to send email.

    How to set up a multifunction device or application to send email using Office 365 

    If you do have an Exchange Server On-Prem (eg in a hybrid model) you might be able to use it as an SMTP server with Windows Integrated connection.

    I would create a new notification channel, rather than edit the existing one. Just a personal preference, it seems to be cleaner. And then delete the original one that is not working. 

    Regards

    Glen


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps


    • Edited by Glen.Xapity Tuesday, March 6, 2018 7:02 AM
    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:06 AM
    Tuesday, March 6, 2018 7:01 AM
  •  You have configured the notification channel to use anonymous connections when the SMTP server (in your case Office 365?) is expecting Windows Integrated connection. - I tried both Anoymous and Windows Integrated Connection but both saying error:

    The System Center Data Access service client failed to send a notification to the SMTP server at smtp.office365.com:XXX using the authentication method WindowsIntegrated.

    The System Center Data Access service client failed to send a notification to the SMTP server at smtp.office365.com:XXX using the authentication method Anonymous.

    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:06 AM
    Tuesday, March 6, 2018 7:10 AM
  • Hi

    Are you using the details from the link above:

    • smtp.office354.com
    • port 587 (port 25 shouold also work)
    • TLS
    • and does the workflow account have a mailbox in Office 365

    This is essentially a problem with Service Manager connecting to the Office 365 smtp server. Anonymous is not going to work, it will have to be windows integrated. Check the email address that you are using to send email from - make sure it is the same as what Office 365 has.

    Regards

    Glen



    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:06 AM
    Tuesday, March 6, 2018 7:26 AM
  • Hi

    I would talk to the Email administrator about this or to the Office 365 administrator. I think you will need their advice on how to configure this. 

    The TLS connection could be an issue, as Service Manager does not have an option to explicitly enable this. 

    The Windows Integrated option may not work or it at least it gets complicated as the Service Manager workflow account needs to be synced to Office 365 and needs to have a mailbox enabled in Office 365. 

    Looking at the options for SMTP from the link above, Option 3 should work. This could use an anonymous connection from SCSM, as it needs a connector configured in Office 365 with the static public IP address that the email would be coming from (assuming you are using NAT this will be the gateway address, rather than the SCSM server internal address) and the SPF record needs updating.

    I would also ask around to see if other applications are sending emails - see what SMTP server they use. You might find that there is already an internal SMTP server that could relay the email. 

    Regards

    Glen


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:05 AM
    Tuesday, March 6, 2018 9:11 AM

All replies

  • I check the event logs error and I found this:

    Event ID: 40000 
    Error: The System Center Data Access service client failed to send notification to all SMTP servers.

    Event ID: 40002
    Error: The System Center Data Access service client failed to send a notification to the SMTP server at XXXXXXXX using the authentication method Anonymous.

    Event ID:
    Error: The System Center Data Access service client failed to send a notification via the SMTP server: 
    XXXXXXXXXXXX
    Exception message:
    System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM [AM5PR0202CA0011.eurprd02.prod.outlook.com]
       at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
       at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, MailAddress from, Boolean allowUnicode)
       at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, SmtpFailedRecipientException& exception)
       at System.Net.Mail.SmtpClient.Send(MailMessage message)
       at Microsoft.EnterpriseManagement.NotificationManagement.SendNotifications(String from, IList`1 toList, IList`1 ccList, IList`1 bccList, String subject, String content, Int32 priority, Encoding encoding, Boolean isBodyHtml, Boolean isMulticast, Int32 protocol, String replyTo, String server, Int32 portNumber, String authentication)
       at Microsoft.EnterpriseManagement.NotificationManagement.SendInternal(IDictionary`2 ToAddress, NotificationMessage Message, String FromAddress, IDictionary`2 TokenValues)

    Monday, March 5, 2018 2:52 PM
  • Hi

    I assume you are using an Exchange Server? 

    The error you are getting is from the Exchange Server rejecting the SMTP commands from the Service Manager Server. The Exchange Server is not accepting Anonymous connections, this is configured on the Receive Connectors in Exchange.

    I would probably change the Service Manager Notification Channel to "Windows Integrated" and put the password for the service manager workflow account in. 

    Or you could create a receive connector in Exchange that allows anonymous connections.

    Regards

    Glen


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    Monday, March 5, 2018 7:46 PM
  • No Sir,

    Actually Exhange Connector is not created. We don't have exchange connector.

    But, we  import: Service Manager Inbound Email Configurations Management Pack.

    I only did is 

    https://technet.microsoft.com/en-us/library/hh519719(v=sc.12).aspx

    I configured Notification Channels - smtp office 365

    I create notification templates

    I create subcribe to notifications

    Verify notification configuration

    Thank you.

    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:06 AM
    • Unmarked as answer by newbee_scsm Tuesday, March 6, 2018 10:06 AM
    Tuesday, March 6, 2018 6:28 AM
  • Hi

    The problem is your Notification Channel. All the other steps are correct. In the guide that you followed it mentioned Windows Integrated connections to the SMTP server, but it used an anonymous example. 

    You have configured the notification channel to use anonymous connections when the SMTP server (in your case Office 365?) is expecting Windows Integrated connection.

    To allow a server from On-Prem to use Office 365 as a smtp server, have a look at this article. It talks about printers and MFD's, but it also applies to any application or server using the Office 356 service to send email.

    How to set up a multifunction device or application to send email using Office 365 

    If you do have an Exchange Server On-Prem (eg in a hybrid model) you might be able to use it as an SMTP server with Windows Integrated connection.

    I would create a new notification channel, rather than edit the existing one. Just a personal preference, it seems to be cleaner. And then delete the original one that is not working. 

    Regards

    Glen


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps


    • Edited by Glen.Xapity Tuesday, March 6, 2018 7:02 AM
    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:06 AM
    Tuesday, March 6, 2018 7:01 AM
  •  You have configured the notification channel to use anonymous connections when the SMTP server (in your case Office 365?) is expecting Windows Integrated connection. - I tried both Anoymous and Windows Integrated Connection but both saying error:

    The System Center Data Access service client failed to send a notification to the SMTP server at smtp.office365.com:XXX using the authentication method WindowsIntegrated.

    The System Center Data Access service client failed to send a notification to the SMTP server at smtp.office365.com:XXX using the authentication method Anonymous.

    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:06 AM
    Tuesday, March 6, 2018 7:10 AM
  • Hi

    Are you using the details from the link above:

    • smtp.office354.com
    • port 587 (port 25 shouold also work)
    • TLS
    • and does the workflow account have a mailbox in Office 365

    This is essentially a problem with Service Manager connecting to the Office 365 smtp server. Anonymous is not going to work, it will have to be windows integrated. Check the email address that you are using to send email from - make sure it is the same as what Office 365 has.

    Regards

    Glen



    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:06 AM
    Tuesday, March 6, 2018 7:26 AM
  • Are you using the details from the link above:

    • smtp.office354.com - smtp.office365.com
    • port 587 (port 25 shouold also work)
    • TLS - how will i know if we are using TLS?
    • and does the workflow account have a mailbox in Office 365 - how will I know this also? Sorry I'm not the administrator. No idea regarding this matter :(

    email address that you are using to send email from - make sure it is the same as what Office 365 has. - You mean the receiver email? As testing I used my company email which part of AD and i used in logging in mail office 365

    Tuesday, March 6, 2018 7:33 AM
  • Hi

    I would talk to the Email administrator about this or to the Office 365 administrator. I think you will need their advice on how to configure this. 

    The TLS connection could be an issue, as Service Manager does not have an option to explicitly enable this. 

    The Windows Integrated option may not work or it at least it gets complicated as the Service Manager workflow account needs to be synced to Office 365 and needs to have a mailbox enabled in Office 365. 

    Looking at the options for SMTP from the link above, Option 3 should work. This could use an anonymous connection from SCSM, as it needs a connector configured in Office 365 with the static public IP address that the email would be coming from (assuming you are using NAT this will be the gateway address, rather than the SCSM server internal address) and the SPF record needs updating.

    I would also ask around to see if other applications are sending emails - see what SMTP server they use. You might find that there is already an internal SMTP server that could relay the email. 

    Regards

    Glen


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    • Marked as answer by newbee_scsm Tuesday, March 6, 2018 10:05 AM
    Tuesday, March 6, 2018 9:11 AM
  • Thank you so much Sir.

    I will talk to our Email Administrator. Because I have no idea on this.

    Thank you.

    Tuesday, March 6, 2018 10:05 AM