none
server 2012 r2 ipv4 blue exclamation mark and replication problem RRS feed

  • Question

  • Hello all
    I have a server 2012 r2 run DHCP. i saw that ipv4 has blue exclamation mark. and also the scopes have blue exclamation mark (this is DC1) . i have another server that is replication of the 1st server (this is DC2).

    when i right click on the scope - properties - failover - "state of this server - Lost contact with partner" "state of partner server - Not available"

    restart both servers - didn't help

    ping from dc1 to dc2 - ping ok 

    ping from dc2 to dc1 - ping ok

    when i right click on ipv4 and choose "Configure failover" the window is empty.

    Please assist 

    Wednesday, October 10, 2018 6:32 AM

All replies

  • Hello,

    A blue exclamation mark normally means that no addresses are available from the server scopes because you have reached the maximum of addresses allocated for use or that there is a network related failure on the DHCP server.

    Check if "Reconcile" works on the scopes, right click on a Scope within the DHCP and click "Reconcile".

    This will manually initiate the DHCP database consistency check.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, October 10, 2018 7:16 AM
  • There is no problem of available addresses, in some scopes i even have 1 address... .

    When i do reconcile i get an empty window and then click verify and get - the database is consistent

    Any other options ?

    i think that the problem is with the failover ...that it says -  lost connection to server...


    Wednesday, October 10, 2018 10:50 AM
  • What do you see in your DHCP Event log on both DHCP servers?

    Applications and Services Logs\Microsoft\Windows\DHCP-Server\...

    I believe you will finsd most in the Admin log.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, October 10, 2018 10:56 AM
  • i checked the log - 

    i got this message - 

    The server detected that it is out of time synchronization with partner server: dc02.XXXXXXX.local for failover relationship: dc01.XXXXXXX.local-dc02.XXXXXXX.local.  The time is out of sync by: 107 seconds .

    i fixed the time to be the same in both servers.

    now i get this message - 

    A BINDING-ACK message with transaction id: 3 was sent for IP address: 10.80.9.16 with reject reason: (Outdated binding information) to partner server: dc02.XXXXXXXX.local for failover relationship: dc01.XXXXXXXXXX.local-dc02.XXXXXXXXX.local.

    Wednesday, October 10, 2018 11:38 AM
  • I checked and i saw that update kb2919355 installed on the 2 servers




    • Edited by Yanwal Wednesday, October 10, 2018 1:05 PM
    Wednesday, October 10, 2018 12:23 PM
  • Both servers have been updated.

    it didn't help.

    on the 2nd server i run (as admin) powershell with this command - 

    Invoke-DhcpServerv4FailoverReplication

    it didn't help

    any suggestions ?

    Thursday, October 11, 2018 8:13 AM
  • Do you still receive the same errors? Can you link the errors you're still receiving?

    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, October 11, 2018 9:21 AM
  • A BINDING-ACK message with transaction id: 2817 was received for IP address: 10.80.1.66 with reject reason:  (Reject Reason Unknown ) from partner server: dc02.XXXXX.local for failover relationship: dc01.XXXXX.local-dc02.XXXXX.local.
    Thursday, October 11, 2018 9:30 AM
  • Did you do this?

    Note Before you install this update, you have to first remove the failover relationship, install the update to both DHCP nodes and restart them, and then reestablish the failover relationship.”


    Blog: https://thesystemcenterblog.com LinkedIn:


    • Edited by Leon Laude Thursday, October 11, 2018 9:36 AM
    Thursday, October 11, 2018 9:36 AM
  • in the event viewer , i also recieve this error - IP address range of scope 10.80.1.0 is out of IP addresses.

    however, i see that i have plenty of ip addresses and it's not full.

    Thursday, October 11, 2018 9:36 AM
  • Anyone ? i'm sure someone had this problem before...
    Sunday, October 21, 2018 7:39 AM
  • How many addresses do you have free exactly? You could also try increasing the number of IP addresses / scope (I suppose you have an exclusion range) or decrease the lease duration.



    Blog: https://thesystemcenterblog.com LinkedIn:

    Sunday, October 21, 2018 10:53 AM
  • every scope is between 10.80.X.2-10.80.X.253

    and either of scopes is full

    basically they are far from being full. every scope has between 2 -10 adresses in the reservation (and the same in the address leases).

    only 10.80.1.X has about 70 addresses  

    so the scopes are far from being full.

    by the way , 10.80.4.X isn't having a blue exclamation mark . it's the default address (dhcp) that pc's get when their MAC address isn't in the reservation list of a scope.

    Sunday, October 21, 2018 12:08 PM
  • Hmm, has your DHCP server crashed at some point?

    I'm starting to wonder if this is a false positive alert.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Sunday, October 21, 2018 2:39 PM
  • i only get this message in the event viewer - 

    A BINDING-ACK message with transaction id: 2984 was received for IP address: 10.80.10.1 with reject reason:  (Reject Reason Unknown ) from partner server: dc02 for failover relationship: dc01-dc02.

    Monday, October 22, 2018 5:25 AM
  • dhcp isn't crashing
    Monday, November 5, 2018 8:08 AM
  • Did you try deleting the relationship and re-create it to see whether it helps?

    Blog: https://thesystemcenterblog.com LinkedIn:

    Monday, November 5, 2018 11:04 AM
  • yes

    i tried to recreate a new relationship between the server, but i still have the problem 

    Tuesday, November 13, 2018 8:28 AM