none
DRM upgrade error RRS feed

  • Question

  • I am using Windows 7 64-bit and IE9. I recently received a couple of blu-ray movies with a digital copy. Upon trying to install them I got a message saying I needed to upgrade the most recent version of windows media player (i already have WMP 12). After several emails back and forth with Paramount they were unable to help me with my issue and I was told it was a Microsoft issue. Here are the instructions they sent me:

    Hello,
     
    The problem you’re facing is because of issues with DRM components on your PC. To correct this issue we provide a link to Microsoft's security update page, which you can also go to directly here: http://drmlicense.one.microsoft.com/Indivsite/en/indivit.asp
    Disable ad-blocking software to ensure the page loads correctly. This page must be viewed in Internet Explorer.
     
    If doing this has no effect, you may need to remove/rename the DRM cache on your system and re-upgrade Windows Media security components. Here’s how:
    1. Verify that the Show hidden files and folders option is turned on. To do this, follow these steps:

      Windows 7
      1. Start Windows Explorer. To do this, click Start, type userinit.exe in the Start Search box, and then press ENTER.
      2. Click Organize, and then click Folder and Search Options.
      3. Click the View tab.
      4. Click the option beside SHOW HIDDEN FILES AND FOLDERS - click Apply - click OK

    2. Locate the DRM folder on the computer. Typically, the DRM folder is located in the following location.
      Note In these paths, drive represents the drive on which Windows is installed.
    Windows 7
    o    Windows 7 x86-based versions
    drive:\ProgramData\Microsoft\Windows\DRM
    o    Windows 7 x64-based versions
    drive:\ProgramData\Microsoft\Windows\DRM

                            Rename the DRM folder to DRMbackup.
      1. Right-click the DRM folder, and then click Rename.
      2. Type DRMbackup, and then press ENTER.
      3. Close Windows Explorer.
                            If you receive an “Access denied” error message when you try to rename your DRM folder, start the computer in safe mode and log in as the computer administrator. To do this, follow these steps:
      1. Restart the computer and start pressing the F8 key on your keyboard. On a computer that is configured to start multiple operating systems, press the F8 key when the Boot menu appears.
      2. Select the safe mode option when the Windows Advanced Options menu appears, and then press ENTER.
                            Reset the DRM security component. To do this, visit the following Microsoft Web site, and then follow the steps to upgrade the DRM security component:
    http://go.microsoft.com/FWLink?LinkID=34506
    Note When you access this site through Internet Explorer on a Windows 7-based computer, you may receive a "user account control" popup message that requires that you enter the administrator password to continue.
    NoteIf you are running Windows 7 x64 and the Upgrade button on the site listed earlier in this step appears dimmed, you will have to start Internet Explorer by using an account on the computer that has Administrative privileges in order to continue.
                            Please go to the Digital Copy web page again, select “Transfer to Windows Media Player” and follow further instructions in case of Digital Download. In case you have a Digital Copy disc, please insert the disc and select transfer to Windows Media Player.

                            Restore the setting of the Hidden files and folders option. To do this, follow these steps:
                            Windows 7
      1. Start Windows Explorer. To do this, click Start, type userinit.exe in the Start Search box, and then press ENTER.
      2. Click Organize, and then click Folder and Search Options.
      3. Click the View tab.
      4. Click Advanced Settings.
      5. Under Hidden files and folders, click Do not show hidden files and folders, click to select the Hide Protected Operating System files (recommended) check box, and then click OK.


    Please reply back to us and let us know in case of further issues!

    Thanks!
    DIGITAL COPY SUPPORT

    I tried everything they suggested, but when I went to IE, the upgrade button was grayed out. They suggested this:

    Hello,
     
    If you are using Windows Vista or Windows 7 and the Upgrade button is not active when you go to the security update page at http://drmlicense.one.microsoft.com/Indivsite/en/indivit.aspyou may also need to disable protected mode in Internet Explorer to get the page to load correctly. Here's how:
     
    1.    Launch Internet Explorer.
    2.    Select Tools from the top menu, and click Internet Options.
    3.    In the panel that pops up, select the Security tab.
    4.    Uncheck the option for “Enable Protected Mode (requires restarting Internet Explorer)”
    5.    Click Apply, OK, and close the Internet Explorer browser.
    6.    Restart Internet Explorer and go to the address http://drmlicense.one.microsoft.com/Indivsite/en/indivit.asp
    7.    The Upgrade button should now be operational.
     
    Thanks!
    DIGITAL COPY SUPPORT

    the upgrade button was not operational when I tried their suggestion. After emailing them back another time they told me that it was a Microsoft issue.

    any ideas on what I might be able to do?

    Thanks


    Wednesday, January 16, 2013 10:31 PM

All replies

  • Hi,

    Use the x86 version of IE, not the x64 version.... which does not support x86 activeX controls (see next answer)

    or

    Tools>Internet Options>Security tab, click "Reset all zones to default"...

    you must have "Active Scripting" or "Scripting of ActiveX controls" disabled in your Internet zone... the web page uses scripting and ActiveX control scripting to determine which version of media player you have installed.

    or

    You are using another browser..... you must use an MSIE browser... FX or Chrome will not work on that page.


    Rob^_^

    Thursday, January 17, 2013 5:39 AM
  • I tried downloading and installing the x86 version of IE, but I got the error message "This version of setup doesn't support your Windows system type (32bit/64bit)"I

    I disabled Active X scripting in the IE security section, but the button is still grayed out and I get the error message "Internet Explorer blocked an ActiveX control, so this page might not display correctly.

    And I am using IE9.

    Thursday, January 17, 2013 11:39 PM
  • http://answers.microsoft.com/en-us/windows/forum/windows_7-pictures/windows-media-player-12-drm-security-upgrade-2501/f0836f8b-d81e-417f-a797-5c87dc2a1eed

    I was able to get mine to work following the steps in this link. I was not allowed to paste the link sorry.

    Tuesday, August 6, 2013 6:24 PM