locked
Ligatures in Internet Explorer RRS feed

  • Question

  • Hello, we are working on an icon font that will have an ultimate collection of glyphs and will be available for free (you can see the preview at http://logotwist.com )

    We think that the easiest way to use it is through ligatures and not through elaborate CSS just like many other projects do. The problem is that it doesn't seem that the ligatures do not seem to work in Internet Explorer. They do work just fine in Chrome, Firefox and Safari, but not in IE.

    That is a shame, since it is Microsoft who was the first to use @font-face but for some reason they forget that fonts may have ligatures. Or maybe I am mistaken and I hope I am mistaken and there is some magic way to make them work. I would be very grateful for any advice on this subject. Or if there is no direct solution, maybe you know some workaround. Thank you for any information in advance!


    Thursday, January 3, 2013 6:27 PM

Answers

  • Hi,

    they appear to work on my Win7/IE10 (Document Mode IE8 (Default))....

    see screen shots below

    Preview screen shot

    Dev tools trace styles

    check your IE settings...

    Internet Options>General tab, 'Accessibility' button, uncheck "Ignore font styles specified on web pages"..... user preferences over-ride web page style rules.

    Do you have Adobe Creative Suite installed on your machine? What IDE are you using to compile the fonts? Do you have any Helvical fonts installed on your machine?

    Helvetica fonts are Apple Proprietary (I am not sure of the legalities).... but if you install them on a Wintel machine, IE will not display them (you have a font-families rule for the <body> element.... "Helvetica Neue", Helvetica, Arial, sans-serif)

    to avoid the issue on your production environment, do not specify font-family rules in your css... browsers will fall back to their user chosen defaults.... Uninstall them from your testing machine to mimic the environment that Bob and Betty users will be using on wintel machines.

    for questions about html, css and scripting please post to the IE Web Development forum...

    http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads

    to contact MS directly please see support.microsoft.com for your local subsidiary... these are public peer to peer forums... we do not work for nor represent MS.

    Regards.


    Rob^_^

    Friday, January 4, 2013 1:50 AM
  • Hi,


    It is better to ask this issue in Web Development forum to check the code about this website:

    http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads


    Regards,


    Vincent Wang
    TechNet Community Support

    Monday, January 7, 2013 3:24 AM

All replies

  • Hi,

    they appear to work on my Win7/IE10 (Document Mode IE8 (Default))....

    see screen shots below

    Preview screen shot

    Dev tools trace styles

    check your IE settings...

    Internet Options>General tab, 'Accessibility' button, uncheck "Ignore font styles specified on web pages"..... user preferences over-ride web page style rules.

    Do you have Adobe Creative Suite installed on your machine? What IDE are you using to compile the fonts? Do you have any Helvical fonts installed on your machine?

    Helvetica fonts are Apple Proprietary (I am not sure of the legalities).... but if you install them on a Wintel machine, IE will not display them (you have a font-families rule for the <body> element.... "Helvetica Neue", Helvetica, Arial, sans-serif)

    to avoid the issue on your production environment, do not specify font-family rules in your css... browsers will fall back to their user chosen defaults.... Uninstall them from your testing machine to mimic the environment that Bob and Betty users will be using on wintel machines.

    for questions about html, css and scripting please post to the IE Web Development forum...

    http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads

    to contact MS directly please see support.microsoft.com for your local subsidiary... these are public peer to peer forums... we do not work for nor represent MS.

    Regards.


    Rob^_^

    Friday, January 4, 2013 1:49 AM
  • Hi,

    they appear to work on my Win7/IE10 (Document Mode IE8 (Default))....

    see screen shots below

    Preview screen shot

    Dev tools trace styles

    check your IE settings...

    Internet Options>General tab, 'Accessibility' button, uncheck "Ignore font styles specified on web pages"..... user preferences over-ride web page style rules.

    Do you have Adobe Creative Suite installed on your machine? What IDE are you using to compile the fonts? Do you have any Helvical fonts installed on your machine?

    Helvetica fonts are Apple Proprietary (I am not sure of the legalities).... but if you install them on a Wintel machine, IE will not display them (you have a font-families rule for the <body> element.... "Helvetica Neue", Helvetica, Arial, sans-serif)

    to avoid the issue on your production environment, do not specify font-family rules in your css... browsers will fall back to their user chosen defaults.... Uninstall them from your testing machine to mimic the environment that Bob and Betty users will be using on wintel machines.

    for questions about html, css and scripting please post to the IE Web Development forum...

    http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads

    to contact MS directly please see support.microsoft.com for your local subsidiary... these are public peer to peer forums... we do not work for nor represent MS.

    Regards.


    Rob^_^

    Friday, January 4, 2013 1:50 AM
  • Hi,


    It is better to ask this issue in Web Development forum to check the code about this website:

    http://social.msdn.microsoft.com/Forums/en-US/iewebdevelopment/threads


    Regards,


    Vincent Wang
    TechNet Community Support

    Monday, January 7, 2013 3:24 AM
  • see also the MS typography site...

    http://www.microsoft.com/typography/fonts/


    Rob^_^

    Monday, January 7, 2013 4:06 AM