none
Hybrid Receive Connector

    Question

  • Hi Guys and Girls

    i need to set a receive connector on our edge server so that we can receive emails from our 365 mailbox (this is because all mail needs to route through our on prem)

    what is the command to set the is up as i do not know Microsoft IP/ server names that the O365 emails will be coming form?

    new-ReceiveConnector -name <name>

    Thank you in advance

    Monday, April 18, 2016 9:28 AM

All replies

  • Monday, April 18, 2016 12:53 PM
  • Have done that, but the only thing it says it can not do is set up the receive connector on the edge server
    Monday, April 18, 2016 12:56 PM
  • What 2013 CU is this? Download and install the Hybrid Wizard. It should prompt you to use the Edge.

    See:

    http://exchangeserverpro.com/creating-hybrid-configuration-exchange-office-365/


    Blog:    Twitter:   

    Monday, April 18, 2016 1:12 PM
  • Its  Exchange Server 2013 Cumulative Update 12 (CU12)

    gone through the wizard and all online articles ,and nothing refers to the receive connector. It saying it can not  configure the receive connector. Because there is no default front end one

    The configuring of it is not the issue, its creating a new one, with all of MS ip ranges ect...


    Monday, April 18, 2016 1:51 PM
  • Well, like I said, you shouldnt have to do that manually. But if you have no choice, 

    the IPs you need to allow are listed here

    https://technet.microsoft.com/library/dn163583(v=exchg.150).aspx

    The receive connector should have a valid cert enabled for SMTP that matches the FQDN advertised on it, with a  corresponding outbound connector at EOP that validates the FQDN you have set.

    Make sure you have the TLS settings set correctly:

    https://support.microsoft.com/en-us/kb/3145044?sd=rss&spid=16662

    $rc=Get-ReceiveConnector |where {$_.TlsDomainCapabilities -like "*<I>*" -or $_.TlsDomainCapabilities -like "*[I]*"} 
    $rc | foreach {Set-ReceiveConnector -Identity $_.identity -TlsDomainCapabilities "mail.protection.outlook.com:AcceptCloudServicesMail”}


    Blog:    Twitter:   

    Monday, April 18, 2016 2:09 PM
  • Hi yeah that bit is fin configuring it. do you know what bindings i would have to o to set it up?
    Monday, April 18, 2016 2:26 PM
  • Hi yeah that bit is fin configuring it. do you know what bindings i would have to o to set it up?

    For the IP of the Exchange Server, port 25. Is that what you referring to?


    Blog:    Twitter:   

    Monday, April 18, 2016 2:37 PM
  • Hi,

    If you deploy hybrid with Edge server, the send/receive connectors between Office 365 and the on-premises organization are auto created on the Edge server after run HCW. You can view your hybrid connectors on  the Connectors page in the EAC.

    Here's a link about steps to setup connector between Exchange server with Office 365 and Edge server within hybrid deployments:
    https://technet.microsoft.com/en-us/library/dn751020(v=exchg.150).aspx
    https://technet.microsoft.com/en-us/library/hh134662(v=exchg.150).aspx


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Tuesday, April 19, 2016 8:29 AM
    Moderator
  • Hi thanks both

    yes the wizard should do it its self. But it has not. it has said that i have to do it manually

    however we need to set a new one in order to configure

    What i want to know is how do i set up a new one so far i have

    New-ReceiveConnector -Name "Inbound From Office 365" -Bindings ??.??.??.??:25 -Fqdn "the 365 fqdn?" -RemoteIPRanges "list of ms ip ranges"

    Thanks

    Tuesday, April 19, 2016 10:27 AM
  • Hi thanks both

    yes the wizard should do it its self. But it has not. it has said that i have to do it manually

    however we need to set a new one in order to configure

    What i want to know is how do i set up a new one so far i have

    New-ReceiveConnector -Name "Inbound From Office 365" -Bindings ??.??.??.??:25 -Fqdn "the 365 fqdn?" -RemoteIPRanges "list of ms ip ranges"

    Thanks

    New-ReceiveConnector -Name "Inbound From Office 365" -Bindings <IP of Edge Server:25> -Fqdn <FQDN of Edge Server or your namespace with Certificate in Subject Name> -RemoteIPRanges "list of ms ip ranges" -TlsDomainCapabilities "mail.protection.outlook.com:AcceptCloudServicesMail”


    Blog:    Twitter:   



    Tuesday, April 19, 2016 10:48 AM
  • Brilliant Thank you. i shall give that a go shortly, and let you know the outcome :)

    Thank you

    Tuesday, April 19, 2016 11:01 AM
  • Cheers but how do i add multiple ip ranges in there have tried both

    -RemoteIPRanges "216.32.180.0/24,216.32.181.0/24"

    and

    -RemoteIPRanges "23.103.132.0-23.103.135.255,23.103.136.0-23.103.143.255"

     but neither way it can work

    or am i being really thick

    Wednesday, April 20, 2016 10:14 AM
  • Commas between IP addresses.

    216.32.180.0/24, 216.32.181.0/24

    No need for commas, if you do use them its:

    "216.32.180.0/24", "216.32.181.0/24"


    Blog:    Twitter:   

    Wednesday, April 20, 2016 11:22 AM
  • Sweet. That worked a treat. However im still unable to validate the re3ceive connector from O365 or the HCW still not picking it up.

    Do i need to add other settings to it?

    Friday, April 22, 2016 8:11 AM
  • Sweet. That worked a treat. However im still unable to validate the re3ceive connector from O365 or the HCW still not picking it up.

    Do i need to add other settings to it?

    Why wont it validate? What is the failure? Ensure you have port 25 allowed to the servers inbound on the firewall from those IPs

    Blog:    Twitter:   

    Friday, April 22, 2016 11:04 AM