locked
SP2 RU6 - Can not delete emails with attachments RRS feed

  • Question

  • Hey guys,

    Since installing RU6 for Exchange 2010, service pack2, last week, we have an issue where we can not delete some emails with attachments.  If you try to delete them you get an "unknown error".  Shift-delete will remove the message.  Has anyone come across this and have a fix for it?

    Thank you.


    -Kevin


    • Edited by BestBet Monday, February 25, 2013 2:59 PM
    Monday, February 25, 2013 2:53 PM

Answers

  • Update (3/27/2013): We've been working on a fix for this issue and an Interim Update (IU) is now available for E2010 SP3. Another IU request is in process for E2010 SP2. These fixes will be released as part of next regular updates but if you need the IUs, please contact Microsoft Support to request appropriate fixes for your setup. KB article (KB:2822208) update is also in process.

    -------------------------------------

    (Originally posted on 3/19/2013)
    This is a known issue with Exchange 2010 SP2 RU6 & SP3. Microsoft is investigating it for root cause determination. At this moment, there is no ETA for when a fix will be available. A KB article has been published with more info and workarounds. It will be updated when more information is available. Please see:

    Unable to soft delete some messages after installing Exchange 2010 SP2 RU6 or SP3
    http://support.microsoft.com/kb/2822208


    Sr. Program Manager, Product Quality, Exchange Client Access Server


    Tuesday, March 19, 2013 5:22 PM
  • Guys,

    Problem resolved.  I uninstall RU6 off of all of my servers over night and this fixed both of my issues.  The people that could not delete the messages, can now all delete those problem messages.  Also, the issue with the Sent Items not being viewable is also fixed.  You have to start outlook with the /cleanviews switch and that resets all the views.   

    RU6 uninstalls cleanly and takes about 10 minutes to remove plus a reboot.  I would suggest everyone roll back.

    Ktaber and R_C_3 -2  -  2 of my clients could not delete pdf attachments received from the scanner.  Uninstalling RU6 fixed this issue for both of them.

    Thanks,
    Kevin


    -Kevin

    • Marked as answer by BestBet Thursday, February 28, 2013 3:14 PM
    Thursday, February 28, 2013 3:13 PM

All replies

  • reset your EWS Virtual Directory from Exchange management Console ( don't do changes from IIS ), if need change URL/Authentication from Exchange PowerShell  . once it's finished , reset IIS

    may need to Enable Silverlight

    Set-OwaVirtualDirectory -Identity "CAS Servers\owa (Default Web Site)" -SilverlightEnabled $False

    Monday, February 25, 2013 3:13 PM
  • Is Outlook in cache or online mode? How about from OWA? I've seen some reports of this and wonder if its related to the fix:

    http://support.microsoft.com/kb/2783633

    You cannot move or delete an email message that is larger than the maximum receive or send size in an Exchange Server 2010 environment

    Regardless, you may want to open a case with Microsoft.


    Twitter!:

    Monday, February 25, 2013 3:15 PM
  • I am on the phone with Microsoft support right now.  I will update you with the fix when I am done.

    Thanks,

    Kevin


    -Kevin

    Monday, February 25, 2013 3:34 PM
  • I am in online mode with outlook.  I can not delete it in OWA either.  It does delete if in cached mode but I am not going to change thousands of clients. 


    -Kevin

    Monday, February 25, 2013 4:06 PM
  • Hi

    Any solution from phone support?

    Cheers


    Zi Feng
    TechNet Community Support

    Tuesday, February 26, 2013 7:05 AM
  • 6 1/2 hours on the phone yesterday and problem still exists.  It appears to be mailbox corruption.  Microsoft support is calling me back this morning to continue troubleshooting.  I will update this thread when I know more.

    Thank you.


    -Kevin

    Tuesday, February 26, 2013 1:56 PM
  • Another 4 1/2 hours on the phone with second level support yesterday and still no resolution.  Being escalated to the next level which I am told is the Exchange development team.  The issue affects only some people and they are different kinds of emails.  One is voicemail (.wav) attachments, one is pdf attachments and then I have another person who can not delete a simple message recall email.  I hope to have a fix soon before this becomes a bigger problem for me.

    Kevin


    -Kevin

    Wednesday, February 27, 2013 1:54 PM
  • Microsoft support just called back to say they have other clients with the same issue.  There recommendation is to uninstall the update.  I will be uninstalling tomorrow morning and will let you know if this does fix this issue.

    Thanks,

    Kevin


    -Kevin

    Wednesday, February 27, 2013 5:31 PM
  • Sleighbor, I am having a similar issue but I am not certain it is the same as yours. 

    I do not know when it started, but it is happening now and we are on RU6.

    I do know it (so far) has only happened to PDF scan e-mails from our Konica-Minolta MFP's. 
    These Konica e-mails are sent with no body. If I open, edit, add text to the body, and save the e-mail, I can then delete it as normal. If I configure the MFP's to send e-mails with text in the body, I can delete the e-mails as normal.

    Does that sound like it could be your issue, or something else?

    Wednesday, February 27, 2013 10:03 PM
  • Our Konica sent PDF attachments are un-deletable by only a few users. It is very strange. There is also a company that emails us PDF invoices and those emails cannot be deleted either.

    The only work around so far is to Shift+Delete the messages.

    PDF attachment properties of one that cannot be deleted by just a handful of users. (Some can delete them):

    • Edited by ktaber Thursday, February 28, 2013 2:57 PM added photo
    Thursday, February 28, 2013 2:38 PM
  • Guys,

    Problem resolved.  I uninstall RU6 off of all of my servers over night and this fixed both of my issues.  The people that could not delete the messages, can now all delete those problem messages.  Also, the issue with the Sent Items not being viewable is also fixed.  You have to start outlook with the /cleanviews switch and that resets all the views.   

    RU6 uninstalls cleanly and takes about 10 minutes to remove plus a reboot.  I would suggest everyone roll back.

    Ktaber and R_C_3 -2  -  2 of my clients could not delete pdf attachments received from the scanner.  Uninstalling RU6 fixed this issue for both of them.

    Thanks,
    Kevin


    -Kevin

    • Marked as answer by BestBet Thursday, February 28, 2013 3:14 PM
    Thursday, February 28, 2013 3:13 PM
  • Same issue with 2010 SP3 too it seems:

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/d47965ef-c103-4953-8e57-7af455d1c7c7



    Jason Sherry | Blog | Hire Me | Twitter: @JasonSherry
    Microsoft Infrastructure Architect, MCSE: M, MCTIP, Microsoft Exchange MVP


    • Edited by Jason Sherry Thursday, February 28, 2013 8:25 PM
    Thursday, February 28, 2013 8:23 PM
  • Correct, I installed SP3 hoping that would solve the issue and it did not.

    For my organization I will keep using SP3, and instructed that for emails not wanting to delete...use Shift+Delete.

    Thursday, February 28, 2013 8:33 PM
  • yes we are experiencing it too. remove RU6 and it works fine. remember the server goes straight into uninstall and reboots you cant stop that. also setting outlook in cache mode fixes it. seen this happening with outlook 2013 and once it happens user cant delete the email from owa/another pc with diff outlook version. tho someone with admin access can open the user's mailbox n delete it.
    Thursday, February 28, 2013 10:14 PM
  • Hi Martin,

    I saw this problem with deleting messages happen in all versions of outlook and as an admin I could not delete these message from the users mailbox either, through outlook or owa.

    -Kevin


    -Kevin

    Friday, March 1, 2013 1:48 PM
  • oh ok. i was able to open the user's mailbox with my outlook 2010. i have domain admin privilege and was able to delete.
    Monday, March 4, 2013 5:46 AM
  • Just wanted to plan my upgrade and now this mess again! We are in an production environment, not on a playground!
    Monday, March 4, 2013 6:22 AM
  • Same here planning to upgrade to SP3 but now can not do it.

    Raman

    Tuesday, March 5, 2013 2:29 PM
  • Any update from Micorsoft?   It seems this isn't an isolated incident.  Can someone from Microsoft clarify?  There is a critical security fix in this patch, so we can't wait for too long. 
    • Edited by AndyHWC Thursday, March 7, 2013 8:27 PM
    Thursday, March 7, 2013 8:27 PM
  • Hi Kevin,

    Thanks for posting this. I have a client who has the same problem and the user reported the problem started about the same time Exchange 2010 RU6 was installed.

    I want to take your advice and uninstall RU6 but alittle nervous that this might cause issues with something else after the uninstall.

    You mentioned that you had to run Outlook with /cleanviews switch. Did you have to do this with all user's or only ones that were affected? My client is a 150 seat users site so hence why I'm alittle nervous as I don't want to see us getting bombarded with calls the next morning that's all.....

    Would be really interested in hearing your feedback on this.

    Thanks,

    Binh

    Thursday, March 14, 2013 2:31 AM
  • @Binh You don't need to uninstall it. Just tell the users to Shift+Delete the item. That is it..no need to run any speacial switches.

    Also, it only affects certain mailboxes. And of those few, it only seems to happen to a specific type of PDF attachment or sometimes WAV attachments.

    The updates included in RU6 or SP3 are worth installing.

    -Kevin

    • Edited by ktaber Thursday, March 14, 2013 2:36 AM
    Thursday, March 14, 2013 2:34 AM
  • Some users might experience issues after deploying SP3 or Exchange 2010 sp2 RU6

    a - Cannot delete voice mails

    b - Cannot Delete emails with PDF attachments

    c - you might experience the issues with calendar items too

    work around :

    - Shift+Delete should work

    - move these messages to another folder and sfot delete should work.

    - I'll update this thread once we have the resoultion or Fix   

    Monday, March 18, 2013 3:49 PM
  • And you can monitor this KB

    Unable to soft delete some messages after installing Exchange 2010 SP2 RU6 or SP3

    http://support.microsoft.com/kb/2822208


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Monday, March 18, 2013 3:56 PM
  • @Binh You don't need to uninstall it. Just tell the users to Shift+Delete the item. That is it..no need to run any speacial switches.

    Also, it only affects certain mailboxes. And of those few, it only seems to happen to a specific type of PDF attachment or sometimes WAV attachments.

    The updates included in RU6 or SP3 are worth installing.

    -Kevin

    Hi ktaber,

    Thanks for your reply but unfortunately the issue also happens with the new tries to MOVE the email to another folder for filing. Unfortunately the user doesn't want to delete these emails.

    The only workaround right now is for the user to edit the email, save it then she can move it to another folder without the error.

    Monday, March 18, 2013 9:08 PM
  • @Manju-MSFT,

    The problem I have is the user can't move the email to another folder as it also produces the same email.  So in our client's case, the error happens when she tries to delete it or move it to another folder (even drag and drop to the Deleted Items folder also produces the same message).

    Monday, March 18, 2013 9:10 PM
  • Some users might experience issues after deploying SP3 or Exchange 2010 sp2 RU6

    a - Cannot delete voice mails

    b - Cannot Delete emails with PDF attachments

    c - you might experience the issues with calendar items too

    work around :

    - Shift+Delete should work

    - move these messages to another folder and sfot delete should work.

    - I'll update this thread once we have the resoultion or Fix   

    Any estimate on when a fix will be released? 

    Those who are affected by this problem.  How widespread is the problem?

    thanks

    Tuesday, March 19, 2013 3:23 PM
  • Update (3/27/2013): We've been working on a fix for this issue and an Interim Update (IU) is now available for E2010 SP3. Another IU request is in process for E2010 SP2. These fixes will be released as part of next regular updates but if you need the IUs, please contact Microsoft Support to request appropriate fixes for your setup. KB article (KB:2822208) update is also in process.

    -------------------------------------

    (Originally posted on 3/19/2013)
    This is a known issue with Exchange 2010 SP2 RU6 & SP3. Microsoft is investigating it for root cause determination. At this moment, there is no ETA for when a fix will be available. A KB article has been published with more info and workarounds. It will be updated when more information is available. Please see:

    Unable to soft delete some messages after installing Exchange 2010 SP2 RU6 or SP3
    http://support.microsoft.com/kb/2822208


    Sr. Program Manager, Product Quality, Exchange Client Access Server


    Tuesday, March 19, 2013 5:22 PM
  • This is a known issue with Exchange 2010 SP2 RU6 & SP3. Microsoft is investigating it for root cause determination. At this moment, there is no ETA for when a fix will be available. A KB article has been published with more info and workarounds. It will be updated when more information is available. Please see:

    Unable to soft delete some messages after installing Exchange 2010 SP2 RU6 or SP3
    http://support.microsoft.com/kb/2822208


    Sr. Program Manager, Product Quality, Exchange Client Access Server

    Does the issue affect just CAS servers?  

    If the problem affect us, should we uninstall the patch from all Exchange roles (MBX, CAS and HT)? 

    Wednesday, March 20, 2013 1:14 PM
  • @superfishnz,

    Yes, I am aware of this issue too . You cannot move , drag and drop, items ( like calendar items, email messages using Information Rights  ) to another folder. if you try to move they still produce the same error message as if the messages are already manipualted.

    @AndyHWC

    I do not recommend uninstall of the patch. but it is one of the options, Uninstall will fix the problem.

    -Manju 

    Friday, March 29, 2013 6:26 PM
  • @superfishnz,

    Yes, I am aware of this issue too . You cannot move , drag and drop, items ( like calendar items, email messages using Information Rights  ) to another folder. if you try to move they still produce the same error message as if the messages are already manipualted.

    @AndyHWC

    I do not recommend uninstall of the patch. but it is one of the options, Uninstall will fix the problem.

    -Manju 

    Manju,

    In our environment (upgraded from SP2 to SP3) we are seeing this issue but it appears to only be with encrypted messages. This is a known issue as well?

    Thanks,

    Brandon

    Tuesday, April 16, 2013 4:50 PM
  • Hello, are there any news about this bug ? we got still RU4 because of these circumstances,

    Monday, May 27, 2013 5:42 AM
  • Exchange 2010 SP3 RU1 has been released.  Details and download here:

    http://blogs.technet.com/b/rmilne/archive/2013/05/30/exchange-2010-sp3-ru1-released.aspx

    Please do update this thread with results and findings.


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    • Proposed as answer by Mike Crowley Thursday, May 30, 2013 11:56 PM
    Thursday, May 30, 2013 1:20 PM