locked
Problem switching active foreground application RRS feed

  • Question

  • I am working with several Windows 7 computers that intermittently have this issue. When attempting to switch the foreground application by clicking on it in the task bar, nothing happens. If I hover over the icon of the opened application, it should show a preview (or at least the title bar name if Aero effects are off), but it appears for a split second and then vanishes. I run into a similar problem if I try to switch the active window via Alt+Tab. The switching interface appears briefly but then disappears before I let go of Alt.

    If this were happening to a single computer I would suspect a driver issue. But the computers are all different models of Dell desktops ranging from 4 years old to brand new.

    EDIT:

    The issue seems to be more consistently triggered if I run an application that is incompatible with Aero and forces Windows to use a Basic theme. At that point, whether or not I close that application and Aero comes back, the task switching issue will most likely have begun.

    The models of computers being used are Dell Optiplex 7010, Dell Precision T1700, Dell Precision 3420/3620.

    • Edited by mberemand Thursday, August 10, 2017 1:08 PM more info
    Tuesday, August 8, 2017 4:57 PM

All replies

  • Hi,

    Have you tried to disable Aero in Windows 7 to check the results? Please also test this issue by creating new user account on your PC and let me know the results.

    I tried in my environment, My test virtual machine and my personal Lenovo computer have no such issue.

    Please first make sure that all updates including Windows and Drivers from Manufacturer's have been installed.

    See if there is any error in Event view related to this issue, if so, copy detailed and post back here for our research.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 9, 2017 3:06 AM
  • Yes, I have tried this with Aero disabled and the same problem occurs. I don't see any relevant errors in the Event Viewer. I will work on updating drivers for one of the systems today, but as I stated before, I highly doubt drivers are the cause since systems with a wide range of hardware all exhibit the same behavior.

    I'm also going to see if the behavior can be replicated in Safe Mode.

    Wednesday, August 9, 2017 1:14 PM
  • That's ok, just let me know if there is any update on your test results. 

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 10, 2017 2:45 AM
  • Updating the drivers and BIOS did not make a difference. With a little more finagling I figured out the quick disappearance of the window previews can be fixed by clicking on a blank part of the task bar first to bring it into focus. Even so, I still can't switch between tasks; left clicking on the application I want to bring to the foreground does nothing and Alt+Tab still fails.

    The issue seems to be more consistently triggered if I run an application that is incompatible with Aero and forces Windows to use a Basic theme. At that point, whether or not I close that application and Aero comes back, the task switching issue will most likely have begun.

    The models of computers being used are Dell Optiplex 7010, Dell Precision T1700, Dell Precision 3420/3620.

    Thursday, August 10, 2017 1:07 PM
  • I could not replicate the issue in Safe Mode. Before anyone suggests "disable services one at a time in msconfig", these are about as vanilla of Windows 7 installations as they come.
    Wednesday, August 16, 2017 5:32 PM
  • Hi,

    "The issue seems to be more consistently triggered if I run an application that is incompatible with Aero and forces Windows to use a Basic theme. At that point, whether or not I close that application and Aero comes back, the task switching issue will most likely have begun."

    As you mentioned, that's could be the issue, the incompatible application cause this issue. And also Safe mode work fine, that indicates system core has no such issue.

    What about if this issue happen and then you try to restart Explorer.exe in Task manager? If it can work again, you can create to one-click batch file to restart explorer.exe as workaround on your PC.

    Create .bat file with following contents:

    @echo off
     taskkill /f /im explorer.exe
     start explorer.exe


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, August 24, 2017 10:15 AM
  • The Aero-incompatible application is being run on several dozen other Windows 7 computers without issue. I just mentioned it because I think the switch from Aero to Basic and back again can trigger the issue, not the application itself.

    I will see if simply killing and restarting the explorer process is enough to get around the issue, but I would still like to figure out the root cause.

    Friday, August 25, 2017 11:40 AM
  • Hi,

    The different hardware or driver can also be the cause even the same application works on same OS.  


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, August 28, 2017 3:07 AM