locked
xp desktop wallpaper off center to right and bottom RRS feed

  • Question

  • I'm using Windows XP and have one account on my computer.  The desktop became off-center a couple months ago and I can't fix it.

     

    Here's an example of what's going on:

     

     

     

    It's sort of like the center of the screen moved.  Or like XP thinks I have a big virtual desktop that's bigger than my real desktop.  But it doesn't affect icons or windows or the mouse.  Just the desktop wallpaper.  Strangely, video backgrounds  work fine and fill the screen normally.   I tried a couple new video drivers and that didn't fix anything either.

     

    My screen is a 1280x1024 LCD, and my display adapter is an Radeon x300.

    By the way, I copied most of this post from someone having troubles with Vista doing this, but the fix in the registry called to change the wallpaper origin for x and y to zero, but my xp registry does not have that option. I tried all display properties, and options on the monitor, but i cannot fix this, and it bothers me.
    Any ideas?

     

     

    Tuesday, August 11, 2009 3:26 AM

All replies

  • I notice you have double-posted and I have replied to this one.

    As you don’t have the two registry keys mentioned in the other thread, try creating them:

    Click the Windows Orb (Start), type regedit, press Enter and navigate to HKEY_CURRENT_USER\Control Panel\Desktop and right-click in the right pane > New > DWORD, type the name WallpaperOriginX and press Enter. Double-click the name and give it a value of 0 (zero).

    Repeat the procedure for WallpaperOriginY, close regedit and restart the computer.

    Wednesday, August 12, 2009 6:21 PM
  • I tried this, and it did not work. The wallpaper did not move. Any other ideas?
    Thursday, August 13, 2009 11:16 PM
  • I've had this same problem, and I have come to the same conclusions as goyzzo: "XP thinks I have a big virtual desktop that's bigger than my real desktop."


    But the difference on mine is, I've noticed that the quality of the photo decreases and is stretched out a bit front the view on my desktop.

    Please, if anyone has a solution!
    Monday, October 19, 2009 7:04 AM
  • Try uninstalling IE8.
    Monday, October 26, 2009 12:01 PM
  • I had a Dell Desktop PC with same problem after a microsoft update.  Here is the fix:

    Right Click on the desktop display

    Choose Arrange Icons By

    Uncheck Lock Web items on Desktop

    Hope this works for you.
    • Edited by Echocliffs Sunday, December 27, 2009 11:30 PM had to delete a step that wasn't necessary
    • Proposed as answer by ShelleBelle99 Friday, January 22, 2010 3:32 PM
    Sunday, December 27, 2009 11:29 PM
  • Echocliffs is right on!!!  That's the cure!  Thanks!
    Friday, January 22, 2010 3:29 PM
  • See Echocliffs suggestion!  I have IE8 and you don't need to uninstall it!
    Friday, January 22, 2010 3:31 PM
  • Tried both options and mine is still off centered. Any other suggestions out there besides a fresh install?
    Friday, January 22, 2010 6:16 PM
  • I was having the same issues. None of the proffered solutions worked. Here is what worked for me.
    Open the registry (Regedit). Drill down to:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
    change HideIcons to Hex 1.

    This is not an ideal solution because you have to logoff and back on to see the changes. But it works.
    Kevin Warner
    Wednesday, March 10, 2010 5:15 PM
  • The problem is a webpage is being displayed on your desktop as an active desktop item.  To recenter the wallpaper, you have to remove it.


    Desktop Properties>Desktop>Click on "Customize Desktop"> Web tab

     

    Chances are a URL is checked here.  make sure nothing is selected on this page and click ok.  My computer thought for a bit then centered the wallpaper :)

    • Proposed as answer by C_Pritchard Thursday, May 6, 2010 9:33 AM
    Thursday, May 6, 2010 9:31 AM
  • Thank you C_Pritchard, your idea resolved my problem.
    Thursday, May 13, 2010 9:11 AM
  • That's the one.  Brilliant.  And I thought I had a virus or something equally nasty!  So... many many thanks for posting this solution.
    Monday, May 24, 2010 9:29 PM
  • AWESOME!

    :)

    An easy fix for me......stupid Lock Web items on Desktop.....

    SlelleBelle99 and
    Echocliffs

    THANK YOU!

    Tuesday, August 17, 2010 1:31 PM
  • The web lock did not work for me.  The only work around was to show desktop icons

    I copied all of the icons into a rocket docket folder as I view from that program now anyway

    then deleted the icons on the desktop and it stays centered!  the dpi can then be larger per my settings.

    Tuesday, September 7, 2010 5:52 PM
  • WindowsOriginX worked great. I also had my icons hidden and when I chose to display them, the wallpaper snapped right to the center like normal. But, when I unchecked it again, it moved right back to off-center.
    • Proposed as answer by Farhad R Monday, January 9, 2012 5:00 AM
    • Unproposed as answer by Farhad R Monday, January 9, 2012 5:00 AM
    Friday, November 26, 2010 2:33 AM
  • I tried the WallpaperOriginX & Y settings = 0 > did not work

    I tried clearing Lock Web Items on Desktop in Arrang Icons By > did not work

    I do not use IE8 so no help there

     

    Properties/Desktop/Customize Desktop/Web did show a web page checked to show on Desktop - I cleared it and it solved the problem.

     

    Big thanks to C_Pritchard

    Monday, January 9, 2012 5:06 AM
  • Sand B... You are the man.. Thank you very much I tried everything but your fix was the one.. Thanks again champ
    Saturday, January 21, 2012 2:30 AM
  • Great! It worked for me...
    Tuesday, July 24, 2012 12:46 PM
  • Hi,

    I resolved this by checking the Desktop Properties>Desktop>Click on "Customize Desktop"> Web tab.

    Got the same possitive result when I at - Right Click on the desktop display-Choose Arrange Icons By - cheched the "Lock Web items on Desktop". 

    Tried both ways checking and unchecking a couple of times to be sure. They obviously are the same and - Locking should be checked - at least for me

    This seems a bit odd to me. I have never noticed this behavior before and i cannot really understand what this really has to do with the size of the background picture and the ability to strech it to full size. Especially when locked.

     

    Monday, May 20, 2013 10:52 PM